MANUAL: FTTH Movistar/Jazztel con router neutro Mikrotik

Gracias a Malvas y a todos los que han contribuido, lo he configurado y está funcionando estupendamente.

*Quería decir "Malosa".

Por cierto, que la versión de OS es la 6.46.4


Lo siento Furny, me cambie de Movistar a O2, por lo que ya no tengo la televisión de Movistar.

Pero yo no tenia los sintomas que tu describes, nunca tube ese problema.

Como ya han pasado varios meses y alguna que otra version de RouterOs mejor que te pueda orientar algun otro usuario que lo tenga activo.
 
Lo siento Furny, me cambie de Movistar a O2, por lo que ya no tengo la televisión de Movistar.

Pero yo no tenia los sintomas que tu describes, nunca tube ese problema.

Como ya han pasado varios meses y alguna que otra version de RouterOs mejor que te pueda orientar algun otro usuario que lo tenga activo.
Gracias de todas formas, Bencio.
 
Bueno, pues al final la solución de Toniros me funciona. He tenido tiempo de ocuparme del tema y resulta que tenía un pequeño error tonto. Es verdad que cuando uno cambia de un disco a otro hay que tener un poco de paciencia y esperar los 30s del script, pero todo funciona bien. Falsa alarma. Toniros, muchas gracias por la solución.
 
Hola,

Veo con agrado que un post de hace mas de 2 años aun ayuda a alguien, actualmente he mejorado un poco el proceso y el funcionamiento es muy bueno, sin esa espera de unos segundos cuando hay cambio de deco.

Recuerdo el link original del proceso a seguir:
https://www.adslzone.net/foro/fibra...-neutro-mikrotik.311611/page-360#post-3074318

Simplemente si sustituimos el script del paso 3 por este:
Código:
/system script add dont-require-permissions=no name=vod owner=admin policy=read,write source=":local iplist [:len [/ip firewall address-list find list=\"vod-receiver\"]]\
    \n:local rules [:len [/ip firewall nat find where comment=\"VOD Script\"]]\
    \n#:log info \"VODScript: IPs in list are \$iplist !\"\
    \n#:log info \"VODScript: Rules are \$rules !\"\
    \n:if (\$iplist = 0 and \$rules > 0) do={\
    \n\t#/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t#:log info \"VODScript: Rule removed !\"\
    \n} else {\
    \n\t:local ipadressnew [/ip firewall address-list get [:pick [/ip firewall address-list find list=\"vod-receiver\"] (\$iplist-1)] address]\
    \n\t:local ipadressold \"None\"\
    \n\t#:log info \"VODScript: IP adress new is \$ipadressnew !\"\
    \n\t:if (\$iplist > 0 ) do {\
    \n\t\tif (\$rules > 0 ) do {\
    \n\t\t\t:set ipadressold [/ip firewall nat get [find comment=\"VOD Script\"] to-addresses] \
    \n\t\t\t#:log info \"VODScript: IP adress old is \$ipadressold !\"\
    \n\t\t}\
    \n\t\t:if (\$ipadressnew != \$ipadressold) do={\
    \n\t\t\tif (\$rules > 0 ) do {\
    \n\t\t\t\t/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t\t\t}\
    \n\t\t\t/ip firewall nat add action=dst-nat chain=dstnat comment=\"VOD Script\" dst-address-type=local in-interface=vlan2 to-addresses=\$ipadressnew\
    \n\t\t\t:log info \"VODScript: IP adress changed from \$ipadressold to \$ipadressnew !\"\
    \n\t\t}\
    \n\t}\
    \n}"

El script aunque mas largo es mas ligero que el original, ya que normalmente solo hace comparaciones, se puede eliminar algún comentario, para ser mas vervose, o para eliminar la regla cuando paramos el deco, pero eso ya lo dejo al gusto de cada uno.

Como que el script es más ligero, el intervalo de ejecución del paso 4, puede ser más agresivo:

Código:
/system scheduler add interval=5s name=vod on-event=vod policy=read,write start-time=startup

Un saludo a todos, y me alegro de haber ayudado.
 
Última edición:
Hola,

Veo con agrado que un post de hace mas de 2 años aun ayuda a alguien, actualmente he mejorado un poco el proceso y el funcionamiento es muy bueno, sin esa espera de unos segundos cuando hay cambio de deco.

Recuerdo el link original del proceso a seguir:
https://www.adslzone.net/foro/fibra...-neutro-mikrotik.311611/page-360#post-3074318

Simplemente si sustituimos el script del paso 3 por este:
Código:
/system script add dont-require-permissions=no name=vod owner=admin policy=read,write source=":local iplist [:len [/ip firewall address-list find list=\"vod-receiver\"]]\
    \n:local rules [:len [/ip firewall nat find where comment=\"VOD Script\"]]\
    \n#:log info \"VODScript: IPs in list are \$iplist !\"\
    \n#:log info \"VODScript: Rules are \$rules !\"\
    \n:if (\$iplist = 0 and \$rules > 0) do={\
    \n\t#/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t#:log info \"VODScript: Rule removed !\"\
    \n} else {\
    \n\t:local ipadressnew [/ip firewall address-list get [:pick [/ip firewall address-list find list=\"vod-receiver\"] (\$iplist-1)] address]\
    \n\t:local ipadressold \"None\"\
    \n\t#:log info \"VODScript: IP adress new is \$ipadressnew !\"\
    \n\t:if (\$iplist > 0 ) do {\
    \n\t\tif (\$rules > 0 ) do {\
    \n\t\t\t:set ipadressold [/ip firewall nat get [find comment=\"VOD Script\"] to-addresses] \
    \n\t\t\t#:log info \"VODScript: IP adress old is \$ipadressold !\"\
    \n\t\t}\
    \n\t\t:if (\$ipadressnew != \$ipadressold) do={\
    \n\t\t\tif (\$rules > 0 ) do {\
    \n\t\t\t\t/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t\t\t}\
    \n\t\t\t/ip firewall nat add action=dst-nat chain=dstnat comment=\"VOD Script\" dst-address-type=local in-interface=vlan2 to-addresses=\$ipadressnew\
    \n\t\t\t:log info \"VODScript: IP adress changed from \$ipadressold to \$ipadressnew !\"\
    \n\t\t}\
    \n\t}\
    \n}"

El script aunque mas largo es mas ligero que el original, ya que normalmente solo hace comparaciones, se puede eliminar algún comentario, para ser mas vervose, o para eliminar la regla cuando paramos el deco, pero eso ya lo dejo al gusto de cada uno.

Como que el script es más ligero, el intervalo de ejecución del paso 4, puede ser más agresivo:

Código:
/system scheduler add interval=5s name=vod on-event=vod policy=read,write start-time=startup

Un saludo a todos, y me alegro de haber ayudado.

Ya lo he probado Toniros, y va estupendamente, mejor que el anterior. ¡Te superas a ti mismo! Muchas gracias!

Un saludo
 
Buenas!

Algun softphone de Android que identifique el número desde el cual se le llama?

Es decir... si llamo a mi numeración fija y suena en el móvil, no me identifica la llamada, me pone 00000000 (no se cuantos 0s exactamente xD)

Es error de configuración? O según la APP identifica o no?

Tengo ONT + RB2011uias-2hnd-in con las 3 vlan y demás (me funciona la TV con el deco UHD y las llamadas también).

Muchas gracias.

Un saludo
 
Hola,

Veo con agrado que un post de hace mas de 2 años aun ayuda a alguien, actualmente he mejorado un poco el proceso y el funcionamiento es muy bueno, sin esa espera de unos segundos cuando hay cambio de deco.

Recuerdo el link original del proceso a seguir:
https://www.adslzone.net/foro/fibra...-neutro-mikrotik.311611/page-360#post-3074318

Simplemente si sustituimos el script del paso 3 por este:
Código:
/system script add dont-require-permissions=no name=vod owner=admin policy=read,write source=":local iplist [:len [/ip firewall address-list find list=\"vod-receiver\"]]\
    \n:local rules [:len [/ip firewall nat find where comment=\"VOD Script\"]]\
    \n#:log info \"VODScript: IPs in list are \$iplist !\"\
    \n#:log info \"VODScript: Rules are \$rules !\"\
    \n:if (\$iplist = 0 and \$rules > 0) do={\
    \n\t#/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t#:log info \"VODScript: Rule removed !\"\
    \n} else {\
    \n\t:local ipadressnew [/ip firewall address-list get [:pick [/ip firewall address-list find list=\"vod-receiver\"] (\$iplist-1)] address]\
    \n\t:local ipadressold \"None\"\
    \n\t#:log info \"VODScript: IP adress new is \$ipadressnew !\"\
    \n\t:if (\$iplist > 0 ) do {\
    \n\t\tif (\$rules > 0 ) do {\
    \n\t\t\t:set ipadressold [/ip firewall nat get [find comment=\"VOD Script\"] to-addresses] \
    \n\t\t\t#:log info \"VODScript: IP adress old is \$ipadressold !\"\
    \n\t\t}\
    \n\t\t:if (\$ipadressnew != \$ipadressold) do={\
    \n\t\t\tif (\$rules > 0 ) do {\
    \n\t\t\t\t/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t\t\t}\
    \n\t\t\t/ip firewall nat add action=dst-nat chain=dstnat comment=\"VOD Script\" dst-address-type=local in-interface=vlan2 to-addresses=\$ipadressnew\
    \n\t\t\t:log info \"VODScript: IP adress changed from \$ipadressold to \$ipadressnew !\"\
    \n\t\t}\
    \n\t}\
    \n}"

El script aunque mas largo es mas ligero que el original, ya que normalmente solo hace comparaciones, se puede eliminar algún comentario, para ser mas vervose, o para eliminar la regla cuando paramos el deco, pero eso ya lo dejo al gusto de cada uno.

Como que el script es más ligero, el intervalo de ejecución del paso 4, puede ser más agresivo:

Código:
/system scheduler add interval=5s name=vod on-event=vod policy=read,write start-time=startup

Un saludo a todos, y me alegro de haber ayudado.

Probado y perfecto
 
Pregunta a los expertos en mikrotik

Actualmente dispongo de dos oficinas cada una con un numero de teléfono SIP unidas por VPN
He intentado pasar la telefonía de una a otra y funciona sin problemas añadiendo rutas hacia la 10.31.255.134, hasta ahí todo bien.

Ahora para rizar el rizo, me gustaría poder tener los dos números en las dos oficinas y por SIP no por la salida del router (ya que mi idea es cambiar la ONT)

Mi idea, o lo que tenía en mente es hacer un NAT de la 10.31.255.134 a una IP local pongamos 192.168.1.10 y en el otro router lo mismo de la 10.31.255.134 pero a la 192.168.2.10 de esta manera cada oficina tendrá su propio numero de teléfono registrándose a la 10.31.255.134 y a la IP de NAT del router de la oficina contraria, manteniendo los dos números en cada sede.

He estado buscando info y he encontrado la opción de netmap (que me parece que es lo que más se acerca)

/ip firewall nat add chain=dstnat dst-address=10.31.255.134 action=netmap to-addresses=192.168.1.10
/ip firewall nat add chain=srcnat src-address=192.168.1.10/24 action=netmap to-addresses=10.31.255.134

Esto no funciona así que algún experto en Mikrotik podría darme algo de luz, en resumen lo que busco es generar una IP vitual que sea un reflejo del servidor SIP, me da igual restringir solo el puerto 5070 que todo el trafico hacia la IP

Muchas gracias y salu2
 
Hola,
Llevo con FTTH movistar y microtik ya un tiempo sin problemas.
Ayer pensé en cambiar mi red (era 192.168.1.0) a otra (10.10.33.0). Despues de trastear ayer y hoy he llegado a un punto sin retorno porque no puedo poner la iptv en marcha. Todo lo demas si funciona.
Estoy seguro que es una tonteria pero no doy con ella. Tengo un backup de mi red anterior, asi que no hay problema en restaurarla.
Lo que he intentado es esto:
-en IP addresses>creo una nueva red 10.10.33.1/24 y elimino la anterior 192.168.1.1/24; la nueva la asocio a el bridge que tenia creado antes para mi LAN (bridge1) que engloba todos los ether menos el primero que es de la WAN.
-en DCHP server creo uno nuevo para 10.10.33.0/24 con gateway 10.10.33.1 y dns 8.8.8.8 (y elimino el de la red anterior)
-en IP pool creo un rango de ip´s de la 10.10.33.100 a 120 (y elimino el de la red anterior)
-en FW NAT cambio en la regla que tenia para VOD: solo cambio "to addresses" a 10.10.33.199
-en ROUTES creo estas nuevas:
>10.10.33.0/24 con Pref. Sorce 10.10.33.1 y asignada a bridge1
>10.10.33.199 con Pref. Sorce 10.10.33.1 y asignada a bridge1
>10.10.33.200 con Pref. Sorce 10.10.33.1 y asignada a bridge1
(y elimino las de la red anterior)
Voy al deco (zyxel) y compruebo que tiene IP 10.10.33.200, 255.255.255.0, puerta enlace 10.10.33.1, dns 172.16.23.3.
Y hasta aqui llego, a vber si alguien me puede echar una mano.
Sl2
 
Hola,
Llevo con FTTH movistar y microtik ya un tiempo sin problemas.
Ayer pensé en cambiar mi red (era 192.168.1.0) a otra (10.10.33.0). Despues de trastear ayer y hoy he llegado a un punto sin retorno porque no puedo poner la iptv en marcha. Todo lo demas si funciona.
Estoy seguro que es una tonteria pero no doy con ella. Tengo un backup de mi red anterior, asi que no hay problema en restaurarla.
Lo que he intentado es esto:
-en IP addresses>creo una nueva red 10.10.33.1/24 y elimino la anterior 192.168.1.1/24; la nueva la asocio a el bridge que tenia creado antes para mi LAN (bridge1) que engloba todos los ether menos el primero que es de la WAN.
-en DCHP server creo uno nuevo para 10.10.33.0/24 con gateway 10.10.33.1 y dns 8.8.8.8 (y elimino el de la red anterior)
-en IP pool creo un rango de ip´s de la 10.10.33.100 a 120 (y elimino el de la red anterior)
-en FW NAT cambio en la regla que tenia para VOD: solo cambio "to addresses" a 10.10.33.199
-en ROUTES creo estas nuevas:
>10.10.33.0/24 con Pref. Sorce 10.10.33.1 y asignada a bridge1
>10.10.33.199 con Pref. Sorce 10.10.33.1 y asignada a bridge1
>10.10.33.200 con Pref. Sorce 10.10.33.1 y asignada a bridge1
(y elimino las de la red anterior)
Voy al deco (zyxel) y compruebo que tiene IP 10.10.33.200, 255.255.255.0, puerta enlace 10.10.33.1, dns 172.16.23.3.
Y hasta aqui llego, a vber si alguien me puede echar una mano.
Sl2
Hola razzta01, voy a intentar ayudarte. No soy un experto, pero lo primero que me salta a la vista es que la ip del desco y la que tienes en FW NAT no coinciden.
Por otro lado, ¿qué tienes en DCHP Server/Options?
Ahí tiene que darse de alta un valor determinado para el/los desco, al que tendrás que hacer referencia cuándo des de alta la ip del desco en DHCP Server/Networks
 
Hola,
Llevo con FTTH movistar y microtik ya un tiempo sin problemas.
Ayer pensé en cambiar mi red (era 192.168.1.0) a otra (10.10.33.0). Despues de trastear ayer y hoy he llegado a un punto sin retorno porque no puedo poner la iptv en marcha. Todo lo demas si funciona.
Estoy seguro que es una tonteria pero no doy con ella. Tengo un backup de mi red anterior, asi que no hay problema en restaurarla.
Lo que he intentado es esto:
-en IP addresses>creo una nueva red 10.10.33.1/24 y elimino la anterior 192.168.1.1/24; la nueva la asocio a el bridge que tenia creado antes para mi LAN (bridge1) que engloba todos los ether menos el primero que es de la WAN.
-en DCHP server creo uno nuevo para 10.10.33.0/24 con gateway 10.10.33.1 y dns 8.8.8.8 (y elimino el de la red anterior)
-en IP pool creo un rango de ip´s de la 10.10.33.100 a 120 (y elimino el de la red anterior)
-en FW NAT cambio en la regla que tenia para VOD: solo cambio "to addresses" a 10.10.33.199
-en ROUTES creo estas nuevas:
>10.10.33.0/24 con Pref. Sorce 10.10.33.1 y asignada a bridge1
>10.10.33.199 con Pref. Sorce 10.10.33.1 y asignada a bridge1
>10.10.33.200 con Pref. Sorce 10.10.33.1 y asignada a bridge1
(y elimino las de la red anterior)
Voy al deco (zyxel) y compruebo que tiene IP 10.10.33.200, 255.255.255.0, puerta enlace 10.10.33.1, dns 172.16.23.3.
Y hasta aqui llego, a vber si alguien me puede echar una mano.
Sl2
No es una buena decisión cambiar el rango de tu lan de una dirección tipo C a una tipo A, más aún cuando tu operador tiene sus servicios corriendo en una red 10.x
Creo que te va a costar un dolor de cabeza el cambio. Para tu lan usa una dirección de tipo C, la que quieras, pero no te muevas de ahí, a menos que sepas muy bien qué estás haciendo.

Saludos.
 
No es una buena decisión cambiar el rango de tu lan de una dirección tipo C a una tipo A, más aún cuando tu operador tiene sus servicios corriendo en una red 10.x
Creo que te va a costar un dolor de cabeza el cambio. Para tu lan usa una dirección de tipo C, la que quieras, pero no te muevas de ahí, a menos que sepas muy bien qué estás haciendo.

Saludos.
Hola, hoy he recuperado el backup y he regresado a la configuracion anterior. Como suele suceder cuando uno toca algo, ahora tampoco funciona.
He detectado que el deco no se conecta. Si desde la terminal del microtik le hago ping a su ip 192.168.1.200 no responde. Que debo comprobar para solicionarlo, ya que creo que ahi está el problema.
Sl2
 
Hola, hoy he recuperado el backup y he regresado a la configuracion anterior. Como suele suceder cuando uno toca algo, ahora tampoco funciona.
He detectado que el deco no se conecta. Si desde la terminal del microtik le hago ping a su ip 192.168.1.200 no responde. Que debo comprobar para solicionarlo, ya que creo que ahi está el problema.
Sl2
Según la configuración que mostraste, parecía que lo tenías apuntando a la 192.168.1.199. Pon el deco a la ip 192.168.1.199
 
Hola, escribo a ver si hay alguien capaz de ayudarme. Actualmente tengo Jazztel y he configurado una ONT ZTE ONT F601 que sincroniza correctamente. Tengo conectado el cable WAN al puerto 1 de un MikroTik RB4011 y estoy usando este script que lo ejecuto tras un rest del router, pero no consigo tener internet... y ya no se que mas hacer. A ver si alguien es capaz de decirme que hay mal en el script. Muchisimas gracias de ante mano.

Código:
/interface bridge
add igmp-snooping=yes name=bridge

/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] name=ether3-slave-local
set [ find default-name=ether4 ] name=ether4-slave-local
set [ find default-name=ether5 ] name=ether5-slave-local
set [ find default-name=ether6 ] name=ether6-slave-local
set [ find default-name=ether7 ] name=ether7-slave-local
set [ find default-name=ether8 ] name=ether8-slave-local
set [ find default-name=ether9 ] name=ether9-slave-local
set [ find default-name=ether10 ] name=ether10-slave-local

/interface vlan
add interface=ether1-gateway mtu=1500 name=vlan1 vlan-id=1074

/ip pool
add name=default-dhcp ranges=192.168.1.10-192.168.1.254

/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=default bootp-support=dynamic

/interface bridge port
add bridge=bridge interface=ether2-master-local
add bridge=bridge interface=ether3-slave-local
add bridge=bridge interface=ether4-slave-local
add bridge=bridge interface=ether5-slave-local
add bridge=bridge interface=ether6-slave-local
add bridge=bridge interface=ether7-slave-local
add bridge=bridge interface=ether8-slave-local
add bridge=bridge interface=ether9-slave-local
add bridge=bridge interface=ether10-slave-local

/interface bridge settings
set use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes

/ip neighbor discovery-settings
set discover-interface-list=!dynamic

/ip settings
set tcp-syncookies=yes

/ip address
add address=192.168.1.1/24 comment="default configuration" interface=bridge network=192.168.1.0

/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=vlan1 use-peer-ntp=no

/ip dhcp-server network
add address=192.168.1.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.1.1 netmask=24

/ip dns
set servers=8.8.8.8,8.8.4.4

/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add chain=input comment=webfig dst-port=81 in-interface=vlan1 protocol=tcp
add action=drop chain=input comment="default configuration" in-interface=vlan1
add action=fasttrack-connection chain=forward comment="default configuration" connection-state=established,related
add chain=forward comment="default configuration" connection-state=established,related
add action=drop chain=forward comment="default configuration" connection-state=invalid
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat connection-state=new in-interface=vlan1

/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1-gateway
add action=masquerade chain=srcnat comment="default configuration" out-interface=vlan1

/ip route
add distance=255 gateway=255.255.255.255

/ip upnp interfaces
add interface=bridge type=internal
 
Hola, escribo a ver si hay alguien capaz de ayudarme. Actualmente tengo Jazztel y he configurado una ONT ZTE ONT F601 que sincroniza correctamente. Tengo conectado el cable WAN al puerto 1 de un MikroTik RB4011 y estoy usando este script que lo ejecuto tras un rest del router, pero no consigo tener internet... y ya no se que mas hacer. A ver si alguien es capaz de decirme que hay mal en el script. Muchisimas gracias de ante mano.

Código:
/interface bridge
add igmp-snooping=yes name=bridge

/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] name=ether3-slave-local
set [ find default-name=ether4 ] name=ether4-slave-local
set [ find default-name=ether5 ] name=ether5-slave-local
set [ find default-name=ether6 ] name=ether6-slave-local
set [ find default-name=ether7 ] name=ether7-slave-local
set [ find default-name=ether8 ] name=ether8-slave-local
set [ find default-name=ether9 ] name=ether9-slave-local
set [ find default-name=ether10 ] name=ether10-slave-local

/interface vlan
add interface=ether1-gateway mtu=1500 name=vlan1 vlan-id=1074

/ip pool
add name=default-dhcp ranges=192.168.1.10-192.168.1.254

/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=default bootp-support=dynamic

/interface bridge port
add bridge=bridge interface=ether2-master-local
add bridge=bridge interface=ether3-slave-local
add bridge=bridge interface=ether4-slave-local
add bridge=bridge interface=ether5-slave-local
add bridge=bridge interface=ether6-slave-local
add bridge=bridge interface=ether7-slave-local
add bridge=bridge interface=ether8-slave-local
add bridge=bridge interface=ether9-slave-local
add bridge=bridge interface=ether10-slave-local

/interface bridge settings
set use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes

/ip neighbor discovery-settings
set discover-interface-list=!dynamic

/ip settings
set tcp-syncookies=yes

/ip address
add address=192.168.1.1/24 comment="default configuration" interface=bridge network=192.168.1.0

/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=vlan1 use-peer-ntp=no

/ip dhcp-server network
add address=192.168.1.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.1.1 netmask=24

/ip dns
set servers=8.8.8.8,8.8.4.4

/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add chain=input comment=webfig dst-port=81 in-interface=vlan1 protocol=tcp
add action=drop chain=input comment="default configuration" in-interface=vlan1
add action=fasttrack-connection chain=forward comment="default configuration" connection-state=established,related
add chain=forward comment="default configuration" connection-state=established,related
add action=drop chain=forward comment="default configuration" connection-state=invalid
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat connection-state=new in-interface=vlan1

/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1-gateway
add action=masquerade chain=srcnat comment="default configuration" out-interface=vlan1

/ip route
add distance=255 gateway=255.255.255.255

/ip upnp interfaces
add interface=bridge type=internal

No tires de scripts que encuentres por internet, se quedan obsoletos tan pronto el firmware va evolucionando, mejor basarse en una configuración base reciente. Dale un reset, un quick setup con todo por defecto y, sobre la configuración que monta, configuras encima la VLAN. Si estás en cobertura directa, será la 1074 que mencionas, si eres neba, será la 20. Son básicamente tres pasos, desde la config que escupe el quick set:
  • Dar de alta la vlan
  • Meter la vlan en la lista de interfaces WAN
  • Actualizar la interfaz sobre la que corre el cliente dhcp para que pase de ser ether1 a ser la vlan que has configurado.

Saludos!
 
No tires de scripts que encuentres por internet, se quedan obsoletos tan pronto el firmware va evolucionando, mejor basarse en una configuración base reciente. Dale un reset, un quick setup con todo por defecto y, sobre la configuración que monta, configuras encima la VLAN. Si estás en cobertura directa, será la 1074 que mencionas, si eres neba, será la 20. Son básicamente tres pasos, desde la config que escupe el quick set:
  • Dar de alta la vlan
  • Meter la vlan en la lista de interfaces WAN
  • Actualizar la interfaz sobre la que corre el cliente dhcp para que pase de ser ether1 a ser la vlan que has configurado.

Saludos!
FUNCIONA!!! Tio dame tu direccion que te mando un jamon XD muchisimas gracias. Un apunte para los que venga despues de mi, cuando das de alta la vlan se asocia automaticamente a la interface "bridge", hay que cambiarla a ether1 que es donde esta la WAN conectada y listo :D!!! De nuevo gracias @pokoyo
 
FUNCIONA!!! Tio dame tu direccion que te mando un jamon XD muchisimas gracias. Un apunte para los que venga despues de mi, cuando das de alta la vlan se asocia automaticamente a la interface "bridge", hay que cambiarla a ether1 que es donde esta la WAN conectada y listo :D!!! De nuevo gracias @pokoyo

Correcto; ese detalle se me pasó. Te iba a pasar los comandos de esos tres pasos, pero me pillas fuera, respondiéndote desde un móvil.
Si quieres, para más tarde, le damos un repaso a la config, por si se puede mejorar algo más. Si te apetece, me mandas un export, sin datos sensibles, y lo reviso.

export hide-sensitive file=config

El fichero resultante config.src lo tendrás guardado en la carpeta files de winbox/webfig, desde ahí te lo puedes descargar.

Saludos!
 
Buenos días,

En primer lugar, agradecer a todos la colaboración en este tema y hacer posible que gente como yo haya podido poner la FTTH directa en el Mikrotik.

Ahora bien, me está dando problemas el VOD en el momento de reproducir algo desde el principio sobre todo. He probado el método de @toniros pues tengo dos decos, uno antiguo y otro de los nuevos UHD y el VOD se pixela siempre en el momento de visualizar un programa desde el principio (botón amarillo) he probado con la configuración del script y a quitarlo y dejar solo una regla para un único deco y nada, en todos los casos se me pixela la imagen. También se pixelaba el visionado en directo, pero lo he "solucionado" programando un reinicio diario del router pues me parece que de alguna forma se satura y ese es el motivo del pixelado de imagenio en directo.

A alguien mas le pasa? VOD se pixela sobre todoo en el visionado desde el inicio

Gracias y un saludo!!
 
Eso suena a que se te esta saturando por trafico Multicast.

Mira en Interface _ Bridge y marca la casilla IGMP snooping, para que te filtre el trafico multicast solo al equipo que lo reclama.
 
Eso suena a que se te esta saturando por trafico Multicast.

Mira en Interface _ Bridge y marca la casilla IGMP snooping, para que te filtre el trafico multicast solo al equipo que lo reclama.

Muchas gracias por contestar Benicio. Es lo mismo que he pensado yo, pero está activado el IGMP Snooping :( comentar también que entre el router y el deco hay un switch (no gestionado) por si eso afecta... Y también comentar que en directo también pixela :cry:

EDITO:
Por si ayuda a identificar el problema, esta es mi configuración actual:
ONT Huawei de la que sale el telefono por el rj11 y la eth al Mikrotik y a éste le entra la eth por el puerto sfp con un adaptador sfp a eth.

Código:
/interface bridge add igmp-snooping=yes name=bridgeMain
/interface ethernet set [ find default-name=ether1 ]
/interface ethernet set [ find default-name=ether2 ]
/interface ethernet set [ find default-name=ether3 ]
/interface ethernet set [ find default-name=ether4 ]
/interface ethernet set [ find default-name=ether5 ]
/interface ethernet set [ find default-name=ether6 ]
/interface ethernet set [ find default-name=ether7 ]
/interface ethernet set [ find default-name=ether8 ]
/interface ethernet set [ find default-name=ether9 ]
/interface ethernet set [ find default-name=ether10 ]
/interface vlan add comment="Movistar FTTH IPTV" interface=sfp-sfpplus1 name=vlan2 vlan-id=2
/interface vlan add comment="Movistar FTTH VoIP" interface=sfp-sfpplus1 name=vlan3 vlan-id=3
/interface vlan add comment="Movistar FTTH Data" interface=sfp-sfpplus1 name=vlan6 vlan-id=6
/interface pppoe-client add add-default-route=yes allow=pap,chap disabled=no interface=vlan6 keepalive-timeout=60 max-mru=1492 max-mtu=1492 name=pppoe-FTTHMovistar use-peer-dns=yes user=adslppp@telefonicanetpa
/interface ethernet switch port set 0 default-vlan-id=0
/interface ethernet switch port set 1 default-vlan-id=0
/interface ethernet switch port set 2 default-vlan-id=0
/interface ethernet switch port set 3 default-vlan-id=0
/interface ethernet switch port set 4 default-vlan-id=0
/interface ethernet switch port set 5 default-vlan-id=0
/interface ethernet switch port set 6 default-vlan-id=0
/interface ethernet switch port set 7 default-vlan-id=0
/interface ethernet switch port set 8 default-vlan-id=0
/interface ethernet switch port set 9 default-vlan-id=0
/interface ethernet switch port set 10 default-vlan-id=0
/interface ethernet switch port set 11 default-vlan-id=0
/interface list add name=WAN
/ip dhcp-server option add code=240 name=option_para_deco value="':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
/ip firewall layer7-protocol add comment=VODMovistar name=rtsp regexp="SETUP rtsp.*"
/ip ipsec proposal set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-192-cbc pfs-group=none
/ip pool add name=dhcp-Subnet1 ranges=192.168.1.150-192.168.1.199
/ip dhcp-server add address-pool=dhcp-Subnet1 disabled=no interface=bridgeMain lease-time=1h name=dhcp_Subnet1
/interface bridge port add bridge=bridgeMain interface=sfp-sfpplus1
/interface bridge port add bridge=bridgeMain interface=ether1
/interface bridge port add bridge=bridgeMain interface=ether2
/interface bridge port add bridge=bridgeMain interface=ether3
/interface bridge port add bridge=bridgeMain interface=ether4
/interface bridge port add bridge=bridgeMain interface=ether5
/interface bridge port add bridge=bridgeMain interface=ether6
/interface bridge port add bridge=bridgeMain interface=ether7
/interface bridge port add bridge=bridgeMain interface=ether8
/interface bridge port add bridge=bridgeMain interface=ether9
/interface bridge port add bridge=bridgeMain interface=ether10
/interface bridge settings set use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes
/ip settings set tcp-syncookies=yes
/interface detect-internet set detect-interface-list=WAN
/interface list member add interface=pppoe-FTTHMovistar list=WAN
/ip address add address=192.168.1.1/24 interface=bridgeMain network=192.168.1.0
/ip address add address=10.68.97.232/10 interface=vlan2 network=10.64.0.0
/ip dhcp-client add add-default-route=no disabled=no interface=vlan3 use-peer-ntp=no
/ip dhcp-server config set store-leases-disk=immediately
/ip dhcp-server lease add address=192.168.1.201 address-lists=vod-receiver comment=DecoSalon dhcp-option=option_para_deco server=dhcp_Subnet1
/ip dhcp-server network add address=192.168.1.0/24 dns-server=80.58.61.254,80.58.61.250 gateway=192.168.1.1 netmask=24
/ip dhcp-server network add address=192.168.1.200/29 dhcp-option=option_para_deco dns-server=172.26.23.3 gateway=192.168.1.1 netmask=24
/ip dns set servers=80.58.61.250,80.58.61.254
/ip firewall filter add action=fasttrack-connection chain=forward connection-state=established,related
/ip firewall filter add chain=input comment="default configuration" protocol=icmp
/ip firewall filter add chain=input comment="default configuration" connection-state=established
/ip firewall filter add chain=input comment="default configuration" connection-state=related
/ip firewall filter add action=drop chain=input comment="default configuration" in-interface=pppoe-FTTHMovistar
/ip firewall filter add chain=forward comment="default configuration" connection-state=established
/ip firewall filter add chain=forward comment="default configuration" connection-state=related
/ip firewall filter add action=drop chain=forward comment="default configuration" connection-state=invalid
/ip firewall mangle add action=set-priority chain=postrouting new-priority=4 out-interface=vlan3
/ip firewall mangle add action=set-priority chain=postrouting new-priority=4 out-interface=vlan2
/ip firewall mangle add action=set-priority chain=postrouting new-priority=1 out-interface=pppoe-FTTHMovistar
/ip firewall mangle add action=add-src-to-address-list address-list=vod-receiver address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" dst-port=554 out-interface=vlan2 protocol=tcp
/ip firewall nat add action=masquerade chain=srcnat comment="default configuration" out-interface=pppoe-FTTHMovistar
/ip firewall nat add action=masquerade chain=srcnat comment="default configuration - NOT WORKING DUE TO BRIDGE" disabled=yes out-interface=sfp-sfpplus1
/ip firewall nat add action=masquerade chain=srcnat comment="default configuration" out-interface=vlan2
/ip firewall nat add action=masquerade chain=srcnat comment="default configuration" out-interface=vlan3
/ip firewall nat add action=dst-nat chain=dstnat comment=VOD dst-address-type=local in-interface=vlan2 to-addresses=192.168.1.201
/ip firewall nat add action=masquerade chain=srcnat comment=HAIRPIN dst-address=192.168.1.0/24 src-address=192.168.1.0/24
/ip firewall nat add action=dst-nat chain=dstnat comment="VOD Script" disabled=yes dst-address-type=local in-interface=vlan2 to-addresses=192.168.1.201
/ip route add distance=255 gateway=255.255.255.255
/ip upnp interfaces add interface=bridgeMain type=internal
/ip upnp interfaces add interface=pppoe-FTTHMovistar type=external
/routing igmp-proxy set query-interval=15s quick-leave=yes
/routing igmp-proxy interface add alternative-subnets=0.0.0.0/0 interface=vlan2 upstream=yes
/routing igmp-proxy interface add interface=bridgeMain
/routing rip interface add interface=vlan3 passive=yes receive=v2
/routing rip interface add interface=vlan2 passive=yes receive=v2
/routing rip network add network=10.0.0.0/8
/routing rip network add network=172.26.0.0/16
/system clock set time-zone-name=Europe/Madrid
/system identity set name=Router-Core
/system ntp client set enabled=yes primary-ntp=129.6.15.28 secondary-ntp=129.6.15.29
/system routerboard settings set auto-upgrade=yes

Salu2!
 
Última edición:
Arriba