Hilo para mejoras con Mikrotik (Movistar TV)

#41
ESABEA dijo:
Pues se queda funcionando.....sin embargo, reinicio el mikrotik y necesito volver a hacerlo.....
puff... pues con esto que comentas, a no ser que cuando añades el PIM le hayas marcado (que no creo) algo distinto como la opción de "igmpv3" y tenga algo que ver.... Pues suena mas o a un bug en el router o algún pequeño fallo que se nos ha pasado.
 
#42
no....lo dejé como igmpv2....
Lo que si que vi en el LOG es que al "crear" la interface en PIM, me pinta en el LOG que crea/asigna la IP a la VLAN2.....como si hasta entonces no estuviera creada/asignada
Es como si con el PIM "se despertase" la VLAN2.......
 
#43
Re:

ESABEA dijo:
no....lo dejé como igmpv2....
Lo que si que vi en el LOG es que al "crear" la interface en PIM, me pinta en el LOG que crea/asigna la IP a la VLAN2.....como si hasta entonces no estuviera creada/asignada
Es como si con el PIM "se despertase" la VLAN2.......
Te has fijado si al crear la PIM te añade alguna ruta que antes no tuvieses??
 
#45
Y yo pregunto desde la ignorancia.

¿No se podría utilizar un equipo Linux baratito como este BPi-R1, para hacer de router y deco a la vez?

http://www.bananapi.com/index.php/compo ... edit&id=59

Soporta estos OS:
http://www.bananapi.com/index.php/downl ... edit&id=65

E implementar todos los manuales de esta página?

Movistar Fusión Fibra + TV + VoIP con router Linux
http://www.luispa.com/?p=266

Movistar TV: Video bajo demanda con router Linux
http://www.luispa.com/?p=378

La idea sería incluso implementar una distro propia o algo así, para MovistarTV, con todo lo necesario instalado.

Sólo es una idea, pero creo que puede funcionar.
 
#46
Hola, soy Luis el que ha escrito esos links que comentas.

Mi respuesta es que es una idea genial, meter todo en una Raspberry, que sea el Router/Firewall hacia Internet y que además haga todo el tema de IPTV, TVHeadEnd, EPG, etc. Tenía una duda: ¿Soportará VLANs la tarjeta (y el driver) Ethernet de la Raspberry?, parece que ese "reparo" se salva, por lo menos sí que dicen que lo soporta en lo que he ojeado en internet.

Ahora bien, tienes un handicap importante: La tarjeta LAN de la Raspberry (1 y 2) usam el chip ethernet LAN9154 que a su vez emplea el bus USB para comunicarse, y ese bus es muyyy lento... En mi caso no he sido capaz de pasar (de forma estable) de los 40-45Mbps sostenidos, así que solo valdrá para entornos que se muevan por esos números, para un entorno de fibra donde puedes necesitar mantener los 100Mbps o más, pues mal asunto.

Es más, lo ideal como dices es que sea el router de internet, y el firewall y además IPTV. Como sabes Movistar te entrega en la vlan 6 hasta 100Mbps, y en la vlan 2 puedes tener varios canales HD, eso supone que estamos hablando de 120, 130, 140Mbps (depende de cuantos Decos o XBMC's/VLC's esten tirando del video de forma simultánea).

Lo dicho, un reto interesante, barato, bajo consumo, me gusta, pero ... esperaré a ver si algún día sacan una versión 3 con un chip decente de LAN :)

Luis
 
#47
Por lo que me enseñaron en primero de la carrera, para hacer un router hacen falta dos interfaces, lo que sería en LAN y en WAN. No comprendo cómo hacer un router con una Raspberry con un solo puerto.

Teóricamente es posible con VLANs, pero no tiene sentido porque harían falta switches para separar los puertos y nunca podríamos obtener el mismo rendimiento.
 
#48
La placa a la que hacía referencia eltate (BPi-R1) sí que tiene 2 interfaces gigabit (1 WAN y un switch de 4 puertos para la LAN).

Además lleva dos conectores para antenas (802.11n). No sé si comparte bus como la Raspberry, sería cuestión de leerse la docu.
 
#49
Parece interesante lo que planteáis pero yo a día de hoy los problemas que veo serían:
- Superar la complejidad que suponga el montarle el SO con su configuración totalmente funcional.
- En caso de conseguirlo, tengo dudas sobre el rendimiento que pueda dar ese hardware. ¿alguien lo sabe?

Es decir, que si lo valorase desde mi punto de vista, no le veo la ventaja respecto a tener el Ubiquiti ¿cual sería la ganancia o ventajas? Ya me trae todo con su caja, fuente, SO, flash, soporte etc.. y no solo una placa. Lo tengo todo configurado sin mayor problema.
 
#51
Begepeich dijo:
Comento, sobre los puntos

1- Efectivamente siempre ha sido así, lo de meter el nat estático es digamos "el parche" para mantener la funcionalidad, pero la limitación es esa, solo sirve para un Deco en cada momento, no varios a la vez utilizando esos servicios concretos.

Respecto a como lo hace el Comtrend, pues realmente es un helper de NAT para video, igual que el mikrotik tiene también para FTP, H323, IRC, PPTP....y algún otro. Es decir, son módulos que si están activados trabajan inspeccionando el trafico de capas superiores, para leer la información concreta relativa a esos servicios, solo lo que les interesa en los paquetes para facilitar la apertura sobre filters o DNATs dinamicamente.
Un ejemplo claro de esto en las configs, ¿por qué funciona la VPN PPTP si no esta abierto ni filtro, ni NAT para el GRE? Pues porque el helper de PPTP esta habilitado y te lo hace automáticamente después de ver los primeros paquetes que se intercambian por el puerto 1723 que lo inspecciona este helper.

Sobre el Helper concreto de imagenio, es para RTSP, tiene que leer el trafico de ese protocolo.... hay un momento concreto en el que el Deco cuando solicita algún VOD envía al servidor el puerto origen concreto por el que espera recibirlo, pues bien, acto seguido el router crea la redireccion a ese puerto en el NAT hacia la ip de ese deco. Así funciona el invento.

En un Ubiquiti creo que se podría incorporar, compilando el modulito a parte, por eso lo lo dejé ahí parado .... los fuentes los tengo.
Hola Begepeich, despues de intentar si exito configurar el erlite para tener VOD en varios dispositivos (deco+Xbmcs) simultaneamente, he terminado llegando a este hilo.
He estado dandole vueltas al como puede ser que el Comtrend con el firm oficial de Movistar sea capaz de gestionar esas peticiones de VOD sin tener que configurar nada. Por nás que he mirado no veo nada en el Comtrend relacionado con RTSP .
¿No sería posible que más bien lo que tiene el Comtrend esté relacionado con Port triggering o Dynamic Port Forwarding?
 
#52
Me parece que el Comtrend lo hace con full cone NAT, pero en tu caso creo podrías hacer lo siguiente (no tengo edgerouter, así que igual lo que te digo es inviable): como no vas a usar nada más que un deco y en el addon de xbmc puedes definir el puerto de origen de la petición del vod, podrías poner uno diferente en cada xbmc, y reglas de apertura de puertos (una por xbmc) por encima de la del deco.

La regla del deco debe ser la última ya que como el puerto es aleatorio, todos los demás deben ir redirigidos al deco.

A priori se me ocurre que podrías tener la mala suerte de que el deco realizara la petición por uno de los puertos del xbmc... quizá alguien por aquí sepa el rango que utiliza para dicha solicitud.
 
#53
Invitado dijo:
Hola Begepeich, despues de intentar si exito configurar el erlite para tener VOD en varios dispositivos (deco+Xbmcs) simultaneamente, he terminado llegando a este hilo.
He estado dandole vueltas al como puede ser que el Comtrend con el firm oficial de Movistar sea capaz de gestionar esas peticiones de VOD sin tener que configurar nada. Por nás que he mirado no veo nada en el Comtrend relacionado con RTSP .
¿No sería posible que más bien lo que tiene el Comtrend esté relacionado con Port triggering o Dynamic Port Forwarding?
Puede que seas pqmc pero que has entrado sin registrar?

Lo del RTSP es para que todo fuese "automatico", no vas a encontrar nada en los menús del comtrend .... debe traerlo activado sin mas, igual que el helper de SIP que por culpa suya y no tener opción para desactivarlo a la gente la daba sus problemas con algún proveedor de voip.


Si tienes un deco y el resto son XBMC con addon pues se configura igual que expliqué para Mikrotik en este post , es la respuesta al punto 4.
http://www.adslzone.net/postt311611-5385.html#p2663776

La ventaja es que el Addon de XBMC si tiene opción para elegir el puerto/s por el que quieres que trabaje, solo hay que redirigirlos en el Router y como explicaba esas reglas deben ir antes de la del VOD que ya hay para el deco.

Si necesitas algún pantallazo de como se hace dímelo en el hilo de los Ubiquiti y te lo pongo sin problemas.

Saludos.
 
#55
Re:

Buenas

Yo clonando la MAC en un bridge vlan2 con la vlan2 como integrante, consigo recibir RIP v2 :) BIEN!!

Ahora haciendo lo que dice ESABEA lo que hace lo de PIM es forzar a usar igmpv2 en vez de igmpv3 que e slo que hace por defecto el igmp proxy.

He sacado trazas y se ven los intentos de membersip report y JOIN con igmpv3 que Movistar rechaza

Creo que vamos en la buena dirección

Echarle un ojo a este enlace

http://forum.mikrotik.com/viewtopic.php?t=55797

Begepeich dijo:
Y siguiendo esos pasos ¿se queda funcionando o es algo que dura poco?

Saludos
 
#56
Re: Re:

Hola

Como estoy en el mismo caso que ESABEA

No, las rutas son las mismas se active el PIM antes o demás

ismamolero dijo:
ESABEA dijo:
no....lo dejé como igmpv2....
Lo que si que vi en el LOG es que al "crear" la interface en PIM, me pinta en el LOG que crea/asigna la IP a la VLAN2.....como si hasta entonces no estuviera creada/asignada
Es como si con el PIM "se despertase" la VLAN2.......
Te has fijado si al crear la PIM te añade alguna ruta que antes no tuvieses??
 
#57
Re: Re:

comagfan dijo:
Hola

Como estoy en el mismo caso que ESABEA

No, las rutas son las mismas se active el PIM antes o demás

ismamolero dijo:
ESABEA dijo:
no....lo dejé como igmpv2....
Lo que si que vi en el LOG es que al "crear" la interface en PIM, me pinta en el LOG que crea/asigna la IP a la VLAN2.....como si hasta entonces no estuviera creada/asignada
Es como si con el PIM "se despertase" la VLAN2.......
Te has fijado si al crear la PIM te añade alguna ruta que antes no tuvieses??
gracias @comangfan....en cuanto pueda retomar el tema intentaré aportar algo de información.
Coincido con vosotros que no tengo ninguna ruta nueva....Y en su día probé lo del PIM porque veía que en algunos sitios hacían referencia a las versiones v2/v3 del igmp proxy
 
#58
ESABEA que firmware usas tu?

Yo con el 6.27 tengo el problema de que se quedan los "canales" enganchados a nivel IGMP y se llega hasta 30 Mbps por vlan2.. y no veo la forma de que deje sólo el flujo del canal actual
 
#59
Buenas,

He hecho el montaje sobre una CubieTruck con udpxy + xupnpd, la verdad que funciona, pero la usuabilidad con mi LG del 2013 es infumable. Los cambios de "canal" son muy lentos.
Me quedo con mi montaje anterior TVHeadEnd + WebGrabberPlus, con esto los cambios de canal en un XBMC (raspberryPi) son de 2 segundos aproximadamente.
Pierdo el VoD, pero como no estoy suscrito a nada que requiera VoD me da igual y las grabaciones las gestiono con el TVHeadEnd

Un saludo
 
#60
Re:

comagfan dijo:
ESABEA que firmware usas tu?

Yo con el 6.27 tengo el problema de que se quedan los "canales" enganchados a nivel IGMP y se llega hasta 30 Mbps por vlan2.. y no veo la forma de que deje sólo el flujo del canal actual
Ah , entonces en tu caso si que lo ves? Para lo del flujo con un solo canal has probado a activar el quick-leave en el igmp-proxy?
 
Arriba