Hacer que Mikrotik elija por que interfaz sale el trafico

Hola! Tengo un Mikrotik RouterBoard 750 y el escenario es este:
1- Conectada a la eth1, ISP que me entrega IP: 172.56.7.9 (como gateway, es solo para el ejemplo).
2- Conectada a la eth2, Intranet laboral IP: 10.20.3.2 (como gateway, es solo para el ejemplo).
3- Conectada a la eth3, Red LAN con IP: 192.168.5.xx (gateway 192.168.5.1, es solo para el ejemplo).

Una vez hecho eso me gustaria lograr:
1- Que si cualquier usuario de la LAN quiere ver Youtube, Facebook, periódicos, etc. Salga automaticamente por la eth1.
2- Que si cualquier usuario de la LAN quiere utilizar un recurso de la intranet, salga automaticamente por la eth2.

Seguro que algún genio de los que está en este foro me va a saber guiar!!!
 
Eso ya lo hace el propio equipo, sin tú decirle nada. Tan pronto le des a las interfaces ether2 y ether3 una dirección del segmento de red correspondiente, con una máscara de subred adecuada, se creará una ruta de tipo automática directamente conectada que te hará eso. El gateway de tu proveedor en ether1 ira asociado a la ruta por defecto (0.0.0.0), para todo lo demás que no encuentre en la tabla de rutas, lo saque por ahí (internet).

Además, en mikrotik todas las redes que definas en interfaces de red están directamente comunicadas, y serias tú vía firewall quien tendrías que impedir dicha comunicación, de necesitarlo.

Saludos!
 
Ejemplo, imaginemos este supuesto:
Mi proveedor de internet me entrega una dirección de tipo estática, 172.56.7.9, con máscara /28 y la coloco en ether1.
Estoy conectado a una red corporativa por ether2, donde se me asigna la dirección 10.20.3.2, con máscara 22.
El mikrotik define la subred 192.168.5.1/24 para su propia red local, en ether3. Con este supuesto, tendríamos el siguiente set de direcciones:
Código:
/ip address
add address=172.56.7.9/28 interface=ether1
add address=10.20.3.2/22 interface=ether2
add address=192.168.5.1/24 interface=ether3

Y, sin hacer nada más, tendríamos ya la siguiente tabla de rutas en /ip route print
1633504146497.png


Como ves en esa tabla, cada vez que se pregunte por una IP de la subred correspondiente, saldrá por el gateway que le toque, con una entrada de tipo DAc y distancia 0 (directamente conectada).

¿Y qué pasa con el tráfico de internet? Esa entrada se crea automáticamente en la tabla de direcciones, a partir de un cliente DHCP o un PPPoE normalmente. Pero, si nuestro proveedor nos ha dado IP estática, nos habrá provisto de los siguientes 3 elementos: IP pública, máscara y gateway. La IP pública y la máscara es lo que va definido en /ip address sobre ether1. Y el gateway es lo que usaremos para crear la ruta por defecto. Imaginemos que el gateway que nos han dado es el 172.56.7.1. Atendiendo a eso, tendríamos que realizar la siguiente entrada en la tabla de rutas:
Código:
/ip route add gateway=172.56.7.1
Esto, se traduciría en la siguiente tabla de rutas, ya completa:
1633504713651.png


Y, con esto, tendrías justo el comportamiento que quieres. Te quedaría cerrar el tráfico entre la red corporativa y tu LAN (sentido Corporativa -> LAN) Si no quieres que esa comunicación se dé.

Saludos!
 
Arriba