¿Es posible definir una lista de frecuencias al elegir Frequency: auto?

¿Hay alguna forma de que cuando se seleccione Frequency auto, busque en una lista de frecuencias definida.

Frecuency: auto
Lista de frecuencias: 5180-5240 ó 5180 ,5200 ,5220 ,5240
Buscará de forma automática la mejor frecuencia entre las definidas.

1633173643223.png


Saludos.
 
Sí. Un ejemplo: creamos la lista UNII-1, con los canales no DFS:
Código:
/interface wireless channels
add band=5ghz-n/ac extension-channel=Ce frequency=5180 list=UNII-1 name=ch36 \
    width=20
add band=5ghz-n/ac extension-channel=Ce frequency=5200 list=UNII-1 name=ch40 \
    width=20
add band=5ghz-n/ac extension-channel=Ce frequency=5220 list=UNII-1 name=ch44 \
    width=20
add band=5ghz-n/ac extension-channel=Ce frequency=5240 list=UNII-1 name=ch48 \
    width=20

Y ahora se lo aplicas a la interfaz wireless, con el parámetro "scan-list", para que sólo trabaje en esos canales. Ahí puedes apuntar a la lista o a canales sueltos + la lista, separados por coma. Así puedes jugar con lo que pretendes hacer.
Código:
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-n/ac channel-width=20/40mhz-XX \
    country=spain disabled=no distance=indoors frequency=auto mode=ap-bridge \
    name=wifi-5ghz scan-list=UNII-1 ssid=MYWIFI

Si quieres algo más avanzado, como lo de definir rangos y canales sueltos, usa CAPsMAN.

Saludos!
 
Última edición:
Arriba