Bridge VLAN RouterOS 7.1.1 a SwOS 2.14: Switch no asigna IP Pool

Buenas a todos, espero me puedan ayudar para no seguir consumiendo neuronas ni terminarme los pocos pelos que aún me quedan.:x

Seguí el excelente Manual:Mikrotik, bridge VLAN filtering de este foro y he conseguido configurar 4 VLANs en un solo bridge del router RB5009UG+S+IN. La LAN asigna las direcciones creadas en su pool a las interfaces designadas; cada una de las VLANs también asignan sus respectivas direcciones IP a los puertos designados. Las 4 VLANs están asignadas a las interfaces ether5, ether6, ether7 y ether8, destagueadas respectivamente. Por conveniencia, las interfaces ether4 y sfp-sfplus1 (esta última para conectarla por fibra 10G al switch) están tagueadas. En el router todo funciona perfectamente: interfaces, VLANs, rutas, acceso a internet, etc.

Sin embargo, después de configurar el switch CSS610-8G-2S+IN (que tiene switch chip 88E6193X, por aquello de que los switches Mkrotik se configuran diferente, dependiendo del medelo y swip chip que tengan), pierdo acceso a su interfaz web y no me asigna las VLANs como las configuré en el router.

Al respecto, conecto del router por la interfaz sfp-sfplus1 (PVID=1) a la interfaz sfp-sfplus1 del switch (tagged) y conecto mi computadora a la interfaz ether4 del switch, pero al principio me da dirección IP de la LAN para acceder a la web de configuración, pero una vez configuradas las VLANs pierdo acceso.

He seguido las instrucciones del fabricante: Basic Vlan Switching, Bridge VLAN Table y CSS 610 Series Manual, y no logro tener éxito. Agradeceré sus valiosas sugerencias. Creo que tengo algo mal configurado en el router que no me deja ver las VLANs creadas en el switch, pero no detecto el problema.

Saludos!
 
Pásame ambos exports, que me los reviso. No te prometo que sea mañana mismo, pero los miro en cuanto pueda y te digo.

Saludos!
 
Gracias, @pocoyo, por tomarte tu tiempo para revisar mi configuración, seguro será una chorrada. Te adjunto el export del router 5009:


5009:LAN.png5009:VLAN10.png5009:VLAN20.png5009:VLAN30.png5009:VLAN40.png
 

Adjuntos

  • 5009.txt
    4.9 KB · Visitas: 94
El switch tiene sistema operativo SwitchOS Lite, por lo que no encuentro donde pudiera hacerse el export, pero te pongo captura de pantallas de las ventanas de configuración como le he hice, paso a paso:

01ListadoPuertos.png02VLANs.png03Etiquetas.png04Sistema.png05DHCPcompu.png
 
Me disculparas que lo envíe así, pero apenas estoy aprendiendo a usar la pañgina del foro.

Saludos y gracias de nuevo!
 
No te preocupes, está perfecto.

Tu problema: no estás definiendo un puerto trunk, por eso las vlans no te funcionan en el switch. Correcciones:
A nivel de router:
- Definir un puerto trunk, el que vaya a enlazar con el switch. Suponemos sfp-sfpplus1 como trunk, debemo taggearlo en la definición del filtrado del bridge, al igual que se taggea el propio bridge. Por otro lado, el untagged no hace falta definirlo, porque ya lo define el PVID de los puertos que añades al bridge, que básicamente es asignar los puertos y su vlan de acceso. Y, si tuvieras que definirlo en la tabla de filtrado del bridge, en el untagged iría el puerto físico, no la interfaz VLAN.
- Si no estás manejando tráfico multicast, quita el igmp-snooping y el multicast querier del bridge. Una de estas dos opciones, más que probablemente, hará que el router trabaje sin hardware offloading (mira la pestaña ports del bridge y fíjate si llevan un flag "H" delante; si no lo llevan, no están funcionando con hardware offloading)
- El loop protection de la vlan se lo puedes quitar y, si quieres proteger tu red ante bucles, utiliza MSTP en el protocol mode del bridge.

A nivel de switch: todo parece estar bien, simplemente asegúrate de que la vlan de administración que tienes definida, la 10, se mande taggeada al switch. Otra opción es dejar la vlan=1 por defecto, y de esa manera tendrías acceso al switch desde la red que no lleva tagging alguno.

Borra la definición de VLANs de /interface/bridge/vlan, y la defines de la siguiente manera. Si además quisieras taggear ether4, lo metes igual en el tagged=bridge-vlans,sfp-sfpplus1,ether4
Código:
/interface/bridge/vlan
add bridge=bridge-vlans tagged=bridge-vlans,sfp-sfpplus1 vlan-ids=10
add bridge=bridge-vlans tagged=bridge-vlans,sfp-sfpplus1 vlan-ids=20
add bridge=bridge-vlans tagged=bridge-vlans,sfp-sfpplus1 vlan-ids=30
add bridge=bridge-vlans tagged=bridge-vlans,sfp-sfpplus1 vlan-ids=40

Saludos!
 
Muchas gracias, @pocoyo!

Revisaré con detenimiento tus precisiones y más tarde pongo manos a la obra, ya que el deber y la parienta llaman.

Saludos!
 
Saludos a todos y ante todo una enorme disculpa, ya que por motivos de trabajo estuve fuera de la ciudad unos días, apenas hoy pude reconfigurar los dispositivos conforme a las atinadas indicaciones de @pocoyo, y voila! Ya están funcionando correctamente las vlans.

Nuevamente mi agradecimiento, @pocoyo!

Saludos
 
Arriba