ayuda con VOIP movistar en router mikrokit

Hola.

vengo a preguntar porque me he quedado ya sin ideas a ver si alguien en el foro es capaz de ver donde he metido la pata, porque yo no logro encontrarlo y el teléfono no consigo que funcione.

de referencia para hacer la configuración he usado este hilo: https://www.adslzone.net/foro/mikrotik.199/voip-movistar-mikrotik.494422/

Tengo un router mikrokit rb4011iGS conectado a un switch CRS326-24G-2S+RM. la voIP funciona con un telefono convencional conectado a un ata-SIP grandsteam HT802

el router tiene acceso a internet por dos WAN:

-la de orange que va conectada al livebox (router) de orange a traves de un DMZ apuntando al router de mikrokit.

-la de movistar que funciona con una ONT de ubiquity nano g y el router de mikrokit se encarga del PPPOE en la vlan 6 y de sacar la VLAN 3 del telefono

estas dos estan simplemente puestas en failover la de movistar con prioridad 1 y la de orange prioridad 2.

en cuanto a movistar configure la VLAN 3 del telefono igual que ya habia configurado la VLAN 6 de internet ,cree un cliente DHCP,marque el priority en postrouting en el mangle y añadi la interfaz en el rip ademas de poner tambien la ip de la network de la vlan 3 en las rutas del RIP (vamos,en pocas palabras lo que se explica en el hilo que he citado al principio)

una vez hecho esto he visto que el servidor DHCP si que esta recibiendo una configuración IP de parte de movistar, por lo que entiendo que la VLAN esta funcional, pero en el mangle no aparece ningún tipo de actividad (solo 6 paquetes y creo que los manda el router o el ata-SIP, no estoy seguro)
by RouterOS 6.48.3
# model = RB4011iGS+
/interface bridge
add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no comment=defconf dhcp-snooping=yes \
igmp-snooping=yes name=bridge
/interface ethernet
#wan de movistar
set [ find default-name=ether1 ] name=WANM
#wan de orange
set [ find default-name=ether2 ] name=WANO
/interface vlan
add interface=WANM name=MovistarInternet vlan-id=6
add interface=WANM name=MovistarTelefono vlan-id=3
/interface pppoe-client
add add-default-route=yes disabled=no interface=MovistarInternet \
keepalive-timeout=60 name=pppoe-movistar password=adslppp user=\
adslppp@telefonicanetpa
/interface ethernet switch port
set 0 default-vlan-id=0
set 1 default-vlan-id=0
set 2 default-vlan-id=0
set 3 default-vlan-id=0
set 4 default-vlan-id=0
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
set 10 default-vlan-id=0
set 11 default-vlan-id=0
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
add name=dhcp_pool1 ranges=\
192.168.2.2-192.168.2.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge name=dhcp1
/interface bridge port
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=sfp-sfpplus1
/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-pppoe=yes \
use-ip-firewall-for-vlan=yes
/ip neighbor discovery-settings
set discover-interface-list=dynamic
/ip settings
set tcp-syncookies=yes
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=WANM list=WAN
add interface=pppoe-out1 list=WAN
add interface=WANO list=WAN
/ip address
add address=192.168.2.1/24 comment=defconf interface=bridge network=\
192.168.2.0
add address=192.168.1.25/24 interface=WANO network=192.168.1.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=1m
/ip dhcp-client
add comment=defconf interface=WANM
add add-default-route=no disabled=no interface=MovistarTelefono use-peer-ntp=\
no
/ip dhcp-server network
add address=192.168.2.0/24 comment=defconf dns-server=8.8.8.8,1.1.1.1 \
gateway=192.168.2.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=1.1.1.1,8.8.8.8
/ip dns static
add address=192.168.2.1 comment=defconf name=router.lan
add address=10.34.255.134 name=telefonica.net
/ip firewall address-list
add address=192.168.1.0/24 list=statipwan
add address=192.168.2.1-192.168.2.255 list=lan
add address=***.***.***.*** disabled=yes list=statipwan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add action=drop chain=input comment="default configuration" in-interface=\
pppoe-movistar
add action=fasttrack-connection chain=forward connection-state=\
established,related
add chain=forward comment="default configuration" connection-state=\
established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" \
connection-state=invalid
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add action=drop chain=input comment="default configuration" in-interface=\
pppoe-movistar
add action=fasttrack-connection chain=forward connection-state=\
established,related
add chain=forward comment="default configuration" connection-state=\
established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" \
connection-state=invalid
add action=accept chain=input in-interface=MovistarTelefono src-address=\
10.26.0.0/18
/ip firewall mangle
add action=accept chain=prerouting dst-address-list=statipwan
add action=set-priority chain=postrouting new-priority=1 out-interface=\
pppoe-movistar
add action=set-priority chain=postrouting new-priority=4 out-interface=\
MovistarTelefono passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat dst-address-list="" src-address-list=lan
add action=masquerade chain=srcnat out-interface=pppoe-movistar
add action=masquerade chain=srcnat out-interface=MovistarTelefono
/ip firewall service-port
set ftp disabled=yes
set irc disabled=yes
set sip disabled=yes ports=5060,5061,5070
/ip route
add check-gateway=ping distance=1 gateway=pppoe-movistar
add check-gateway=ping distance=2 gateway=WANO
add distance=255 gateway=255.255.255.255
/ip upnp interfaces
add interface=bridge type=internal
add interface=pppoe-movistar type=external
/routing rip interface
add interface=MovistarTelefono passive=yes receive=v2
/routing rip network
add network=10.26.0.0/18
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Por cierto,se me olvido comentar que algo que me resulto extraño es que por lo que vi en el otro hilo movistar para la VoIP suele dar la ip 10.0.0.0/8 y a mi al cliente dhcp me manda la 10.26.5.85/18,no se si puede tener que ver con que no funcione
 
Última edición:
Tienes bastantes cosas raras en esa configuración. Pero sí, empezaría por dejar la 10.0.0.0/8 como dirección RIP.

Saludos!
 
/ip firewall service-port
set sip ports=5060,5061

Deja el sip como viene por defecto y prueba.

sip-default.png

Saludos.
 
Una pregunta, por curiosidad, las opciones del bridge que ponen "yes":

use-ip-firewall=yes
use-ip-firewall-for-pppoe=yes
use-ip-firewall-for-vlan=yes

¿las tienes puestas porque vas a usar colas o prioridades complejas o algo así? Es que en la config por defecto vienen en "no" todas ellas
 
Esas opciones son una cagada como un templo. No sólo te quedas sin hardware offloading, sino que pasas el tráfico por la CPU sin sentido.

Saludos!
 
Una pregunta, por curiosidad, las opciones del bridge que ponen "yes":

use-ip-firewall=yes
use-ip-firewall-for-pppoe=yes
use-ip-firewall-for-vlan=yes

¿las tienes puestas porque vas a usar colas o prioridades complejas o algo así? Es que en la config por defecto vienen en "no" todas ellas
eso lo tengo porque en principio tengo la intención de propagar la vlan 3 tambien por el switch gestionable,no solo por el router como esta ahora. solo que me estoy centrando en primero hacer que funcione en el router

aunque por lo que dices creo que puede que no sea eso.
 
eso lo tengo porque en principio tengo la intención de propagar la vlan 3 tambien por el switch gestionable,no solo por el router como esta ahora. solo que me estoy centrando en primero hacer que funcione en el router

aunque por lo que dices creo que puede que no sea eso.
Para pasar las vlans hacia abajo, basta con taggearlas en el puerto que toque. No obstante, ¿para qué tagguear las vlans del operador, más allá del puerto WAN donde se usen? Si luego tú quieres usar vlans en tu setup, hazlo, pero ¿las del operador?

Y no, esas líneas no valen para eso. Están haciendo que el tráfico local del bridge suba a la cpu, cosa que no debería hacer. Cuidado con copiar configuraciones que veis por internet sin saber lo que hacen, que te pueden llevar a un galimatías como el que tienes.

Saludos!
 
¿Cuál sería la intención exactamente de propagar la vlan 3 de movistar hacia tu red local?

Yo estuve dándole vueltas a la cabeza a eso. Pensé, por ejemplo, en desactivar el cliente dhcp del mikrotik en la vlan3, y permitir que sea el cliente DHCP del propio ATA el que reciba la dirección IP. De esa forma en principio se podría eliminar la regla masquerade en la vlan3.

Pero luego pensé: ¿y qué hago con el protocolo RIP? ¿cómo lo activo en el ATA? O, en su defecto, ¿cómo le añado las rutas estáticas?

Los ATA por lo general son muy simplones y no permiten ni protocolo RIP ni gestión de rutas estáticas ni nada de eso!
 
¿Cuál sería la intención exactamente de propagar la vlan 3 de movistar hacia tu red local?

Yo estuve dándole vueltas a la cabeza a eso. Pensé, por ejemplo, en desactivar el cliente dhcp del mikrotik en la vlan3, y permitir que sea el cliente DHCP del propio ATA el que reciba la dirección IP. De esa forma en principio se podría eliminar la regla masquerade en la vlan3.

Pero luego pensé: ¿y qué hago con el protocolo RIP? ¿cómo lo activo en el ATA? O, en su defecto, ¿cómo le añado las rutas estáticas?

Los ATA por lo general son muy simplones y no permiten ni protocolo RIP ni gestión de rutas estáticas ni nada de eso!
Exacto. Una vez tratas correctamente a nivel de router la vlan del voip, todo lo que penda del router tiene acceso a usar ese servicio. No tiene mucho sentido querer rehusar o propagar las mismas vlans hacia abajo.

Saludos.
 
Arriba