Ayuda con el siguiente SCRIPT muchachos

Tengo el siguiente script y me funciona muy bien

:global interfaceIP "ETHERT 1"
:global filenameIP "iphistory.txt"

:global arrMonths {jan="01";feb="02";mar="03";apr="04";may="05";jun="06";jul="07";aug="08";sep="09";oct="10";nov="11";dec="12"}
{
:local data [/system clock get date]
:local itime [/system clock get time]
:local hours [:pick $itime 0 2]
:local minsec [:pick $itime 2 8]
:local mhours [:tonum $hours]
:local msymbl "AM"
:if ($mhours > 11) do={:set msymbl "PM"}
:set mhours ($mhours % 12)
:if ($mhours = 0) do={:set mhours 12}
:if ($mhours < 10) do={:set mhours "0$mhours"}
:local mtime "$mhours$minsec $msymbl"
:global now "HORA:$mtime FECHA: $[:pick $data 4 6]-$($arrMonths->[:pick $data 0 3])-$[:pick $data 7 11]"
}
/file
:if ([:len [find where name="flash" and type="disk"]] = 1) do={:set filenameIP "flash/$filenameIP"}
:if ([:len [find where name=$filenameIP]] = 0) do={print file="$filenameIP"; :delay 5s; set $filenameIP contents=""}

:global currentIP
:if ([:len $currentIP] = 0) do={:set currentIP 0.0.0.0/0}
:local newIP [/ip address get [find interface="$interfaceIP"] address]
:set newIP [:pick $newIP 0 [:find $newIP "/" -1]]
:if ($newIP != $currentIP) do={
/file
:delay 5s
:local filecontent [get $filenameIP contents]
:local newfilecontent "NUEVA IP:$newIP\t$now\r\n$filecontent"
set $filenameIP contents=$newfilecontent
:set currentIP $newIP;
}


el problema lo tengo cuando hay algun corte electrico prolongado y el Routerboard no sincroniza la hora actual pasa lo siguiebte:

NUEVA IP:190.78.186.59 HORA:05:36:10 PM FECHA: 15-04-2022
NUEVA IP:186.95.45.220 HORA:04:17:51 PM FECHA: 06-04-2022
NUEVA IP:186.95.84.150 HORA:04:11:51 PM FECHA: 15-04-2022
NUEVA IP:186.95.13.112 HORA:03:48:20 PM FECHA: 15-04-2022
NUEVA IP:186.95.84.150 HORA:03:48:00 PM FECHA: 15-04-2022
NUEVA IP:186.95.45.220 HORA:12:03:40 PM FECHA: 15-04-2022
NUEVA IP:190.72.12.81 HORA:12:02:10 PM FECHA: 15-04-2022
NUEVA IP:186.95.13.112 HORA:12:01:10 PM FECHA: 14-04-2022
NUEVA IP:190.72.12.81 HORA:11:34:20 AM FECHA: 14-04-2022

como haria para que no registre en el archivo la ultima fecha en que se reinicio el RB? O sea la linea roja. Gracias por su ayuda.
 
Última edición:
Pon un cliente NTP a funcionar, tal que lo primero que haga el router al arrancar se sincronizar fecha/hora desde internet.

Saludos!
 
Si tienes activado IP -> Cloud, y marcada la opción "update time", se actualizará sólo. Eso en sí, ya es un cliente NTP.

Saludos!
 
Si ese no te da la hora lo suficientemente rápido, cámbialo por otro. Ejemplo:
Código:
/system ntp client
set enabled=yes
/system ntp client servers
add address=es.pool.ntp.org

Si estás en España, ese pool. Si estás en otro país, el que sea de tu país: www.pool.ntp.org

Saludos!
 
y tienes configurado en esa version un NTP Client alli?
yo tengo la version 6.49.4
¿Allí donde, en mi router? Sí, el que te mando, tal y como te lo mando. Tan pronto el equipo reinicia y se conecta a internet, corrige la hora, si se ha desincronizado.

Saludos!
 
 
y que mejoras tiene la version 7 con respecto a la version 6 amigo?
tengo un RB 750GL, me recomiendas actualizarlo a version 7?
 
Arriba