Ayuda para configuración Triple VLAN

Hola amigos.
Había abierto esta pregunta en el hilo de configuraciones básicas, pero me han recomendado abrir uno nuevo, así que, aquí estoy!

Sigo este foro desde hace tiempo, y ya hace años use la célebre configuración de Malosa en una vivienda anterior.
Ahora estoy utilizando la app de Movistar sobre una NVidia Shield y no el Desco, pero me gustaría ponerlo en marcha para evitar las limmitaciones de algunos canales o de dispositivos simultáneos viendo programas.
Mi problema es que tengo una instalación relativamente compleja (para mis conocimientos de comunicaciones...), y me gustaría confirmar que es posible (casi seguro...) y qué fichero de configuración debería usar antes de ponerme a enredar y romper todo... previo backup, claro ;-)

Mi instalación es la siguiente:
Comunicaciones.png


Los componentes:

- ONT: HUAWEI HG8240

- ROUTER: Mikrotik 850 Gx2, FW: 6.49.6 (Es el único sirviendo direcciones para toda la instalación)

- SWITCH1: UBNT EdgeSwitch 16

- SWITCH2: TPLink TL-SG108E (8 Port Gigabit Easy Smart Switch) (tiene una opción IGMP snooping)

- Conectados al SWITCH1 hay varios elementos como una NAS, 2PCs, 2 APs UniFi, Telefono Cisco IP, varias Raspberry Pi, etc.

- Conectados al SWITCH2 hay varios elementos como AppleTV, NVidia, Samsung TV, AP Linksys1900 con WRT, etc.

Pretendo conectar el DESCO de Movistar (HUMAX UHD) en el salón, es decir, al SWITCH2; sólo tengo un cable de red entre la despensa y el salón.

Como decía, me gustaría asegurarme de que puedo usar el DESCO y saber qué fichero de configuración debería utilizar.

Gracias por adelantado por vuestra ayuda
 
Hola amigos.
Había abierto esta pregunta en el hilo de configuraciones básicas, pero me han recomendado abrir uno nuevo, así que, aquí estoy!

Sigo este foro desde hace tiempo, y ya hace años use la célebre configuración de Malosa en una vivienda anterior.
Ahora estoy utilizando la app de Movistar sobre una NVidia Shield y no el Desco, pero me gustaría ponerlo en marcha para evitar las limmitaciones de algunos canales o de dispositivos simultáneos viendo programas.
Mi problema es que tengo una instalación relativamente compleja (para mis conocimientos de comunicaciones...), y me gustaría confirmar que es posible (casi seguro...) y qué fichero de configuración debería usar antes de ponerme a enredar y romper todo... previo backup, claro ;-)

Mi instalación es la siguiente:
Ver el adjunto 94284

Los componentes:

- ONT: HUAWEI HG8240

- ROUTER: Mikrotik 850 Gx2, FW: 6.49.6 (Es el único sirviendo direcciones para toda la instalación)

- SWITCH1: UBNT EdgeSwitch 16

- SWITCH2: TPLink TL-SG108E (8 Port Gigabit Easy Smart Switch) (tiene una opción IGMP snooping)

- Conectados al SWITCH1 hay varios elementos como una NAS, 2PCs, 2 APs UniFi, Telefono Cisco IP, varias Raspberry Pi, etc.

- Conectados al SWITCH2 hay varios elementos como AppleTV, NVidia, Samsung TV, AP Linksys1900 con WRT, etc.

Pretendo conectar el DESCO de Movistar (HUMAX UHD) en el salón, es decir, al SWITCH2; sólo tengo un cable de red entre la despensa y el salón.

Como decía, me gustaría asegurarme de que puedo usar el DESCO y saber qué fichero de configuración debería utilizar.

Gracias por adelantado por vuestra ayuda

Muy buenas. Entiendo que tienes contratado Movistar Plus en tu casa no?

Otra cosa, porque no le has subido a la v7 el firmware del mikrotik?

Ah, y para la configuración de la triple vlan, tienes en las chinchetas el manual de como hacerlo, perfectamente explicado… síguelo y lo tienes funcionando sin problemas… A mi me aparece el primero y pone: “configuraciones básicas ISP”
 
Última edición:
Muy buenas. Entiendo que tienes contratado Movistar Plus en tu casa no?

Otra cosa, porque no le has subido a la v7 el firmware del mikrotik?

Ah, y para la configuración de la triple vlan, tienes en las chinchetas el manual de como hacerlo, perfectamente explicado… síguelo y lo tienes funcionando sin problemas… A mi me aparece el primero y pone: “configuraciones básicas ISP”

Claro, claro, tengo M+ en esta casa. De hecho, enchufando el Deco con el router original funciona ;-)

Lo de la V7 pues porque creía que estaba con la última, tenía seleccionado en channel "stable" y no "upgrade", pero puedo actualizarlo sin problema.

Sobre el último punto, eso quería, confirmación de que no hay nada raro en mi red que impida usar esa configuración. Me pierdo con algunos aspectos de las comunicaciones...

Gracias por tus comentarios!
 
Claro, claro, tengo M+ en esta casa. De hecho, enchufando el Deco con el router original funciona ;-)

Lo de la V7 pues porque creía que estaba con la última, tenía seleccionado en channel "stable" y no "upgrade", pero puedo actualizarlo sin problema.

Sobre el último punto, eso quería, confirmación de que no hay nada raro en mi red que impida usar esa configuración. Me pierdo con algunos aspectos de las comunicaciones...

Gracias por tus comentarios!

No veo que tengas nada raro… ont, router, varios switch y dispositivos conectados a esos switch y al router.

De hecho, si tienes switch que soportan igmp snooping, no deberías de tener problemas tal cual tienes ahora mismo sin tocar nada… quiero decir, mis padres en su casa tienen el hgu de movistar, que esta en medio de la casa… de ahi sale un cable largo al salón de la casa que conecta con un switch, y a ese switch esta conectada la tv, un apple tv y un deco. Y funciona sin problemas.. y del hgu otro cable a otra habitación, de ahi a otro switch, y de ese switch, otro apple tv y otro deco…. Y lo mismo, funcionan perfectamente sin estar conectados directamente al hgu…

Así que no deberías de tener problemas en poner en marcha el setup indicado…
 
Ayer me puse a ello, y finalmente tengo el Desco de Movistar funcionando en mi red. Tal y como decías, @huzoazz, no he tenido problemas para hacerlo funcionar. Gracias a @furny por su configuración, a @pokoyo por su recopilatorio y a todos los que están por aquí resolviendo dudas.

Tengo no obstante un problemilla... Lo he visto mencionado por @furly, pero no sé cual es la solución, no me llegan mis conocimientos ;-). Es el siguiente:

Tengo el desco conectado con un switch al eth2. De ese switch cuelgan otros equipos, y estos reciben una dirección 192.168.77.xx. Necesitaría que tuvieran una dirección tipo 192.168.1.xx para poder acceder a ellos. ¿Cómo puedo conseguirlo?

Gracias de nuevo!
 
Ayer me puse a ello, y finalmente tengo el Desco de Movistar funcionando en mi red. Tal y como decías, @huzoazz, no he tenido problemas para hacerlo funcionar. Gracias a @furny por su configuración, a @pokoyo por su recopilatorio y a todos los que están por aquí resolviendo dudas.

Tengo no obstante un problemilla... Lo he visto mencionado por @furly, pero no sé cual es la solución, no me llegan mis conocimientos ;-). Es el siguiente:

Tengo el desco conectado con un switch al eth2. De ese switch cuelgan otros equipos, y estos reciben una dirección 192.168.77.xx. Necesitaría que tuvieran una dirección tipo 192.168.1.xx para poder acceder a ellos. ¿Cómo puedo conseguirlo?

Gracias de nuevo!
Usa el DHCP condicional, identificando los tipos de dispositivos, para que sólo le de la subred de IPTV al desco, y no al resto de cacharros. De la config de furny, este cacho:

Código:
# Asignamos el vendor-class al nuevo servidor IPTV, para los descos
/ip dhcp-server vendor-class-id
add address-pool=pool-iptv-descos name="Movistar Descos" server=dhcp-server-iptv vid="[IAL]"

... etc

Saludos!
 
Usa el DHCP condicional, identificando los tipos de dispositivos, para que sólo le de la subred de IPTV al desco, y no al resto de cacharros. De la config de furny, este cacho:

Código:
# Asignamos el vendor-class al nuevo servidor IPTV, para los descos
/ip dhcp-server vendor-class-id
add address-pool=pool-iptv-descos name="Movistar Descos" server=dhcp-server-iptv vid="[IAL]"

... etc

Saludos!
Hola pokoyo. Las líneas que has puesto las tengo, he utilizado la conf de furny.

Quieres decir que tengo que poner algo similar para cada tipo de dispositivo (buscar el vendor Class ID; he visto como hacerlo en la wiki con debug "system logging add topics=dhcp") pero apuntando al pool y server defconf?
O sea, no hay manera de hacer que por defecto se conecten todos a la defconf excepto el desco?

Gracias,
 
He estado intentando que los dispositivos que tengo conectados al switch en eth2 recibieran una dirección 192.168.1.xx en lugar de 192.168.77.xx (la de IPTV subnet for hosts), pero no he sido capaz. Si cambiaba el address pool de dhcp-server-iptv de pool-iptv-hosts a dhcp, recibían una dirección 192.168.1, pero no podían resolver direcciones ni yo acceder a ellos desde mi PC con dirección 192.168.1.3. El desco sin embargo funcionaba, supongo que porque la regla del Vendor Class "corregía" la asignación a una ip correcta.

Tengo que estudiar más...

Os dejo mi configuración por si podéis echarle un vistazo, aunque es básicamente la que resulta de la guía de @furly.

Código:
# apr/26/2022 00:49:09 by RouterOS 6.49.6
# software id = UBEG-LBMV
#
# model = 850Gx2
# serial number = 
/interface bridge
add admin-mac=E4:8D:8C:0E:44:3C auto-mac=no comment=defconf name=bridge \
    protocol-mode=none
add igmp-snooping=yes name=bridge-iptv
/interface vlan
add interface=ether1 name=internet-vlan6 vlan-id=6
add interface=ether1 name=iptv-vlan2 vlan-id=2
add interface=ether1 name=voip-vlan3 vlan-id=3
/interface pppoe-client
add add-default-route=yes allow=pap,chap disabled=no interface=internet-vlan6 \
    keepalive-timeout=60 max-mru=1492 max-mtu=1492 name=pppoe-out1 \
    use-peer-dns=yes user=adslppp@telefonicanetpa
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
add comment="Vlan2 (Iptv) & Vlan3 (Voip)" name=Vlan2&3
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server option
add code=240 name=option_para_deco value=\
    "':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
/ip pool
add name=dhcp ranges=192.168.1.201-192.168.1.254
add name=pool-iptv-descos ranges=192.168.77.201-192.168.77.206
add name=pool-iptv-hosts ranges=192.168.77.50-192.168.77.199
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
add address-pool=pool-iptv-hosts disabled=no interface=bridge-iptv name=\
    dhcp-server-iptv
/interface bridge port
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge-iptv interface=ether2
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add list=WAN
add interface=pppoe-out1 list=WAN
add interface=iptv-vlan2 list=Vlan2&3
add interface=voip-vlan3 list=Vlan2&3
add interface=bridge-iptv list=LAN
/ip address
add address=192.168.1.1/24 comment=defconf interface=bridge network=\
    192.168.1.0
add address=10.xx.yy.zz/9 comment="My Telefonica's IPTV address" interface=\
    iptv-vlan2 network=10.0.0.0
add address=192.168.77.1/24 comment="IPTV subnet" interface=bridge-iptv \
    network=192.168.77.0
/ip dhcp-client
add comment=defconf interface=ether1
add add-default-route=no disabled=no interface=voip-vlan3 use-peer-ntp=no
/ip dhcp-server lease
add address=192.168.1.4 client-id=1:fc:ec:da:16:5d:a3 comment="Unifi P.Baja" \
    mac-address=FC:EC:DA:16:5D:A3 server=defconf
add address=192.168.1.5 client-id=1:fc:ec:da:16:5c:75 comment="Unifi P1" \
    mac-address=FC:EC:DA:16:5C:75 server=defconf
add address=192.168.1.16 client-id=1:b8:27:eb:af:4e:ae comment="IoT - PiLCD" \
    mac-address=B8:27:EB:AF:4E:AE server=defconf
add address=192.168.1.40 always-broadcast=yes client-id=1:88:87:17:85:f6:75 \
    comment="Canon MG6200" mac-address=88:87:17:85:F6:75 server=defconf
add address=192.168.1.83 always-broadcast=yes comment="IoT - ledsCocina" \
    mac-address=A0:20:A6:14:BA:FA server=defconf
.... omitidas unas cuantas fijas más ....

/ip dhcp-server network
add address=192.168.1.0/24 comment=defconf dns-server=192.168.1.1 gateway=\
    192.168.1.1 netmask=24
add address=192.168.77.0/24 comment="IPTV subnet for hosts" gateway=\
    192.168.77.1 netmask=24
add address=192.168.77.200/29 comment="IPTV subnet for descos" dhcp-option=\
    option_para_deco dns-server=172.26.23.3 gateway=192.168.77.1 netmask=24
/ip dhcp-server vendor-class-id
add address-pool=pool-iptv-descos name="Movistar Descos" server=\
    dhcp-server-iptv vid="[IAL]"
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.1.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
    in-interface=iptv-vlan2 protocol=igmp
add action=accept chain=input comment=\
    "Accept vlan2 & 3  (Iptv & Voip) multicast & broadcast traffic" \
    dst-address-type=!unicast in-interface-list=Vlan2&3
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add action=drop chain=forward comment=\
    "Drop all new unicast traffic from vlan3 & 2 (Voip & Iptv) not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new dst-address-type=\
    unicast in-interface-list=Vlan2&3
/ip firewall mangle
add action=set-priority chain=postrouting comment="Prioritise Voip packets" \
    new-priority=5 out-interface=voip-vlan3 passthrough=yes
add action=set-priority chain=postrouting comment="Prioritise Iptv packets" \
    new-priority=4 out-interface=iptv-vlan2 passthrough=yes
add action=set-priority chain=postrouting new-priority=1 out-interface=\
    pppoe-out1
add action=add-src-to-address-list address-list=vod-receiver \
    address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" \
    connection-state=new dst-port=554 out-interface=iptv-vlan2 protocol=tcp
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment=\
    "masq. vlan2 & vlan3 (Iptv & Voip)" out-interface-list=Vlan2&3
add action=masquerade chain=srcnat comment="masq. IPTV hosts" src-address=\
    192.168.77.0/24
add action=dst-nat chain=dstnat comment="JMB para DiskStation" dst-port=\
    5000-5001 protocol=tcp to-addresses=192.168.1.70 to-ports=5000-5001
add action=dst-nat chain=dstnat disabled=yes dst-port=80 protocol=tcp \
    to-addresses=192.168.1.70
add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local \
    in-interface=iptv-vlan2 to-addresses=192.168.77.205
/routing igmp-proxy
set query-interval=30s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=iptv-vlan2 upstream=yes
add interface=bridge-iptv
/routing rip interface
add interface=voip-vlan3 passive=yes receive=v2
add interface=iptv-vlan2 passive=yes receive=v2
/routing rip network
add network=10.0.0.0/8
add network=172.26.0.0/16
/system clock
set time-zone-name=Europe/Madrid
/system logging
add disabled=yes topics=dhcp
/system scheduler
add interval=6s name=vod on-event=vod policy=read,write start-time=startup
/system script
add dont-require-permissions=no name=vod owner=admin policy=read,write \
    source=":local iplist [:len [/ip firewall address-list find list=\"vod-rec\
    eiver\"]]\
    \n:local rules [:len [/ip firewall nat find where comment=\"VOD Script\"]]\
    \n#:log info \"VODScript: IPs in list are \$iplist !\"\
    \n#:log info \"VODScript: Rules are \$rules !\"\
    \n:if (\$iplist = 0 and \$rules > 0) do={\
    \n\t#/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t#:log info \"VODScript: Rule removed !\"\
    \n} else {\
    \n\t:local ipadressnew [/ip firewall address-list get [:pick [/ip firewall\
    \_address-list find list=\"vod-receiver\"] (\$iplist-1)] address]\
    \n\t:local ipadressold \"None\"\
    \n\t#:log info \"VODScript: IP address new is \$ipadressnew !\"\
    \n\t:if (\$iplist > 0 ) do {\
    \n\t\tif (\$rules > 0 ) do {\
    \n\t\t\t:set ipadressold [/ip firewall nat get [find comment=\"VOD Script\
    \"] to-addresses] \
    \n\t\t\t#:log info \"VODScript: IP address old is \$ipadressold !\"\
    \n\t\t}\
    \n\t\t:if (\$ipadressnew != \$ipadressold) do={\
    \n\t\t\tif (\$rules > 0 ) do {\
    \n\t\t\t\t/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t\t\t}\
    \n\t\t\t/ip firewall nat add action=dst-nat chain=dstnat comment=\"VOD Scr\
    ipt\" dst-address-type=local in-interface=iptv-vlan2 to-addresses=\$ipadre\
    ssnew\
    \n\t\t\t:log info \"VODScript: IP address changed from \$ipadressold to \$\
    ipadressnew !\"\
    \n\t\t}\
    \n\t}\
    \n}"
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
Arriba