Catalina es compatible con apps de otras versiones anteriores?

Hola, hace unos días la tarjeta de wifi de mi MacBook Pro ( 2008 )se ha dañado y ya no funciona. Estoy por comprar un adaptador usb Tp-link Tl-wn725n pero sus versiones de drivers para Mac van desde la 10.11 a 10.6 y yo estoy usando Mac Os Catalina 10.15.7. Mi pregunta es, es compatible la instalación de estos drivers aunque tenga esa versión? Agradezco a quien pueda ayudarme, soy muy novato en los Mac y este recién me lo regalaron y quiero darle un buen uso.
 
Arriba