Smartphone no conecta a wi-fi pide inicio de sesión.

#1
Smartphone no conecta a wi-fi pide inicio de sesión.
Hola buenas tardes. Ante todo, dar las gracias por este foro, es muy ilustrativo.
A ver si me podéis echar una mano en solucionar un problema con la conexión wi-fi.
Me explico. A petición de mi mujer instale un segundo router (LiveBox arcadyan model: PVR3399B-B-LT, el que instala Jazztel) en la habitación para ampliar la red wi-fi pues el principal que está en el salón no tiene suficiente potencia para cubrir todo el piso y eso que es pequeño. La conexión entre ambos router es por cable ethernet y he conseguido extender la red wi-fi al 100% y mi esposa loca de contenta pues ya no tiene cortes de conexión ni le va lento, hasta aquí todo bien y felices pero mi dolor de cabeza es que no soy capaz de conectar mi Smartphone al segundo router LiveBox, el Galaxy S7 de mi mujer se conectó sin problemas desde el primer momento, sin embargo el mío un Galaxy S8 no soy capaz a tener red internet porque conexión si tengo, cada vez que conecta el wifi al router sale el mensaje “Sistema Android. Inicie sesión red wifi” le doy en el mensaje y me lanza a la página de configuración del router y puedo navegar e incluso modificar la configuración del router pero solo puedo navegar por la configuración del router, por la red internet no puedo porque de esta página no puedo salir, dicha página tiene un botón con 3 opciones:
1º Desconectar de la red.
2º Mantener conexión.
3º Abrir en el navegador.
Con ninguna opion he conseguido navegar. Lo curioso que el primer día que me conecte lo hizo sin problemas y le hice un test de velocidad y como un avión, pero cuando Salí y perdí la conexión y al volver me intente conectar me pide que inicie sesión.
Buscando en google, veo que es un problema de seguridad del móvil, pero tampoco explican cómo solucionarlo y ya no se me ocurre que puedo hacer más. En los router tengo el rango dividido en 2 para que distribuya las IP por DHCP para que no coincidan las ip, he probado a cambiar de canal wifi y ponerlo en auto, también probé cambiando el tipo de autentificación e incluso ponerlo sin contraseña y nada me sigue pidiendo que inicie sesión. Estaría muy agradecido me ayudarais a solucionarlo, gracias.

3 configuracion y conexion router.PNG
2 opciones.PNG
 
Arriba