Vlc entrelazado paff y ps3

Hola, buenas, os queria comentar, que estoy teniendo algunos problemas para ver imagenio en la ps3, la uso mas que nada para hacer volcados, pero con el nuevo entrelazado, se me cierra el vlc! No es problema de nada mas! Ya que el descodificador esta en el canal bloqueado(hay ancho de banda!) y esta todo bien configurado, el tema es que siguiendo los dos manuales que hay en la web, no consigo solucionar nada, No se si hay que hacer algo extraordinario por ser la ps3...
Por si os interesa en la consola al cerrarse el vlc, me da un fallo de segmentacion y core dumped...
P.D:La pregunta va mas que nada para homer512 porque se que el tiene imagenio y es el autor de uno de los how-to`s
Gracias! :p
 
Hola rafius, no te rompas la cabeza ahora mismo ya que lo que postee para linux a dejado de funcionar :devilish: :devilish: , antes de que se me fastidiara el ubuntu estuve trasteando con distintas versiones de vlc de ffmpeg, y no conseguí nada.

incluso estuve emulando el vlc de compilo cosimo por wine y tampoco. lo único que me quedo por hacer es emular xp con virtualbox y hacerlo desde allí, pero no me dio tiempo. :( :(

Ahora mismo estoy con PCLinux y cuando tenga tiempo ya tanteare.

Saludos y felices fiestas. ;)

P.D. si te enteras de algo. comunicamelo :p
 
Ah ok! pues yo con wine y el vlc de cosimo, vi el barça madrid...(en el portatil...) Pues nada aver si lo solucionamos! jeej
Gracias! y felices fiestas
Gracias! :p
 
¿? Yo uso openSUSE 10.3 (que se puede instalar en la PS3) y no tengo problema alguno para ver Imagenio con H264.
El repositorio de Packman incluye un vlc 0.8.6d (sí, también para PPC) enlazado contra un libavcodec del 29 de diciembre (ayer), que se va actualizando, con lo cual no hay problema alguno. Vamos, que es que yo nunca he llegado a quedarme sin Imagenio, tuve el problema mientras estaban haciendo la migración pero para cuando acabó yo ya lo veía bien... pensaba que todo el mundo estaba igual.

En cualquier caso el truco es sólo ese, usar un ffmpeg actualizado que ya soporta PAFF. Si tu distro no lo tiene empaquetado es sólo cuestión de compilarlo uno mismo. Nunca he compilado el VLC, aunque será cuestión de ./configure && make y poco más, pero el mplayer sí que lo he compilado y esté puedo asegurar que no tienen ningún truco... como mucho habrá que hacer un "./configure --use-external-ffmpeg" o algo parecido.

De hecho si el VLC de vuestra Ubuntu enlaza dinámicamente contra libavcodec no hace falta ni recompilar el VLC (si no ha cambiado el SONAME), sólo hay que sustituir el libavcodec por uno más reciente.

La que he liado pensando que estaba logueado... sorry.

editado por Homer512, Arreglado ;)
 
Vale, reddrawf, me he liado un poquillo, de donde consigo el ffmpeg para compilar...? Conseguí uno, lo compile y nanai!
Me podrias dar un enlaze, o alguna cosa...?
Muchisimas gracias! :p
 
Bueno, para empezar deberías mirar contra que versión de libavcodec/ffmpeg enlaza tu VideoLAN.
~> ldd /usr/lib64/vlc/codec/libffmpeg_plugin.so | grep avcodec
libavcodec.so.51 => /usr/lib64/libavcodec.so.51 (0x00002ac1b9705000)
Lo importante es ese "51". Si tu versión de VideoLAN te da un número menor entonces tendrás que recompilar todo el VideoLAN, no sólo el libavcodec. Tu paquete puede instalar el archivo en otro directorio, el caso es que tienes que hacer "ldd libffmpeg_plugin.so".
Si hay suerte y sólo tienes que compilar el libavcodec yo lo que haría sería intenta crear un archivo .deb actualizado... así no enguarras tu instalación y puedes compartirlo con otros usuarios fácilmente.
- Te vas a http://packages.ubuntu.com/gutsy/source/ffmpeg y descargas los archivos necesarios para crear el paquete que viene en Ubuntu
- Te descargas la última versión de "http://ffmpeg.mplayerhq.hu/ffmpeg-export-snapshot.tar.bz2", tal y como pone en http://ffmpeg.mplayerhq.hu/download.html
- Con esto buscas en Google "como crear paquetes deb" y lo haces (yo sé con RPMs, pero ni idea de DEBs). En http://www.ubuntu-es.org/node/11143 mismo tienes una guia.

Si lo de crear el paquete deb se te hace muy complicado simplemente descarga el ffmpeg-export-snapshot.tar.bz2 y haz el típico ./configure && make. El configure seguro que tiene muchas opciones según que formatos quieras soportar. Un "./configure --help" primero sería prudente.
 
Hola, gracias por la paciencia primero de todo.
Te cuento, le tiro el comando que me has dicho y me contesta que lib64 no existe, oseaser que no tengo la carpeta lib64 sino lib asecas(como de 32 bits) y me digo pues bueno, un simple fallo no me para! pongo tu comando pero en /usr/lib/... y me contesta:
Código:
libavcodec.so.1d => /usr/lib/libavcodec.so.1d (0xb79fe000)
:cautious: :cautious:
1d, es menos que 51...? no...? Total que digo bueno, tendria que recompilar todo el vlc, pero voy a probar compilando ese ffmpeg actualizado(por cierto muchisimas gracias porque no lo encontrava) ./configure && make && sudo make instal. Tarda su tiempo, y al finalizar, pruebo el vlc y DUMP de nuevo! Que hago ahora...? Desinstalo el vlc que tengo completamente y compilo uno con h264 y paff... El problema de siempre, donde lo encuentro....
Gracias por la paciencia
Gracias! :p
 
Lo de lib64 vs lib ya me lo esperaba. Debian usa un sistema "raro" para gestionar los sistemas de 64bits, da igual.
Lo de 1d... la madre que parió a Debian y sus dichosas "mejoras"!!!. Si te miras el fichero "ffmpeg_0.cvs20070307-5ubuntu4.diff.gz" de http://packages.ubuntu.com/gutsy/source/ffmpeg verás que Debian/Ubuntu cambia el archivo libavcodec/avcodec.h con
+-#define LIBAVCODEC_VERSION 51.38.0
++#define LIBAVCODEC_VERSION 1d.51.38.0
Vamos, que le añaden un "1d." delante por algún motivo (probablemente no se fían de lo de ffmpeg). La buena noticia es que viendo ese archivo queda confirmado que *no* hace falta recompilar el VLC (aunque lo hayan renombrado un 51 siempre será un 51).

El caso es que como han cambiado el nombre la versión que has compilado no sirve. Si no vas a intentar crear el deb, de todas formas intenta aplicar el parche (el .diff) antes de compilar. Si no puedes aplicar el parche como mínimo tienes que hacer eso, cambiar el "51." por un "1d.51." en libavcodec/avcodec.h.
 
En serio me estas ayudando muchisimo jeej
Entonces, cambio 51 por 1d.51. y vuelvo a compilar....?
Muchisimas gracias, voy a probar!
Gracias! :p
 
Sólo es descomprimir ffmpeg-export-snapshot.tar.bz2 y cambiar el archivo libavcodec/avcodec.h con tu editor favorito. Por seguridad también hazlo con libavutil/avutil.h, libpostproc/postprocess.h, libswscale/swscale.h y libavformat/avformat.h. Al principio de todos ellos hay una línea tipo "#define LIBAVCODEC_VERSION 51.49.0" que tienes que dejar como "#define LIBAVCODEC_VERSION 1d.51.49.0".
He visto que el en parche hay otra cosa donde se añade "1d"... es algo necesario si vas a crear el deb, pero no se si influirá al compilarlo a mano.

Una vez editado esto es sólo volver a compilarlo. Simplemente comprueba que crea un fichero "libavcodec.so.1d" y no un "libavcodec.so.51".
Al final tienes que ver que mientras ahora /usr/lib/libavcodec.so.1d es un enlace simbólico que apunta a /usr/lib/libavcodec.so.1d.51.38.0, después de instalar apunta a /usr/lib/libavcodec.so.1d.51.49.0.
 
Tio, te quiero! Perfecto, solo me ha saltado en un canal, los demas todos perfectos, la sexta, fox en los anuncios, etc... Perfectiiisimooo!
Muchisimas gracias! Solucionado,
Si los adimins quieren, y cuando tenga tiempo, hago un how-to de como hacerlo con capturas y tal ejej
Gracias! :p
 
Buenas, pues voy a sacar el hilo a flote otra vez! porque la cosa no esta solucionada del todo! No he tenido mucho tiempo para probarlo, pero ahora que empiezo a tener mas tiempo, sigue dando dumps! en menor medida pero sigue!
Invoco a redrawf entre otros a ver si lo solucionamos! jeje
Siento ser pesado jeej
Gracias! :p
 
Código:
lrwxrwxrwx 1 root root 24 2007-10-19 21:00 /usr/lib/libavcodec.so.1d -> libavcodec.so.1d.51.38.0
Creo que a la 38... y eso significa...! jejeje
Gracias!:p
 
La 38 es la que viene con Ubuntu, la vieja que da problemas. La que compilas y que funcionará es la 49. No has llegado a instalar la nueva y por eso sigue fallando.

No se, lo mismo al hacer "make install" lo copia en /usr/local/lib/ en vez de en /usr/lib/... o en cualquier otra parte, vete a saber.
Si ves que la versión 49 la tienes en /usr/local/lib/ es cuestión de cambiarla de sitio (y corregir el enlace simbólico). Y en tal caso para que lo copiase directamente en el lugar correcto al hacer el "make install" habría que hacer "./configure --prefix=/usr".
 
voy a hacer ./configure --prefix=/usr y a ver que pasa jeej
Muchas gracias por la paciencia
Gracias! :p
 
Vale, ./configure --prefix=/usr no soluciona nada! he mirado y en usr/local/lib estan los archivos:
/usr/local/lib/libavcodec.a
/usr/local/lib/libavdevice.a
/usr/local/lib/libavformat.a
/usr/local/lib/libavutil.a
/usr/local/lib/libdausng.a
/usr/local/lib/libdausng.la
/usr/local/lib/libdausng.so
/usr/local/lib/libdausng.so.0
/usr/local/lib/libdausng.so.0.0.0
Son esos?
Los he movido a /usr/lib pero... que enlace simbolico corrijo?
Gracias! :p
 
"libavcodec.a" es una librería estática, para este caso no nos vale.
Me lo he descargado yo a ver que pinta tiene. Sólo he ejecutado el ./configure, pero de momento yo lo dejaría así:
./configure --prefix=/usr --enable-shared --disable-static
Veras que ahora al ejecutarlo dice:
Código:
install prefix            /usr
...
static                    no
shared                    yes

Con esto estoy bastante convencido de que ya conseguirás instalarlo. Pero asegurate de que tienes instaladas las librerías para poder tener soporte para MP3 y H.264... si no tendrás una librería actualizada, pero inútil. Comprueba que dice en "Enabled decoders:", "Enabled protocols:", "Enabled outdevs:", etc.

Además si ejecutas "./configure --help" verás opciones que te pueden interesar.
Código:
  --enable-gpl             allow use of GPL code, the resulting libav*
                           and ffmpeg will be under GPL [default=no]
  --enable-nonfree         allow use of nonfree code, the resulting libav*
                           and ffmpeg will be unredistributable [default=no]
  --enable-pp              enable GPLed postprocessing support [default=no]
  --enable-swscaler        software scaler support [default=no]

  --enable-liba52          enable GPLed liba52 support [default=no]
  --enable-liba52bin       open liba52.so.0 at runtime [default=no]
  --enable-avisynth        allow reading AVISynth script files [default=no]
  --enable-libamr-nb       enable libamr-nb floating point audio codec
  --enable-libamr-wb       enable libamr-wb floating point audio codec
  --enable-libdc1394       enable IIDC-1394 grabbing using libdc1394
                           and libraw1394 [default=no]
  --enable-libfaac         enable FAAC support via libfaac [default=no]
  --enable-libfaad         enable FAAD support via libfaad [default=no]
  --enable-libfaadbin      open libfaad.so.0 at runtime [default=no]
  --enable-libgsm          enable GSM support via libgsm [default=no]
  --enable-libmp3lame      enable MP3 encoding via libmp3lame [default=no]
  --enable-libnut          enable NUT (de)muxing via libnut,
                           native demuxer exists [default=no]
  --enable-libtheora       enable Theora encoding via libtheora [default=no]
  --enable-libvorbis       enable Vorbis encoding via libvorbis,
                           native implementation exists [default=no]
  --enable-libx264         enable H.264 encoding via x264 [default=no]
  --enable-libxvid         enable Xvid encoding via xvidcore,
                           native MPEG-4/Xvid encoder exists [default=no]

  --list-decoders          show all available decoders
  --list-encoders          show all available encoders
  --list-muxers            show all available muxers
  --list-demuxers          show all available demuxers
  --list-parsers           show all available parsers
  --list-protocols         show all available protocols
  --list-bsfs              show all available bitstream filters
  --list-indevs            show all available input devices
  --list-outdevs           show all available output devices
 
Arriba