DoH Pi-hole (SOLUCIONADO)

Quieres que pruebe a montarlo en mi pi-hole? No tenía pensado tener DoH a nivel de pi-hole, pero lo puedo hacer si quieres.

Saludos!
 
Buenas @Otro+ y @pokoyo,

Lo acabo de terminar aunque sin raspberry pi, he entrado en distrowatch.com y en este mismo foro, y no tengo anuncios, de manera que creo que esta bien hecho.
(Lo tengo hecho en debian10 i386)
Captura de pantalla -2020-12-23 03-57-24.png

Todo en verde.

Captura de pantalla -2020-12-23 04-00-02.png

Tengo el IPv6 desactivado.
En el DoT y DoW me sale no, pero supongo que es normal.

Captura de pantalla -2020-12-23 04-06-46.png

Esto es lo que tengo en el mikrotik. Donde 192.168.88.8 es el debian donde esta pi-hole.

En el navegador (uso firefox) entre en about:config y puse las variables: network.security.esni.enabled en true y network.trr.mode en 2.

La configuracion dns de pi-hole:


Captura de pantalla -2020-12-23 04-25-39.png


ampliandolo:

Captura de pantalla -2020-12-23 04-22-18.png


Captura de pantalla -2020-12-23 04-23-34.png


Ahora leeré el hilo entero para ver si identifico tu problema y con suerte te puedo ayudar...

EDICION: No se cual puede ser tu problema @Otro+...
 

Adjuntos

  • Captura de pantalla -2020-12-23 04-22-18.png
    Captura de pantalla -2020-12-23 04-22-18.png
    136.9 KB · Visitas: 63
Última edición:
Ojo, no hace falta que metas DoH en los dos sitios. De hecho, como nos avisaron de un posible bug en mikrotik con el DoH y la tabla de caché, te diría que de momento lo metas solo en el pi-hole y este lo uses como dns primario, dejando tu propio router como secundario sin DoH. Al menos hasta que se aclare si el bug es tal o no, en la propia release de RouterOS.

Saludos!
 
Ojo, no hace falta que metas DoH en los dos sitios. De hecho, como nos avisaron de un posible bug en mikrotik con el DoH y la tabla de caché, te diría que de momento lo metas solo en el pi-hole y este lo uses como dns primario, dejando tu propio router como secundario sin DoH. Al menos hasta que se aclare si el bug es tal o no, en la propia release de RouterOS.
Ok, gracias por avisar, así lo he hecho.
 
Que eso sólo es válido para el firefox, si usas cualquier otro navegador no te asiste
También algunos que derivan de firefox, para android por ejemplo tenemos fennec que ademas es libre (se puede encontrar en f-droid.org), para linux: abrowser, iceweasel, icecat (este ultimo llevan tiempo sin actualizarlo), y algunos derivados mas.
Pero si, Los otros 3 gordos: chrome, safari y edge, creo que en ellos por ahora no se puede. No han habilitado todavía ese standard.
ESNI no es compatible con pihole
si, claro, eso hay que ponerlo en cada uno de los navegadores que uses y no en el pi hole.
 
También algunos que derivan de firefox, para android por ejemplo tenemos fennec que ademas es libre (se puede encontrar en f-droid.org), para linux: abrowser, iceweasel, icecat (este ultimo llevan tiempo sin actualizarlo), y algunos derivados mas.
Pero si, Los otros 3 gordos: chrome, safari y edge, creo que en ellos por ahora no se puede. No han habilitado todavía ese standard.

si, claro, eso hay que ponerlo en cada uno de los navegadores que uses y no en el pi hole.
Lo que yo busco es que la raspi se comporte con DoH siendo sólo la raspi, sin tocar la config en los cacharros que "dependen" de la raspi

Configurar equipo por equipo no es una solución deseada

Saludos
 
Lo que yo busco es que la raspi se comporte con DoH siendo sólo la raspi, sin tocar la config en los cacharros que "dependen" de la raspi

Configurar equipo por equipo no es una solución deseada
¿Entonces lo que buscas es filtrar el DNS en la propia raspberry 4, solo para que se autoabastezca de un DNS limpio, siendo autosuficiente?

Disculpa, ahora lo pillo, lo había entendido al revés.

Espero que tengas suerte.

Ya nos contarás.

Saludos.
 
Última edición:
1613663237183.png

1613663289455.png

Hola estoy poniendo el DOH de Cloudflare y veo que ciertas partes me salen aún mal. ¿A que puede ser debido y como puedo corregirlo?

Gracias.
 
Prueba con un navegador compatible, tipo Firefox, y te saldrá esa también en verde.

Saludos!
 
Prueba con un navegador compatible, tipo Firefox, y te saldrá esa también en verde.

Saludos!
Hola, acabo de probar el Firefox ni tampoco se me pone el cuarto en verde. ¿ Hay que configurar algo en firefox, Edge o chorme?

Sobre la segunda foto que puse lo ves bien? He visto más que cambiaba el nombre de cloudflare data center, supongo que no tiene importancia.

Saludos.
 
Por si sirve de algo, yo lo tengo como comenta @pokoyo:

No uso Pi-Hole sino AdGuard, pero es lo mismo.
Osea el Agujero pregunta al DOH del Mikrotik y este a Cloudflare.

Firefox quitó el ESNI en la versión 85, y ahora usa ECH.
Con lo cual ya no se puede modificar en los seteos de firefox.

Y todo va de perlas.
Saludos.
 

Adjuntos

  • Captura de pantalla de 2021-05-26 19-03-07.png
    Captura de pantalla de 2021-05-26 19-03-07.png
    165.5 KB · Visitas: 31
  • Captura de pantalla de 2021-05-26 19-04-53.png
    Captura de pantalla de 2021-05-26 19-04-53.png
    132.4 KB · Visitas: 31
  • Captura de pantalla de 2021-05-26 19-12-02.png
    Captura de pantalla de 2021-05-26 19-12-02.png
    38.6 KB · Visitas: 28
Última edición:
Arriba