Tomato Firmware 1.2x ... Hilo nº9. Solo usuarios registrados

Estado
Cerrado para nuevas respuestas.
Me autocito:

Lantzi dijo:
P.D.: ¡¡tremendo firm!! Victek no se si prefiero que saques nueva versión o que se quede como está.

¿Pero realmente se puede hacer una versión mejor que esta?...

...tal vez si el firm incluyera el decodificador de nagraX... ;) ;) ;)
 
Hola a todos,

Soy nuevo en este foro, y por eso, en primer lugar, quiero felicitaros por su contenido (es muy instructivo) y de modo especial a Victek por su fantástico firmware.

Tengo dos dudas, a ver si me las podéis resolver:

1. ¿Hay alguna versión del firmware que incorpore 'páginas blancas'? He leído los post referidos al tema (los que he encontrado explican cómo hacerlo con iptable), pero estoy buscando algo más elaborado, al estilo de las restricciones de acceso, que permita definir reglas para determinadas IPs, por horas, etc.

2. Aunque soy nuevo en los firmware para routers, tengo cierta experiencia en el uso de Tomato y en programación de sistemas embebidos. Por eso me lancé a intentar compilar el firmware RAF de Victek con la idea de estudiar el código y tratar de realizar yo mismo un mod con páginas blancas, pero no consigo compilar ni siquiera el original. Siguiendo varias guías (todas ellas muy similares) siempre llego al mismo problema: por algún motivo no se encuentra el fichero .config de configuración del kernel, y me inicia siempre el menú de configuración por línea de comandos. Copio aquí la salida de make (sólo las últimas líneas):

Código:
make[4]: Entering directory `/root/toolchain/WRT54GL-US_v4.30.11_11/release/src/linux/linux'
rm -f include/asm
( cd include ; ln -sf asm-mips asm)
/bin/sh scripts/Configure -d arch/mips/config.in
#
# Using defaults found in .config
#
scripts/Configure: line 556: .: .config: file not found
scripts/Configure: line 558: .: .config-is-not.16248: file not found
*
* Code maturity level options
*
Prompt for development and/or incomplete code/drivers (CONFIG_EXPERIMENTAL) [N/y/?] (NEW)
Aunque he conseguido superar este problema con algún parche manual (por ejemplo, definiendo el contenido de .config explícitamente en el Makefile de linux), la compilación nunca concluye con éxito, siempre surge algún otro problema. Supongo que se trata de algo relacionado con el sistema host que estoy usando para compilar.

Estoy trabajando con Ubuntu 10.04. Tengo corregido el shell a bash (ya lo tenía previamente), y estoy casi seguro de haber seguido correctamente los pasos necesarios (ln, PATH, etc.).

¿Alguna sugerencia? ¿Hay algún problema con Ubuntu, además del ya conocido del shell? ¿Hay alguna distribución específica conocida que permita compilar sin errores?

Muchas gracias de antemano.
 
A ver si Victek nos da una sorpresa el Domingo, Tomato RAF Edition España Campeona del Mundo, jeje... ;)

La verdad que la actual versión casi insuperable, este hilo está bastante parado desde hace tiempo, y yo creo que es por lo buena que es precisamente, que la gente no tiene casi problemas con ella...

Saludos.

P.D.: que no suene a meter prisas ni nada por el estilo, sólo que como ya hace días que no leo a Victek por aquí imagino que estará ahí peleándose y compilando módulos, etc, etc... lo otro es un poco la euforia que tenemos muchos con el fútbol, jeje ;)
 
En la página anterior Victek comentó que está trabajando en la versión 1.28

Saludos.
 
hola


tengo una pequeña duda.....tengo la 1.25.8515

me venia dando problemitas no se porque,,,,,,, a veces me sincronizaba y otras no..... borre la nvram,,,,,,,
puse el dlink en modo bridge sin tocar nada mas,,,,
configure el linksys con lo de ppoe y los datos de telefonica y dns,,, pero no me da internet,,,,

le meto algun otro firmware?

sabeis que puede estar mal?


gracias esque ya no se que configurar llevo dos dias dando vueltas a esto
 
Has cambiado la LAN por la 192.168.2.1?? (si es que el D-Link lo tienes en 192.168.1.1).
 
¿Arrancas primero el D-Link y lo dejas que termine de inicializar, y después arrancas el Linksys? A ver si es que arrancas los 2 routers a la vez y no le da tiempo a sincronizar, me suena haber leído que otro zonero tenía ese problema, que arrancaba los 2 routers a la vez y por eso no conseguía que el Linksys enlazara bien con el router que hacía de modem...

Saludos.
 
siii eso hacia yo antes tambien,,,,pero ahora dejo que se pase un rato y cuando lo veo ya sincronizado pues entonces enciendo el linksyss....pero no se que sera....
 
Pásame el LOG por MP a ver si veo algo.
 
jacqlittle dijo:
¿Arrancas primero el D-Link y lo dejas que termine de inicializar, y después arrancas el Linksys? A ver si es que arrancas los 2 routers a la vez y no le da tiempo a sincronizar, me suena haber leído que otro zonero tenía ese problema, que arrancaba los 2 routers a la vez y por eso no conseguía que el Linksys enlazara bien con el router que hacía de modem...

Saludos.

es lo mejor, pero yo tengo un dlink y estan el dlink y el GL enganchados a la misma regleta de corriente, vamos que siempre inician a la vez, y no tengo ningun problema, siempre enganchan bien
 
he leido una noticia de Vulnerabilidad en millones de routers, alguien sabe si el WRT54GL con tomato tiene dicha vulnerabilidad???
saludos

lo he sacado de esta informacion:

Millones de routers de los principales fabricantes, tienen una vulnerabilidad que puede ser aprovechada por hackers, utilizando un ataque DNS Rebinding para redireccionar e interceptar el tráfico además de poder tener acceso a redes locales. El investigador que ha descubierto esta vulnerabilidad, explicará detalles de esta y hará una demostración en el ciclo de conferencias de seguridad Black Hat

Entre las marcas de los routers afectados por este grave problema de seguridad se encuentran: D-link, Netgear, Linksys y Belkin entre otros que se pueden consultar en este listado

Según ha manifestado el descubridor de esta vulnerabilidad, el investigador Craig Heffner de la compañía Seismic, el hacer pública esta vulnerabilidad es la mejor manera, para que los fabricantes de los routers afectados actualicen el firmware de estos para corregir este problema.
 
Solución para el ataque DNS Rebinding.

Nos vamos a:

Advanced ---> DHCP / DNS y en el cuadro del Dnsmasq (Custom Configuration) escribimos:

stop-dns-rebind

Le damos a Save y listo, problema resuelto.

Un Saludo.
 
Bron dijo:
Pásame el LOG por MP a ver si veo algo.

perdon por no contestar antes,,, no e tenido tiempo ni de mirar que le pasaba al router....

a ver el dlink solo lo tengo que poner en modo bridge.....

y el tomato pongo esto a ver si esta bien????

type pppoe
username adslppp@telefonicanetpa
pass adslppp

connet mode keep alive
check interval 30
mtu manual 1482
router ip adress 192.168.2.1
255.255.255.0
dns 80.58.61.250
80.58.61.254


ya esta... a ver que me decis...porque yo no se qe puede ser :S
 
Estado
Cerrado para nuevas respuestas.
Arriba