Router Lynksis WRT54GL. Problema con servidor. Error DNS?

Hola, buenas a todos...
bueno, para empezar quisiera decir que no sabia si esto hiria aqui, asi que, de no ser asi, por favor, pongan el post en el sitio indicado.
Bueno, quisiera decir que soy nuevo en esto de servidores y demas, ganando experiencia poco a poco, llegue a un punto que me dije "Ei, porque no me hago tambien un servidor de correo?". Cuando me dije esto acababa de crearme un servidor web, aunque todavia no habia ido a no-ip para hacer lo del dns y demas historias...Para entonces ya tenia creado medianamente mi web (con Joomla!), tenia el Apache, MySQL, PHP, phpmyadmin, etc... instalados y demas, funcionando perfectamente. Me compre un router (ya que con quien tengo contratado internet me dio un cable/modem, y claro, no me servia) para que la jente pudiese entrar a la web (logico) y ya lo habia configurado y abierto los puertos para esas necesidades. Resulta que, antes de ponerme a hacer el mail server, habia comprobado que poniendo mi IP (normalmente 212.142.xxx.xxx, aunque cambie, porque tengo dinamica, siempre comienza con 212.142) en el navegador podia meterme en la web. Y asi era, al menos al principio, hasta que no se que hice, no se si fue por registrarme en no-ip, o que tocaria pero ya solo puedo acceder a la web poniendo "localhost" o "192.168.1.100" (este ultimo la verdad es que no lo entiendo muy bien, ya que supuestamente es la IP que me asigna el router, no la publica). Entonces la pregunta del millon :D es, que narices he hecho para que no funcione? como solucionarlo?

Quisiera hacer otra pregunta (aunque quizas sea demasiado pedir). Otra duda que tengo es:
Como puedo hacer que cuando se ponga mi direccion de web (despues de haber solucionado el error de arriba y de que tenga una dirrecion amigable en vez de la IP) que valla a la parte del server que yo quiera? es decir, yo por ejemplo, si entro a localhost, me aparece el error 403 el de "Forbiden" "Prohibido" traducido al castellano, y para que valla a otra parte tengo que poner, por ejemplo, http://localhost/info.php (el "info.php", fue un php que hice de prueba para verficiar que el server funcionaba, solamente muestra la info de la version de mi PHP), la pregunta es (que creo que me he desviado):
Como puedo hacer que la gente que entre a mi web no vea lo de forbbiden ni nada de info.php ni nada de eso? quiero decir, que si yo tengo una web, y dentro un foro phpbb3, etc.. como puedo hacer que por defecto, al poner la direccion en el navegador, valla por defecto a la web?

¡Muchisimas gracias de antemano!

(se que soy un chapas asi que perdonen por enrollarme tanto, solo lo hago para explicarme lo mejor posible)

¡Saludos a toda la comunidad!

P.D.: Se me olvido indicar que mi router es Lynksis WRT54GL, aunque lo ponga en el mismo titulo por seacaso lo digo.
 
Para el primer problema, abre el puerto 80 TCP en el portforwarding del router a la IP de la máquina que está haciendo de servidor.
Para el segundo problema, cuando alguien escriba tu dirección IP el servidor Apache mostrará la página index.html

Saludos
 
Hola, y gracias por responder tan rapidamente, pero sigo igual...
Haber, yo lo que hice fue hacer lo que tu me has dicho (aunque no hacia falta porque ya lo tenia puesto de antes). Pero nada. Probe a quitarlo y despues de quitarlo, ponia mi IP en el navegador y en ved de llevarme al servidor, me llevaba a la configuracion del servidor (que cooossaaa maas rara, la verdad). O sea, que era lo mismo poner 212.142.xxx.xxx y 192.168.1.1

Haber, te cuento lo que me pasaba antes:
Al principio me funcionaba, o sea, que yo ponia mi IP en el navegador y entraba a la web. Lo probe desde otro ordenador (el de un amigo) y se podia entrar. Per el fallo vino, cuando queria poner una direccion amigable en ved de la IP. Para ello fui a no-ip. Me cree una cuenta, me baje el programa, todo bien, pero resulta que entonces, cuando probe a poner la direccion, no entraba a ningun lado. Si ponia la IP lo mismo, nada.
Y es desde entonces desde que tengo este problema tan raro. Me deshice de la cuenta, la borre, el host, todo. Pero nada, sigo igual. He probado cambiando la IP del router y nada, igual. He hecho lo que me has dicho tu y nada, todo sigue igual de mal.

No se que sera, pero no es muy normal, o si?

Gracias de nuevo

Y Saludos!

P.D.: Otra cosa que se me habia olvidado comentar. Tambien probe a quitar el router, es decir, solo tenia conectado el cable-modem directamente al PC. Me meti a cmd, ipconfig y demas historias y me saqeu la IP. La puse en el navegador y SI! AHORA SI!.....pero eso solo me funciona sin el router, pero claro, para que la gente entre necesito router, y si lo pongo, ya no va....es una cosa muuu rara. Gracias de nuevo.
 
El cable módem está dando IP por DHCP o es realmente un cable módem (te da la IP pública a la máquina conectada) ? Lo digo porque me parece que da DHCP y debes abrir todos los puertos a la IP WAN del WRT54GL ...

Saludos
 
Si, es realmente un cable-modem. La cosa es que antes de hacer lo de no-ip, teniendo puesto el router, ponia la IP publica en el navegador y podia entrar a la web, pero despues de hacer lo de no-ip ya no podia. Borre mi cuenta d eno-ip y desinstale el programa, pero seguia igual. Pense que cambiando la IP del router podria entrar pero nada.

El cable-modem es de euskaltel (no creo que lo conozcas, ya que es un servicio de internet del Pais Vasco). Para que veas que es cable-modem, aqui tienes la marca:
Scientific Atlanta 2320.

Si quieres te paso las imagenes de como tengo configurado el router (puertos y demas):








(Solo los que se ven son los que estan abiertos)



No se si estos datos te podrias servir para ayudarme, pero muchisimas gracias por ayudarme, de veras, te lo agradezco.

Saludos!
 
Si, lo conozco por soporte a conocidos en el País Vasco, y veo que le ha dado al Linksys una IP pública, o sea es un módem y lo ha hecho bien, el Linksys está en Internet.

Vamos a hacer una prueba sencilla para confirmar que el Linksys está en internet, ve al menú del router, entra en Administration/Management , activa la función de Remote Management (Enable), deja el puerto que te indica (8080), y asegúrate de que la clave que le has puesto para acceder al router no sea la de siempre (admin) pon alguna un poco más rara ... y entonces prueba escribiendo en la barra del navegador tu IP pública seguida de : y 8080, por ejemplo en tu caso y de acuerdo a las capturas que me envías... http://212.142.207.26:8080 .. a ver si te aparece la pantalla de acceso del menú del router, si es así entonces es que el servidor web lo tienes mal redireccionado.

Saludos
 
Si, tienes razón, estará mal redireccionado. He hecho lo que me has dicho y efectivamente, me lleva a la configuración del router. Ahora la pregunta es, que tengo que cambiar para que redireccione bien?

Muchas gracias de nuevo y por querer ayudarme con tanto ímpetu.

Saludos!

P.D.: Perdona mi ignorancia, pero es que soy muy nuevo en esto de servidores.
 
Perfecto, ya he visto que tu router está en Internet :), ahora mira la IP del servidor que esté bien puesta en el Portforward, no hay más secreto . Te explico, escribe ipconfig en en PC que hace de servidor... esta es la IP que debes ponerle en el Portforwarding con el 80 TCP abierto.

PD, una vez lo hagas puedes quitarle el acceso remoto al Linksys o ponerle una clave más rara, no uses las de diccionarios...

Saludos
 
Pfff, es que es esa IP la que esta puesta en la configuracion del router. Mira, cuando pongo ipconfig en el cmd me dice que mi IP (me imagino que esta sera la IP privada) es 192.168.1.100. Yo voy a la configuracion, y alli donde la configuracion de puertos tengo abierto los puertos necesarios (incluido el 80) para el servidor, de la IP 192.168.1.100. (Esa imagen esta arriba. en la respuesta de arriba).

Pffff, sigo igual.

Saludos!
 
mmmm .. algún cortafuegos o suite de seguridad instalado en este PC? ... desconecta seguridad...

Saludos
 
JOder, tio, sabes que era? EL PUÑETERO FIREWALL DE WINDOWS!!
Que cojones? eso es en lo ultimo que habia pensado hasta que me dijiste lo de la seguridad!
Porque habia tocado todo en el router, y nada. Y pense "Oye, hace unas semanas hice una actualización de XP, me instale el SP3 y demas" y dije"Ahora que me acuerdo, el firewall de windows estaba deshabilitado antes de instalar el SP3, y despues se activo por defecto, tras instalar el SP3".
Despues pense "No sera el puñetero firewall, no?" Pues si, eso era. Reinstale el router (ya que habia tocado demasiadas cosas) y desactive el firewall. Fui a otro ordenador poniendo la IP y vuala! Funcionaba! (No veas la alegria que me lleve!). Asi que al final no era lo de no-ip. Era el firewall de windows, joder, es que yo tambien soy mas cortitoooo....bueno, de errores se aprende, no? al menos asi conseguire mas experiencia.


Oye, mil gracias por ayudarme, de veras. Dame la dirección que te envio un jamon de 5 bellotas :D xDD.

Enga, gracias de nuevo y saludos!
 
Se me olvido preguntar una cosa....ahora que tengo esto solucionado, en cuanto a la pregunta 2 que hice en el primer mensaje de este post...
Ahora, cuando pongo mi direccion en el navegador, en ved de llevarme directamente a la pagina web, me lleva a una pagina donde me dice "Forbiden", prohibido en castellano. Y para ir a la web tengo que escribir http:://midireccion.com/joomla.

Como puedo hacer que no sea necesario poner "joomla" para que valla a la web? quiero decir, que yo querria que solo con poner http://midireccion.com entrase a mi web.

Como hago esto? es que no entendi tu respuesta.

Gracias de nuevo

¡Y un gran saludos!
 
No se que servidor web has montado pero lo normal es que los archivos con el contenido de la web estén en el directrio por defecto (/www) .. por lo que parece tu lo has puesto en otro directorio y adicionalmente parece que los permisos de acceso los tienes para que solo el administrador pueda leerlos, revisa esto:

1º Que directorio es el que está configurado en el servidor web como acceso de documentos.
2º Un fichero index.htm o html es el que busca el navegador cuando accede a un servidor web
3º Los permisos de lectura para invitados.

Saludos
 
Arriba