OpenWRT / OpenwrtWRT en Linksys WRT160NL. Instalación

Cual es la situación actual? puedes acceder al router vía ssh? desde ahí podrías montar el nuevo firmware en una posición de memoria y después instalarlo (montarlo) en el router... exlica el punto en que te encuentras.

Saludos
 
Router Muerto

Despues de hacer el primer paso por navegadory una vez reiniciado el equipo,al cargar el comando opkgupdate se abre en la consola:http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Paackages.gz
Me da error 1
Si lo que debe abrir es una pagina http y para entonces yo ya no tengo conexion a internet,¿no puede ser ese el fallo?
 
No, la secuencia correcta sería descargar la lista de archivos del repositorio para que a continuación y después de escribir opkg upgrade obtuvieras una actualización de módulos cambiados, no debe abrir ninguna página web ...

Saludos
 
Indeciso

Hola muy buenos días, que bueno encontrar este tipo de tópicos y personas tan colaboradoras. yo soy un novato en el tema pero tengo algunas dudas que me gustaría aclarar con ustedes.

Desde hace tiempo he querido comprarme un wrt160nl pero según lo que leí de este tema es que aún no hay algo oficial (me equivoco?) y quiero estar seguro de mi compra, entonces les hago unas preguntas a ustedes que son los expertos:

1) el media server funciona bien? me refiero en el sentido de que no se caiga a los 3 segundos como otro usuario comentaba cuando accedía desde su TV

2) me gustaría montar un servidor web, se puede hacer con este router?

3) para el caso de un Portal Cautivo, es posible montarlo dentro de este router?



finalmente.. si no se puede hacer lo que pido, que otro router me recomiendan? no me gustaría tener que dejarlo de pisapapeles...


muchas gracias de antemano
 
Re: Indeciso

Hola a todos, no se si habreis visto esta web... pero yo la acabo de descubrir.
Tuto para el wrt160nl para instalar DD-WRT y mas...
Esta en ingles pero creo que es bastante intuitiva... el que tenga tiempo (del que yo no dispongo) hasta lo podria traducir al español.
http://wrt160nl.org/
Un saludo a todos.
 
Problema flasheando

Muy buenas gente, a ver si alguien me puede ayudar con el ladrillo que tengo actualmente, tras comprar mi flamante wrt160nl, y ver las vondades de dd-wrt he decidido instalarlo en el router, el cual me funcionaba de forma perfecta salvo que si intentaba introducir algun puerto para redireccionar, estos me aparecian todos en blanco en la interface del router, como pense que era un fallo del firmware, decidi instalar el openwrt, seleccionando la version correcta desde la interface del dd-wrt, la cuestion es que durante la instalacion hubo un error...y router muerto...lo enciendo y esta la luz de encendido parpadenado todo el rato, el router no devuelve ping, pero parece que "esta ahi", el cliente ssh dice que hay un erro de conexion, pero no se pasa el tiempo buscando destino, el tftp, encuentra tambien algo, pero si intento subirle nuevo firmware tras un tiempo me dice que no se ha pasado de tiempo.... He visto en algun sitio que mediante el puerto wan, hay una especie de puerto de consola, ya que no queria abrirlo para utilizar las conexiones internas... ya que esta en "garantia", a ver que me podeis decir...gracias de antemano!
 
router aparentemete muerto

Buenos dias, me ha pasado que al instalar openwrt en el wrt160nl, no puede instalar la interfaz web luci, asi que le puse opgk upgrade y tras descargar varios paquetes, el router se quedo como congelado, asi que lo apague y cuando lo enciendo no puedo entrar ni por telnet ni por ssh ni por supuesto por web.

la cosa es que el router responde al ping en 192.168.1.1 (siempre y cuando lo encienda con el boton reset pulsado y dandole muchas veces al boton wps hasta que parpadee constantemente).

Tampoco hace nada con el comando tfpt.

Hay alguna forma de poder arreglarlo?

gracias.
 
como sigo ahora

Buenas noches, despues de mucho trastear he podido entrar en el failsafe mode. utilizando el comando:
mtd -r delete rootfs_data, he conseguido borrar los datos y utilizar el comando opkg update.
pero cuando le pongo el comando opkg upgrade me aparece esto:

Downloading http://downloads.openwrt.org/snapshots/ ... es/Package
s.gz
Inflating http://downloads.openwrt.org/snapshots/ ... s/Packages.
gz
Updated list of available packages in /var/opkg-lists/snapshots
root@OpenWrt:/# opkg upgrade
Multiple packages (kmod-pppoe and kmod-pppoe) providing same name marked HOLD or
PREFER. Using latest.
Upgrading kmod-pppoe on root from 2.6.30.5-1 to 2.6.32.26-1...
Downloading http://downloads.openwrt.org/snapshots/ ... es/kmod-pp
poe_2.6.32.26-1_ar71xx.ipk
Multiple packages (kernel and kernel) providing same name marked HOLD or PREFER.
Using latest.
Multiple packages (kmod-ppp and kmod-ppp) providing same name marked HOLD or PRE
FER. Using latest.
Upgrading kmod-button-hotplug on root from 2.6.30.5-1 to 2.6.32.26-3...
Downloading http://downloads.openwrt.org/snapshots/ ... es/kmod-bu
tton-hotplug_2.6.32.26-3_ar71xx.ipk
Multiple packages (kernel and kernel) providing same name marked HOLD or PREFER.
Using latest.
Upgrading uci on root from 0.7.5-1 to 2010-09-28.2-2...
Downloading http://downloads.openwrt.org/snapshots/ ... es/uci_201
0-09-28.2-2_ar71xx.ipk

y ahi se queda parado......

despues vuelvo a entrar y aparece esto:

root@OpenWrt:/# opkg upgrade
Multiple packages (kmod-pppoe and kmod-pppoe) providing same name marked HOLD or
PREFER. Using latest.
Upgrading kmod-pppoe on root from 2.6.30.5-1 to 2.6.32.26-1...
Downloading http://downloads.openwrt.org/snapshots/ ... es/kmod-pp
poe_2.6.32.26-1_ar71xx.ipk
Multiple packages (kernel and kernel) providing same name marked HOLD or PREFER.
Using latest.
Multiple packages (kernel and kernel) providing same name marked HOLD or PREFER.
Using latest.
Multiple packages (kmod-ppp and kmod-ppp) providing same name marked HOLD or PRE
FER. Using latest.
Upgrading kernel on root from 2.6.30.5-1 to 2.6.32.26-1...
Downloading http://downloads.openwrt.org/snapshots/ ... es/kernel_
2.6.32.26-1_ar71xx.ipk
Upgrading kmod-button-hotplug on root from 2.6.30.5-1 to 2.6.32.26-3...
Downloading http://downloads.openwrt.org/snapshots/ ... es/kmod-bu
tton-hotplug_2.6.32.26-3_ar71xx.ipk
Multiple packages (kernel and kernel) providing same name marked HOLD or PREFER.
Using latest.
Upgrading uci on root from 0.7.5-1 to 2010-09-28.2-2...
Downloading http://downloads.openwrt.org/snapshots/ ... es/uci_201
0-09-28.2-2_ar71xx.ipk
Upgrading liblua on root from 5.1.4-5 to 5.1.4-7...
Downloading http://downloads.openwrt.org/snapshots/ ... es/liblua_
5.1.4-7_ar71xx.ipk
Upgrading dropbear on root from 0.52-3 to 0.52-5...
Downloading http://downloads.openwrt.org/snapshots/ ... es/dropbea
r_0.52-5_ar71xx.ipk
conffile_has_been_modified: conffile /etc/dropbear/dropbear_rsa_host_key:
old md5=3f852cf15686ccb057f6617a2a092fa5
new md5=d41d8cd98f00b204e9800998ecf8427e
conffile_has_been_modified: conffile /etc/dropbear/dropbear_dss_host_key:
old md5=acf112c7ec753acf551b23a9e94d4028
new md5=d41d8cd98f00b204e9800998ecf8427e
Upgrading liblua on root from 5.1.4-5 to 5.1.4-7...
Downloading http://downloads.openwrt.org/snapshots/ ... es/liblua_
5.1.4-7_ar71xx.ipk
Not upgrading package kmod-crypto-core which is marked hold (flags=0x2)
Upgrading dropbear on root from 0.52-3 to 0.52-5...
Downloading http://downloads.openwrt.org/snapshots/ ... es/dropbea
r_0.52-5_ar71xx.ipk

y lo mismo..

Porfa, como consigo poner el firm operativo.... :oops:
 
Son errores frecuentes, ve probando opkg update y opkg upgrade hasta que consiga pasar las actualizaciones...
 
volver al firm original

Buenos dias, gracias por la respuesta.
queria preguntar si hay alguna forma de grabar el fichero bin del firm original en un pendrive, introducirlo en el puerto usb del router y desde ahi restaurar el firm original.

Gracias.
:?:
 
El problema es que debe tener cargados los drivers para reconocer el disco duro o drivepen (algo dificil cuando el equipo está muerto), por este motivo lo habitual es cargar por puerto serie en memoria del router el binario y después ejecutar la instalación.
 
instalaion de luci

buenos dias, al instalar luci mira lo que aparece en el navegador:

Error de lectura XML: mal formado
Ubicación: http://192.168.1.1/luci
Número de línea 50, columna 1:<h2><a id="content" name="content">500 Internal Server Error</a></h2>
^

alguna sugerencia?
gracias
 
reinstalar firm

Buenas tardes, soy incapaz de ponerle la interfaz grafica al openwrt
le pongo opkg update/upgrade y luego le intento poner el luci y me dice:
opkg install luci-admin-full y me pone:
* Cannot find package luci-admin-full.

quisiera saber si existe alguna posiblidad desde el prompt root@openwrt:/# usar alguna instruccion/comando para cargarle el firm original.

Gracias.
 
hola ¿alguien sabe como se abren puertos en openwrt? tengo la interfaz luci y quiero abrir puertos para el transmission pero es que no tengo ni idea, a ver si alguien me puede hechar una mano
 
Hola

Mi problema es el siguiente he intentado instalar un firmware openwrt en router lynksys e2100l He probado varios pero no he tenido éxito instalando ninguno. El error que me muestra es code pattern incorrecto. Solo un firmware de varios que he probado me ha funcionado, pero busco uno mas actual. La salida que da consola del router la muestro a continuación:
ar7100> upgrade code.bin
check link duplex:Full/speed:100
dup 1 speed 100
Tftpd start listening on port[69]!
Load address: 0x80060000
Receiving firmware [code.bin] from [192.168.1.254]
Write File : CODE.BIN
#
Current Code Pattern:NL1X , Upgrade Code Pattern:NL16
Code Pattern is incorrect!
Tftpd start listening on port[69]!
Load address: 0x80060000
Agradezco la colaboración que me puedan brindar como podría coregir esta inconsistencia o si me pueden ayudar a conseguir un firmware que pueda instalar.
Muchas gracias.
 
Arriba