Modem Nucom W-260 en Ubuntu

Buenas a todos,

he adquirido un modem usb con una tarifa plana de 500mb. El modem es el Nucom NU-260.

La cuestion es que pese que el fabricante dice que es compatible con linux y ubuntu, en el mismo ubuntu no me lo detecta.

Alguien lo ha conseguido utilizar con Ubuntu?

Un saludo,

Piltrafilla
 
El problema es que Sakis3G ya no está disponible en su web... algún sitio donde bajarlo?

Gracias!
 
Buenas,

definitivamente no funciona.... ni tan siquiera lo detecta.

Un saludo,
 
Piltrafilla34 dijo:
Buenas,

definitivamente no funciona.... ni tan siquiera lo detecta.

Un saludo,

Buenas. Me acabo de registrar solo para decir que yo también tengo jazztel 500 Mb y el modem Nucom W-260 funcionando sobre SuSE Linux 9.2 (la prueba es que estoy conectado y enviando esto).
Para ello sólo necesité descargar e instalar 2 rpm:
libusb 0.1.12-3 y usb_modeswitch 0.9.2-1.1
(http://www.draisberghof.de/usb_modeswitch/)
(es para que Linux lo pueda detectar el pincho como modem)
Una vez instalados, crear los ficheros de configuración:

-rw-r--r-- 1 root root 341 2013-06-05 19:34 /etc/udev/rules.d/16-nucom-w260.rules
SUBSYSTEM=="usb", ATTRS(idVendor)=="2077", ATTRS(idProduct)=="f000", RUN+="/usr/bin/usb_modeswitch -v 0x$attr{idVendor} -p 0x$attr{idProduct} -t option-zerocd"

#-rw-r--r-- 1 root root 389 2013-06-06 00:45 /lib/udev/rules.d/16-nucom-w260.rules
SUBSYSTEM=="usb", ATTRS(idVendor)=="2077", ATTRS(idProduct)=="f000", RUN+="/usr/bin/usb_modeswitch -v 0x$attr{idVendor} -p 0x$attr{idProduct} -t option-zerocd"
(es el mismo contenido en el directorio lib, igual no es necesario)

-rw-r--r-- 1 root root 5374 2013-06-05 21:43 /etc/usb_modeswitch.conf
# Nucom W-260
DefaultVendor= 0x2077
DefaultProduct= 0xf000

TargetVendor= 0x2077
TargetProduct= 0xa000

MessageEndpoint= 0x01
MessageContent="5553424308902082000000000000061b000000020000000000000000000000"

(este fichero es el importante, porque contiene los códigos del hardware para que Linux lo detecte como modem y no como otro tipo)

Ahora ejecuté los siguientes comandos, con sus correspondientes salidas:
Conectar el modem y ejecutar:
SuSE92:/ # lsusb
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 006: ID 2077:a000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

SuSE92:/ # usb_modeswitch -W -c /etc/usb_modeswitch.conf

* usb_modeswitch: tool for controlling "flip flop" mode USB devices
* Version 0.9.2 (C) Josua Dietze 2007
* Works with libusb 0.1.12 and probably other versions

DefaultVendor=0x2077
DefaultProduct=0xf000
TargetVendor=0x2077
TargetProduct=0xa000
DetachStorageOnly=0
HuaweiMode=0
MessageEndpoint=0x1
MessageContent="5553424308902082000000000000061b000000020000000000000000000000"
NeedResponse=0
ResponseEndpoint=0x0

Looking for target device
OK, target device not found. Action required
Looking for default device
Ok, found default device. Prepare switching
Looking for active default driver to detach it
OK, driver found ("usb-storage")
OK, Driver "usb-storage" successfully detached
Trying to send the message
OK, message successfully sent.
-> See /proc/bus/usb/devices (or call lsusb) for changes. Bye

SuSE92:/ # lsusb
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 006: ID 2077:a000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

# El LED del modem ilumina continuamente de color rojo

SuSE92:/ # dmesg
usb 2-2: USB disconnect, address 6
generic ttyUSB0: Generic converter now disconnected from ttyUSB0
usbserial_generic 2-2:1.0: device disconnected
generic ttyUSB1: Generic converter now disconnected from ttyUSB1
usbserial_generic 2-2:1.1: device disconnected
generic ttyUSB2: Generic converter now disconnected from ttyUSB2
usbserial_generic 2-2:1.3: device disconnected
usb 2-2: new full speed USB device using address 7
usb 2-2: device not accepting address 7, error -71
usb 2-2: new full speed USB device using address 8
usb 2-2: Product: 3G USB Modem
usb 2-2: Manufacturer:
usb 2-2: SerialNumber: 1234567890ABCDEF
scsi4 : SCSI emulation for USB Mass Storage devices
Vendor: 3G Modem Model: Mass Storage Rev: 2.31
Type: CD-ROM ANSI SCSI revision: 02
sr0: scsi-1 drive
Attached scsi CD-ROM sr0 at scsi4, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi4, channel 0, id 0, lun 0, type 5
USB Mass Storage device found at 8
usb 2-2: USB disconnect, address 8
usb 2-2: new full speed USB device using address 9
usb 2-2: Product: 3G USB Modem
usb 2-2: Manufacturer:
usb 2-2: SerialNumber: 1234567890ABCDEF
usbserial_generic 2-2:1.0: Generic converter detected
usb 2-2: Generic converter now attached to ttyUSB0
usbserial_generic 2-2:1.1: Generic converter detected
usb 2-2: Generic converter now attached to ttyUSB1
scsi5 : SCSI emulation for USB Mass Storage devices
Vendor: 3G Modem Model: Mass Storage Rev: 2.31
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi5, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi5, channel 0, id 0, lun 0, type 0
USB Mass Storage device found at 9
usbserial_generic 2-2:1.3: Generic converter detected
usb 2-2: Generic converter now attached to ttyUSB2

# Ahora el modem está conectado a /dev/usb/ttyUSB2, parámetro a pasar al script de conexión

SuSE92:/ # pppd file /etc/ppp/options-jazztel
chat: Jun 05 22:26:40 CONNECT 7200000
Serial connection established.
using channel 1
Using interface ppp0
Connect: ppp0 <--> /dev/usb/ttyUSB2
local IP address XXX.XXX.XXX.XXX
remote IP address XXX.XXX.XXX.XXX
Script /etc/ppp/ip-up started (pid 7765)

No me funcionó a la primera así que lo desconecté y lo volví a conectar y tuve que hacer:
SuSE92:/ # rmmod /lib/modules/2.6.8-24-default/kernel/drivers/usb/serial/usbserial.ko

SuSE92:/ # insmod /lib/modules/2.6.8-24-default/kernel/drivers/usb/serial/usbserial.ko vendor=0x2077 product=0xa000

SuSE92:/ # modprobe -vvv usbserial vendor=0x2077 product=0xa000

y luego ejecutar usb_modeswitch como antes y ver si aparece detectado como /dev/ttyUSB* (en mi caso /dev/ttyUSB2, pero puede ser otro e incluso /dev/usb/ttyUSB**, ver el dmesg a ver si te aparece este dispositivo).
Espero que le sirva a alguien. Supongo que para Ubuntu será parecido.
Un saludo linuxero a todos.
 
Pincho nucom wu-260 conectado

Primero darte las gracias icecubeman porque gracias a tu post he conectado a internet mi pincho Nucom WU-260.
Uso Ubuntu Versión 12.04 (precise) de 32-bit. Mi problema principal era que no tenía instalado los módulos del kernel, tal como se dice al final del post, así que en cuanto los instalé echó a andar.
Para configurar la conexión he utilizado aplicación que aparece en la barra superior, esa que si la pinchas se ven todas las conexiones disponibles y que se pueden editar.
Así que solo tuve que instalar las últimas versiones de los programas que comentas, configurar la conexión y instalar los módulos del kernel.
 
Me alegro de que mi post te haya servido para poder conectarte en Ubuntu, miguel_arcangel. :D
Que lo disfrutes!!
 
Arriba