[Solucionado] Movistar TV por wifi desde segundo router (Ope

#1
Hola a todos,

Ayer os preguntaba cómo tener Movistar TV / Imagenio conectándome a un segundo router (DD-WRT) que a su vez se conecta al Mitrastar de  Movistar para poder ver Movistar TV. Pues bien, al final al no conseguirlo y encontrar más que problemas en otros aspectos (estaba harto de la inestabilidad de DD-WRT durante años) me cambié a OpenWRT.

Os cuento mi caso por si me podéis ayudar:

Mi configuración es:

ONT ---> Router Mitrastar -------> Deco oficial de Movistar TV
                                                       |-------> Router  OpenWRT  ---------->  cliente Kodi con plugin PVR de Movistar TV

El router Mitrastar crea una subred 192.168.1.1, mientras que el OpenWRT se conecta como cliente 192.168.1.2 y crea una subred 192.168.0.1

Si el cliente Kodi está conectado por cable o wifi directamente al router Mitrastar, va perfectamente, si lo hago por cable o wifi al OpenWRT no va nada.
He habilitado en OpenWRT el IGMP Snooping y ahora el cliente Kodi detecta los canales y la guía de programación y es capaz de reproducir las grabaciones que tengo en el Deco, pero no es capaz de mostrar los canales en directo.

He probado también lo que dice este tutorial sobre redireccionar el tráfico del OpenWRT de un puerto, por ejemplo el 45000, al cliente Kodi y nada, no me va.
También vi muchos tutoriales para sustituir el router Mitrastar u otro de Movistar por uno de OpenWRT, pero no es mi caso, no quiero cambiarle, solo añadir uno a continuación. Os muestro los principales tutoriales que seguí:
http://foro.seguridadwireless.net/openw ... #msg261384
http://wordpress.igua.es/index.php/2014 ... vAnTCa_mkC
http://www.adslzone.net/postt285772.html

Muchas gracias por adelantado

Actualización: En este post explico cómo se realiza. Ahora ya solo me queda ser capaz de acceder fuera de casa a los canales y, de ser posible, solo por VPN.
 
#2
Buenas, como te dije en el otro post necesitas IGMP Proxy para que enrute el tráfico multicast entre una subred y la otra. Lo de redireccionar el puerto es para que funcione el contenido VOD (grabaciones) detrás de una NAT, como la que debería estar haciendo OpenWRT. Es raro que funcione sin eso. Quizá no tengas masquerading activado en el firewall de la interfaz que conecta al router Movistar, pero en ese caso el router de Movistar desconoce como encaminar el tráfico hasta la otra subred sin rutas estáticas (que no permiten crearlas para interfaces LAN). Dime si necesitas que el equipo con Kodi acceda a internet o no y te muestro capturas de como deberías configurarlo

PD: la compilación de OpenWRT que estés usando debe tener activado el enrutamiento multicast en el kernel, si no no sirve. Chaos Calmer 15.05 creo que lo lleva en todas o casi todas las compilaciones. 

https://downloads.openwrt.org/chaos_calmer/15.05/

o muy reciente https://downloads.openwrt.org/chaos_calmer/15.05.1/
 
#3
Re: Movistar TV por wifi desde segundo router (OpenWRT)

Muchísimas gracias. Sí, uso 15.05 pero una compilación que subieron al foro preparada para Movistar TV. No tengo configurado IGMP Proxy, así que ahí está el problema (en DD-WRT no lo tenía tampoco y me iba por LAN). Buscaré como configurarlo. Muchísimas gracias!
Sí, necesito que el Kodi acceda a Internet, porque es para una raspberry que usa más programas, y el Kodi más add-ons y descarga contenido de Internet (caratulas y otras cosas).
Gracias nuevamente!
 
#4
He estado indagando siguiendo este tutorial y nada. Los pasos que he hecho son:
1) Instalar en el router "kmod-bridge" y "igmproxy"
2) Acceder por ssh y modificar:
/etc/config/igmpproxy
cambiando a
Código:
     list altnet '172.16.0.0/12'
/etc/config/network
Añadiendo a config interface lan
Código:
option igmp_snooping '1'
/etc/config/firewall
añadiendo la regla
Código:
config rule                     
        option name 'Allow-IGMP-MovistarTV'
        option src 'wan'              
        option proto 'udp'    
        option dest 'lan'       
        option dest_ip '172.16.0.0/12'
        option target 'ACCEPT'  
        option family 'ipv4'
Reinicio y nada. He probado lo mismo cambiando la IP a 192.168.1.0/24 que es de donde proviene la señal al OpenWRT (router Mitrastar), a 224.0.0.0/4 que es multicast y a 239.0.0.0/8 que es la regla que tenía en DD-WRT y me iba y nada... algo debo estar haciendo mal.
 
#5
Acabo de ver que tengo la siguiente configuración en Mistrastar:

IPTV Address
10.248.193.17
IPTV Netmask
255.128.0.0
IPTV Gateway
10.128.0.1

En cambio en configuración avanzada del plugin Movistartv de Kodi tengo la IP 239.0.2.129. La verdad es que con DD-WRT no tuve que tocar esa IP para nada, y en configuración del firewall de DD-WRT tenía la subred 239.0.0.0

No sé si ahí está el problema...
 
#6
Lo he conseguido. Funciona tanto canales como EPG por cable y wifi:

Los pasos que he hecho son:
1) Instalar en el router "kmod-bridge", "igmpproxy", "mcproxy" y "kmod-ipt-nathelper-rtsp"..
2) Acceder por ssh y modificar (cambiar 192.168.0.1 por la subred que os cree OpenWRT en su caso):
/etc/config/igmpproxy
Código:
config igmpproxy
        option quickleave 1

config phyint wan
        option network wan
        option direction upstream
        list altnet 172.0.0.0/8
        list altnet 192.168.0.1/24

config phyint lan
        option network lan
        option direction downstream
/etc/config/network
Añadiendo a config interface lan
Código:
option igmp_snooping '1'
/etc/config/firewall
añadiendo la regla
Código:
config rule                     
        option name 'Allow-IGMP-MovistarTV'
        option src 'wan'              
        option proto 'udp'    
        option dest 'lan'       
        option dest_ip '224.0.0.0/4'
        option target 'ACCEPT'  
        option family 'ipv4'
/etc/sysctl.conf
añadiendo (para cambiar IGMP de v3 a v2 que es la que usa Movistar TV)
Código:
net.ipv4.conf.all.force_igmp_version=2
Habilitar igmproxy al arranque:
Código:
/etc/init.d/igmpproxy enable
Reinicio y todo ok.

Nota: Si usamos algún firewall en el ordenador que tenga Kodi, desactivarlo o permitir reglas de multicast. En mi caso, usando en un PC Ubuntu con UFW (interfaz gráfica de iptables) tengo que realizar esto: https://einar.slaskete.net/2014/05/03/a ... v-to-work/
 
#7
Re: [Solucionado] Movistar TV por wifi desde segundo router

Hola,estoy intentando seguir este tutorial. Tengo todo instalado en el router y entro por ssh con el programa putty.   inserto   /etc/config/igmpproxy   y me dice permission denied. me podeis ayudar ? gracias
 
#8
Re: [Solucionado] Movistar TV por wifi desde segundo router

hola por fi lo consegui,el problema es que hay que poner delante (vi) para poder insertar los parametros y para guardarlos es(ZZ) para ver si se guardaron correctamente es (car). un saludo
 
Arriba