Problema fibra movistar cambio de HGU a ONT + router neutro (openwrt) VoIP

#1
hola amigos.
Haber si alguien me puede ayudar que ando algo atascado. En 2017 tuve fibra de telefonica y la tenia funcionando perfectamente con un tplink 1043ND y la ONT, datos y voip ( nunca he tenido imagenio ), usando el vg8050 de ATA para el telefono fijo. Luego me pase a vodafone, todo funcionando con lo mismo y el router original de vodafone de ATA para el telefono.

Ahora hace unos dias me he pasado a O2, entendiendo que al ser como movistar ( usa mismas vlan, etc), podria poner todo a funcionar como antes, pero estoy atascado en la configuracion de VOIP.

Actualmente ya no uso el 1043ND con openwrt 18.06, ahora tengo un r7800 con 19.07 ( digo esto por que no se si es el problema.)

En su día use el script del amigo noltari para connfigurarlo todo, pero como ahora no es compatible con mi router estoy haciendolo manualmente, he seguido todos los pasos pero no soy capaz de que funcione la voip, he probado tanto en el vg8050 como en un softphone en windows, y no funciona, no se registra.

He comprobado la linea y funciona correctamente tanto con el HGU como con una ONT huawei + el vg8050 en modo router.

Os paso la configuración que he hecho a ver si alguien ve el problema.

etc/config/network

Código:
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option stp '1'
    option ifname 'eth1.1'
    option ipaddr '192.168.1.1'
    option delegate '0'
    option netmask '255.255.254.0'
    list dns '1.1.1.1'
    list dns '8.8.8.8'
    list dns '8.8.4.4'
    list dns '208.67.222.222'

config interface 'wan'
    option _orig_bridge 'false'
    option proto 'pppoe'
    option peerdns '0'
    list dns '1.1.1.1'
    list dns '8.8.8.8'
    list dns '208.67.222.222'
    list dns '208.67.220.220'
    option force_link '1'
    option username 'adslppp@telefonicanetpa'
    option password 'adslppp'
    option ifname 'eth0.6'
    option delegate '0'
    option ipv6 '0'
    
config interface 'vpnserver'
    option ifname 'tun0'
    option proto 'none'

config interface 'invitados'
    option proto 'static'
    option netmask '255.255.255.0'
    option delegate '0'
    option ipaddr '192.168.3.1'
    
config interface 'wwan'
    option proto 'dhcp'

config interface 'voip'
    option ifname 'eth0.3'
    option proto 'dhcp'
    option defaultroute '0'
    option peerdns '0'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '6t 4 3 2 1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0t 5t'
    option vid '6'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option ports '0t 5t'
    option vid '3'
etc/config/firewall

Código:
config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan vpnserver'

config zone
    option name 'wan'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option input 'ACCEPT'
    option network 'wan wwan'

config zone
    option name 'voip'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option network 'voip'
    option mtu_fix '1'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fc00::/6'
    option dest_ip 'fc00::/6'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-IPSec-ESP'
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option name 'Allow-ISAKMP'
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'
    
config include
    option path '/etc/firewall.user'

config forwarding
    option dest 'wan'
    option src 'lan'

config forwarding
    option dest 'voip'
    option src 'lan'
    
config forwarding
    option dest 'wan'

etc/bird4.conf, (he instalado el bird1-ipv4 + bird1cl-ipv4)

Código:
log syslog all;

router id 192.168.1.1;

protocol kernel {
   persist;
   scan time 20;
   import all;
   export all;
}

protocol device {
   scan time 10;
}

protocol static {
   export none;
}

filter voip_filter {
   if net ~ 10.0.0.0/8 then accept;
   else reject;
}

protocol rip voip {
   import all;
   export filter voip_filter;
   interface "eth0.3";
}

Haber si alguien da con el fallo!!!! muchas gracias a todos!
 
#2
Bueno os pongo la solución.

Al parecer en el foro de movistar se habla de esto, yo solo encontré un par de post hablando del tema y con la solución descrita.

El caso es que ya no hay que usar bird ( en o2? solo algunas lineas? ) y poner la ruta estatica. Si teneis IPTV imagino que si seguireis necesitando bird, pero en estas conexiones y solo para VOIP no es necesario.

Código:
*** SI NO FUNCIONA BIRD4 POR QUE NO SE ENVIAN LAS RUTAS POR RIPv2 ***

*** TODO FUNCIONANDO EN OPENWRT 19.07 EN ROUTER R7800 ***



Añadir a etc/config/network:


config route
    option interface 'voip'
    option target '10.31.255.128'
    option netmask '255.255.255.224'
    option gateway '10.XX.XX.XX'




******> la ip de gatetway se calcula de la siguiente forma:


En la interface VOIP al estar por dhcp te dara una ip telefonica/O2, por ejemplo en este caso "10.22.58.45/18"
El "/18" es la mascara de red.

Nos vamos ha " https://aprendaredes.com/cgi-bin/ipcalc/ipcalc_cgi1 " para calcular el gateway de la red, y ponemos los datos de ip (10.22.58.45) y la mascara (18)
El valor "HostMin: 10.22.0.1" es el que nos interesa, ya que el gateway es a su vez es la primera ip del rango.
Gracias a los compañeros que pusieron la solución y han pasado sin pena ni gloria
 
Arriba