Obtener configuración Fibra Vodafone

#21
Re:

pelepla dijo:
Y para 50/5 te han puesto el CH?

Supuestamente ponen el CG y dan el Huawei para hacer de router y voip
Ni idea...empece teniendo 30 y luego aumente a 50...

Lo he conseguido (a medias) siguientes estos pasos del hilo que me has mandado!!

 -           Buenas, no es PPPoE, es MER (o IPoE). Esto no es más que un DHCP pero verificando MAC y Hostname (en el TP-Link sería poniendo IP dinámica).
El servidor de Vodafone autentifica contra la MAC del Compal y contra el Hostname del router.
El problema es que Vodafone en el host utiliza un nombre no estandar (tiene una barra en medio, algo así: VFXXXXXX/XXXXXXX.
En internet, los hostname solo pueden llevar caracteres alfanuméricos y guiones -. Si el router neutro no envía el mismo hostname del router original, entonces no habrá internet, el servidor no nos da IP pública. Los routers neutros no admiten caracteres como la barra en el hostname; nosotros lo que hemos hecho ha sido eliminar esa limitación en el router Ubiquiti a través de la línea de comandos (no se si esto se podrá hacer en el TP-Link. (Gracias al usuarios andrew_mp)

 -          
Efectivamente por mas de que le reemplaze la "/"(0x2F) por un 0 (0x30) y le agrege un valor a otro caracter no funciona. Seguramente ni un md5sum o crc32 funcione, debe simplemente compara caracter x caracter. Con lo cual... toca las p___ en los firmwares originales.

Con Openwrt en ssh, "nvram set wan_hostname=VF..." va bien.  (gracias al usuario 
Guillote_rouco)

Por lo tanto he realizado lo siguiente:
1- En el apartado WAN de mi router asus he especificado: ip dinamica, nombre de host: vacio y MAC: router vodafone
2- He entrado por SSH y he ejecutado el comando "nvram set wan_hostname=VFXXX/XXXX"
3-Me ha dado ip publica, gateway y dns publico y el router presentaba como si todo fuera bien.

Para mi desgracia... no funcionaba internat a pesar de todo...

¿Alguna idea?

Gracias.
 
#22
Re: Re:

VictorC dijo:
pelepla dijo:
Y para 50/5 te han puesto el CH?

Supuestamente ponen el CG y dan el Huawei para hacer de router y voip
Ni idea...empece teniendo 30 y luego aumente a 50...

Lo he conseguido (a medias) siguientes estos pasos del hilo que me has mandado!!

 -           Buenas, no es PPPoE, es MER (o IPoE). Esto no es más que un DHCP pero verificando MAC y Hostname (en el TP-Link sería poniendo IP dinámica).
El servidor de Vodafone autentifica contra la MAC del Compal y contra el Hostname del router.
El problema es que Vodafone en el host utiliza un nombre no estandar (tiene una barra en medio, algo así: VFXXXXXX/XXXXXXX.
En internet, los hostname solo pueden llevar caracteres alfanuméricos y guiones -. Si el router neutro no envía el mismo hostname del router original, entonces no habrá internet, el servidor no nos da IP pública. Los routers neutros no admiten caracteres como la barra en el hostname; nosotros lo que hemos hecho ha sido eliminar esa limitación en el router Ubiquiti a través de la línea de comandos (no se si esto se podrá hacer en el TP-Link. (Gracias al usuarios andrew_mp)

 -          
Efectivamente por mas de que le reemplaze la "/"(0x2F) por un 0 (0x30) y le agrege un valor a otro caracter no funciona. Seguramente ni un md5sum o crc32 funcione, debe simplemente compara caracter x caracter. Con lo cual... toca las p___ en los firmwares originales.

Con Openwrt en ssh, "nvram set wan_hostname=VF..." va bien.  (gracias al usuario 
Guillote_rouco)

Por lo tanto he realizado lo siguiente:
1- En el apartado WAN de mi router asus he especificado: ip dinamica, nombre de host: vacio y MAC: router vodafone
2- He entrado por SSH y he ejecutado el comando "nvram set wan_hostname=VFXXX/XXXX"
3-Me ha dado ip publica, gateway y dns publico y el router presentaba como si todo fuera bien.

Para mi desgracia... no funcionaba internat a pesar de todo...

¿Alguna idea?

Gracias.

decian algo de que había que ponerle al ASUS el firm dd-wrt 

yo yo es que no puedo hacer pruebas porque no soy Vodafone aún y a este paso, veremos 
 
#23
Por lo tanto he realizado lo siguiente:
1- En el apartado WAN de mi router asus he especificado: ip dinamica, nombre de host: vacio y MAC: router vodafone
2- He entrado por SSH y he ejecutado el comando "nvram set wan_hostname=VFXXX/XXXX"
3-Me ha dado ip publica, gateway y dns publico y el router presentaba como si todo fuera bien.

Para mi desgracia... no funcionaba internat a pesar de todo...

¿Alguna idea?
 
#24
VictorC dijo:
Por lo tanto he realizado lo siguiente:
1- En el apartado WAN de mi router asus he especificado: ip dinamica, nombre de host: vacio y MAC: router vodafone
2- He entrado por SSH y he ejecutado el comando "nvram set wan_hostname=VFXXX/XXXX"
3-Me ha dado ip publica, gateway y dns publico y el router presentaba como si todo fuera bien.

Para mi desgracia... no funcionaba internat a pesar de todo...

¿Alguna idea?
Hola victor tengo todo igual que tu, has conseguido avanzar algo para quitar el router huawei? a ver si podemos consegirlo
 
#25
alvaropeseto77 dijo:
VictorC dijo:
Por lo tanto he realizado lo siguiente:
1- En el apartado WAN de mi router asus he especificado: ip dinamica, nombre de host: vacio y MAC: router vodafone
2- He entrado por SSH y he ejecutado el comando "nvram set wan_hostname=VFXXX/XXXX"
3-Me ha dado ip publica, gateway y dns publico y el router presentaba como si todo fuera bien.

Para mi desgracia... no funcionaba internat a pesar de todo...

¿Alguna idea?
Hola victor tengo todo igual que tu, has conseguido avanzar algo para quitar el router huawei? a ver si podemos consegirlo
Hola!,

No, sigo igual... no se si habrá que meterle al router wrt merlin o open wrt... pero no queria tener que hacerlo.

Saludos.
 
#26
Re: Re:

VictorC dijo:
pelepla dijo:
Y para 50/5 te han puesto el CH?

Supuestamente ponen el CG y dan el Huawei para hacer de router y voip
Ni idea...empece teniendo 30 y luego aumente a 50...

Lo he conseguido (a medias) siguientes estos pasos del hilo que me has mandado!!

 -           Buenas, no es PPPoE, es MER (o IPoE). Esto no es más que un DHCP pero verificando MAC y Hostname (en el TP-Link sería poniendo IP dinámica).
El servidor de Vodafone autentifica contra la MAC del Compal y contra el Hostname del router.
El problema es que Vodafone en el host utiliza un nombre no estandar (tiene una barra en medio, algo así: VFXXXXXX/XXXXXXX.
En internet, los hostname solo pueden llevar caracteres alfanuméricos y guiones -. Si el router neutro no envía el mismo hostname del router original, entonces no habrá internet, el servidor no nos da IP pública. Los routers neutros no admiten caracteres como la barra en el hostname; nosotros lo que hemos hecho ha sido eliminar esa limitación en el router Ubiquiti a través de la línea de comandos (no se si esto se podrá hacer en el TP-Link. (Gracias al usuarios andrew_mp)

 -          
Efectivamente por mas de que le reemplaze la "/"(0x2F) por un 0 (0x30) y le agrege un valor a otro caracter no funciona. Seguramente ni un md5sum o crc32 funcione, debe simplemente compara caracter x caracter. Con lo cual... toca las p___ en los firmwares originales.

Con Openwrt en ssh, "nvram set wan_hostname=VF..." va bien.  (gracias al usuario 
Guillote_rouco)

Por lo tanto he realizado lo siguiente:
1- En el apartado WAN de mi router asus he especificado: ip dinamica, nombre de host: vacio y MAC: router vodafone
2- He entrado por SSH y he ejecutado el comando "nvram set wan_hostname=VFXXX/XXXX"
3-Me ha dado ip publica, gateway y dns publico y el router presentaba como si todo fuera bien.

Para mi desgracia... no funcionaba internat a pesar de todo...

¿Alguna idea?

Gracias.
Ese post lo escribí yo hace tiempo ya y puedo decirte que a día de hoy a mi amigo le sigue funcionando perfectamente. Nosotros lo hicimos con un Ubiquiti ERLite3. Has probado sin poner nada en la mac? La autenticación la hace Vodafone si no recuerdo mal hacia la MAC del cable-modem, no hacia la del router. Del router coge el hostname. Si no te va, lo único que se me ocurre es que tu Asus no procese la "/" del hostname.

Saludos.
 
#28
Si no te he entendido mal, usas el Wireshark para captura de datos, pero es que con la última versión del firm de ese router (la que acaba en 05) no tienes que usar el Wireshark para capturar nada. Es más fácil de lo que parece:

1-Resetea el router.
2-Activa el port mirroring.
3-Conecta el router a la ONT y esperas 5-6 min.
4-Ese archivo generado lo abres con el Wireshark y ya puedes ver las contraseñas que necesitas (Internet, VOip, SSH...).
Buenas noche por mas que intento generar el archivo , no es posible. En el momento en el que cual empieza a hacerlo... a los pocos segundo se cierra el el portal del router, se corta el archivo de descarga y despues intentas entrar con usuario y contra genericos y nos funciona. A Alguien le pasa igual. Alguna solucion.

Gracias. Un saludo
 
#29
Hola. Quiero cambiar el router de la compañía por uno neutro y tengo todos los datos sacados. Mi duda es ¿podría poner una ont con sip y configurarla con los datos para conectarle el teléfono y asi no tener que poner el router de Vodafone en brigde por narices? ¿valdría cualquier ONT con rj11 en vodafone o tambien tiene que ser compatible con la OLT?
 
Arriba