No consigo que funcione la VPN con Mikrotik RB750gl

#1
Hola:
No consigo hacer funcionar la VPN con el Mikotik RB750GL. He seguido los pasos que exponeis en diferentes hilos y en otros foros, y nada.
No se si los problemas vendran por haber intentado antes montar la VPN para la Raspi.
Como digo, tengo una Raspi montada como servidor DLNA, Samba, Descargas Torrent, Apache, OwnCloud, Servidor de ebooks y noticias, etc. que dan servicio a la Intranet de casa.
A la raspi llego sin problemas por ssh y vnc desde fuera (internet), para lo cual me cree en su momento una cuenta en no-ip.com, y el script correspondiente corre en la raspi (cuando esta encendida).
Con la Raspi no he conseguido entrar por VPN, pero lo achacaba al Comtrend que tenia antes, por lo que decidi cambiar al Mikotik.
Ya con el Mikrokit y la 6.11 el Imagenio va de vicio. Y por ello me gustaria entrar por VPN para disponer de la TV este donde este, y de paso(sie es posible) poder entrar a la Raspi, su disco, etc...
Pongo pantallazos de los principales config del Mikrotik, a ver si veis algo que esté mal:

















Todo lo anterior esta bien???? Es suficiente o falta algo???
No falta habilitar el protocolo GRE en el router?
O los problemas m¡pueden venir de que al llegar la peticionde creacion de la VPN, el Router no sepa si son para el o para la Raspi? Aunque lo que hago es deshabilitarlo en el Nat de la raspi el puerto 1723 como se ve en los pantallazos anteriores.

Como veis tengo un lio de cuidado, y esto de las VPNs me supera con mucho.

Las peticiones al Router llegan, pues se increm,entan los contadores de paquetes correspondientes.

Saludos a todo este esùpendo foro, y Gracias por adelantado.

MarcoA.
 
#2
Añado que para entrar por VPN, estoy prbando con un movil HTC one con 4G, y llegar llego, pùes como comentaba los contadores se incrementasn.
Puff, los pantallazoas que he incrustado no se ven.
Los recargo con mejor resolucion.....
 
#4
Lo que no entendo es por qué no usas el Winbox, cuando toda mi configuración está hecha con él, y al que ya estamos acostumbrados. Me cuesta ver tu configuración vía web.

Lo único que hay que hacer para conectar por VPN es crear un usuario en Secrets, su contraseña y asignarle el perfil default-encryption.
 
#5
Hola:
Probare´ con el winbox, de hecho casi todas las otras labores hasta ahora las he hecho con él.
Lo que ocurre es que entré con otro ordenador, en el que no tenia el winbox instalado, y resulta casi igual de comodo hacerlo desde el navegador, como con su aplicación, con la diferencia de que no hya que instalar nada, y no soy muy partidario de instalar una aplicacion por cada cacharrito que entra en casa. ;)

Repasaré todo nuevamente.
Saludos.
 
#6
Hola,

El profile que tienes que asignar al usuario es el "default-encryption" que es el que ya estará preconfigurado con ip y que le indica de donde asignar las ips del pool para vpn.

Ya de paso veo que en la tabla de reglas de NAT creo que te sobra la 6, que ya la tienes en la 2.
También tienes otra regla para redirigir el puerto 47 udp (ojo, que no es GRE), si las has puesto por algo de esto, también te sobraría.

Saludos
 
#7
Hola:
He estado probando con el Winbox, y nada de nada.
No soy capaz de conectar el HTC one mediante VPN a mi Red.
En el movil sale el mensaje de Conectando, pero a los 20-30 seg. sale Desconectado, y de ahí no pasa.
Adjunto en un unico pantallazo lod principales parametros de config. Tambien se ve el log como indica que el dispositivo con IP 176.83.36.xxx estyasblece conexion TCP:



(La imagen esta en alta resolucion para ver todo en un unico pantallazo)

Saludos y Gracias nuevamente.

MarcoA.
 
#11
Muchas GRACIAS, Malosa.
He conectado el movil a una wifi, y sin problemas, se ha conectado a la primera.
No sabía que los APN de Movistar capasen las VPN. Tendré que buscar alguno que no lo haga.
Eres un crack. Gracias a gente como tu, funcionan este tipo de foros.
Saludos,
MarcoA.
 
#14
Re:

jimenoma dijo:
Muchas GRACIAS, Malosa.
He conectado el movil a una wifi, y sin problemas, se ha conectado a la primera.
No sabía que los APN de Movistar capasen las VPN. Tendré que buscar alguno que no lo haga.
Eres un crack. Gracias a gente como tu, funcionan este tipo de foros.
Saludos,
MarcoA.
El Apn de Movistar por defecto CAPA las VPN. Busca en la comunidad movistar que tienen publicado otro que si funciona ( no usa el proxy).
 
#15
Re: No consigo que funcione la VPN con Mikrotik RB750gl. Con

Hola.
Como comenté antes ya entro sin problemas por VPN.
Pero esta mañana me econtre un monton de intentos de acceso de entrar por telnet al router desde IPs chinas, de malasya, thailandia, hongkong con los usuarios root, admin y cusadmin.

http://subefotos.com/ver/?cb976c32837d83091b756623e4a44e59o.jpg[img]
[img]http://thumbs.subefotos.com/cb976c32837d83091b756623e4a44e59o.jpg[/url]

Es mas, parecdnen que algunos intentos han prosperado.

Aparte de estos intentos que se ven en el pantallazo, hay otros desde IPs spanolas (80.58.63.224) on el usuario 1234 o support, de las que asumo que son desde Telefónica, aunque no deja de extrañarme bastante.

Sinceramente estoy un poco acojonado. No me preocupa demasiado pues n0 tenia nada encendido excepto el Asus ac68 como AP.

Como lo veis? Un poco raro, no?
En algun otro hilo se hablo de intentos de entradas desde IPs chinas y americanas.
Es normal que intenten entrar desde Telefónica, quizas para labores de mantenimiento, actualciones.

Me he asegurado y no tengo abierto el puerto 23 telnet. Tenia abierto en su momento alvuno pero solo para la raspi.
Ttambien cambié la clave de admin.

Saludos, MarcoA.
 
#16
Si no tienes el puerto 23 abierto, ¿entonces que significa el mensaje "user admin logged in from..."?
¿Si no te interesa, pq no desactivas el permiso para logarse en el router desde la wan?¿No se puede?
¿El router no tiene ningún mecanismo que después de x intentos seguidos o en un periodo corto de tiempo se bloquea esa IP?
En mi NAS tb veo intentos de entrar, pero después de 3 intentos fallidos se añade esa IP a una lista negra.
 
Arriba