MANUAL: FTTH Movistar con router neutro (firmware Linux)

Begepeich dijo:
aticatac72 dijo:
Lo más probable es que quite Imagenio y ponga un Asus RT-AC66U que es lo mejor que he visto en router-wifi a un precio bastante razonable; y con el AP wifi preparado para el futuro. Con algún firmware libre creo que conseguiré hacer funcionar internet para FTTH con Movistar.

¿Alguien lo tiene configurado y funcionando? Parece que la mejor opción es DD-WRT.
Solo un apunte.
Hasta donde yo sé, no te hace falta ningún firmware libre para que puedas conectar el Asus a la ONT y te funcione el internet. Con el que trae de serie eso lo haces en 2 minutos.

Otra cosa es que quieras imagenio etc... En ese caso tendrías que dejar también el comtrend entre medias o poner un Mikrotik.
Muchas gracias, Begepeich. Lo de Imagenio no es problema, lo puse por tener algunos canales extra pero tengo cosas mucho más importantes y además otras opciones que puedo poner como Digital+ por parabólica o Intenet. Creo optaré por quitar Imagenio y poner el ASUS RT-AC66U con el firmware Merlin, al menos inicialmente.

Aunque no lo necesite de momento, ¿sabes si VoIP también es posible con el firmware de serie o con Merlin?

Muchas gracias
 
Anonimo dijo:
Aunque no lo necesite de momento, ¿sabes si VoIP también es posible con el firmware de serie o con Merlin?

Muchas gracias
No lo es, el firmware de serie solo tiene una VLAN para datos, no te permite poner VoIP. Y con DD-WRT tampoco se puede poner VoIP.

Si se recomienda Mikrotik es por algo, es porque hoy día es lo único 100% compatible con FTTH+VoIP y con buenas prestaciones.

Si pones cualquer tipo de router que no sea Mikrotik, solo vas a tener internet, ni Imagenio ni VoIP.

Con OpenWRT sí podrías, pero muchos usuarios han reporado problemas (no alcanzar los 100 megas, etc.). No es problema de la configuración de esta web (ni mucho menos) sino del funcionamiento del firmware con determinados modelos. De hecho, hasta donde yo sé, el Asus que tú dices no es compatible con OpenWRT.
 
aticatac72

Malosa dijo:
Anonimo dijo:
Aunque no lo necesite de momento, ¿sabes si VoIP también es posible con el firmware de serie o con Merlin?

Muchas gracias
No lo es, el firmware de serie solo tiene una VLAN para datos, no te permite poner VoIP. Y con DD-WRT tampoco se puede poner VoIP.

Si se recomienda Mikrotik es por algo, es porque hoy día es lo único 100% compatible con FTTH+VoIP y con buenas prestaciones.
Bueno, de todas formas no tengo pensado poner teléfonos VoIP. Creo que Telefónica me obliga a mantener RTB y pagar la cuota de línea por el par de cobre igualmente y además, por lo que me han comentado, las tarifas son las mismas. El VoIP carece de importancia porque en resumidas cuentas me iba a gastar dinero en los teléfonos IP y no me iba a ahorrar ni un céntimo en la factura. Y como yo están todos los usuarios que tengan FTTH y línea telefónica de cobre.

Gracias de todos modos.
 
Lógicamente, la VoIP con Movistar es para aprovechar las ventajas de SIP, como: llamadas simultáneas, tener el fijo en el móvil. Incluso poner una centralita (yo tengo una Rapsberry Pi, para hacer todo topo de virguerías). No tienen que ser teléfonos IP fijos, puede ser softphone a coste cero. Pero como tal, la VoIP no te ahorra dinero (las llamadas, una vez en la central, van por la red convencional teléfonica).

http://www.adslzone.net/postt312263.html

Evidentemente el coste de llamada es el mismo. Aunque sí te compras teléfonos IP perfectamente podrías configurarlos un segundo operador para llamadas por internet.
 
WRT54GL y FTTH Telefónica Movistar

Por si le sirve a alguien, he configurado el WRT54GL con DD-WRT v24-sp2 (10/10/09) std, y siguiendo el tutorial que aparece en el primer post de este hilo no me funciona. Bueno, el WiFi sin problemas pero por cable nada.

En este hilo se muestra la siguiente imagen:



Para que me funcionen las 4 bocas por cable Ethernet he tenido que dejar los 4 puertos Ethernet tal como vienen por defecto, en la VLAN 0 y Assigned To Bridge.

También he tenido problemas si iba guardando y aplicando los cambios tal como aquí se recomienda. He tenido que guardar los cambios pero no aplicar hasta el final, simplemente dando a Reboot Router en Administración (Management) como aquí se recomienda.

He hecho pruebas de subida y bajada por cable y los resultados han sido algo mejor de lo esperado. He conseguido en testdevelocidad.es 50 Mbps de bajada y 10 Mbps de subida. Aunque tengo contratados 100/10, no es mi mayor problema ahora mismo dejarlo así.
 
Hola!

Tengo un Linksys E4200 con tomato raf 1.28.9013 y siguiendo el metodo de este mismo foro (con unas ligeras variaciones de ruta) tengo internet e imagenio.

Puedo ver imagenio tanto desde el deco como por wifi con unicamente 2 pegas.

Algunos canales de alta definicion (no todos) presentan pantalla negra. No me es posible verlos ni en el PC ni en el deco.

El otro problema es que si alguien quiere ver un canal en el deco y yo otro a traves de la wifi, es imposible. O ves imagenio en el deco o en el PC pero no en los dos a la vez.

Sospecho que esto debe ser algun problema en mi configuracion y quisiera saber si la ha pasado a alguien mas y si ha logrado solucionarlo.

Si nadie lo sabe, tendré que seguir probando.

Gracias y saludos.
 
boris_karloff dijo:
Hola!

Tengo un Linksys E4200 con tomato raf 1.28.9013 y siguiendo el metodo de este mismo foro (con unas ligeras variaciones de ruta) tengo internet e imagenio.

Puedo ver imagenio tanto desde el deco como por wifi con unicamente 2 pegas.

Algunos canales de alta definicion (no todos) presentan pantalla negra. No me es posible verlos ni en el PC ni en el deco.

El otro problema es que si alguien quiere ver un canal en el deco y yo otro a traves de la wifi, es imposible. O ves imagenio en el deco o en el PC pero no en los dos a la vez.

Sospecho que esto debe ser algun problema en mi configuracion y quisiera saber si la ha pasado a alguien mas y si ha logrado solucionarlo.

Si nadie lo sabe, tendré que seguir probando.

Gracias y saludos.
puedes poner una copia de las configuraciones que has puesto?

como has hecho para que te funcione el menu?

si puedes pasar un backup de las configuracion estaria bien.
 
Imagenio

Hola:

Yo tengo un asus rt-n66u con tomato raf 1.2 y estoy desesperado porque por más que le doy vueltas solo consiguo internet.

VozIP me da igual, pero con imagenio no hay manera.

Alguien puede poner (o el compañero de 2 post más arriba) que configuración a utilizado o pantallazos para ver su configuración y como ha conseguido ver imagenio?.

Gracias.
 
Puies la configuracon es basicamente la que pone castorcillo, la diferencia es que he definido las rutas que vienen en el comtrend (aunque en interface distinto)

En el comtrend vienen mas direcciones, son las de las diferentes vlan. No estan escondidas y es facil encontrarlas. Yo las he definido en scripts/init

sleep 10;
# Red 10.x y 172.x
ifconfig br0:0 10.x.x.1 netmask 255.255.255.248 up;

ifconfig br0:1 172.x.x.2 netmask 255.255.240.0 up;

route add -net 172.x.x.0 netmask 255.255.240.0 gw 172.26.208.1 metric 1 dev br0:1;
route add -net 172.x.x.0 netmask 255.255.255.224 gw 172.26.208.1 metric 3 dev br0:1;
route add -net 172.x.x.0 netmask 255.255.255.192 gw 172.26.208.1 metric 3 dev br0:1;

Disculpa que cambie mis direcciones por x, probablemente sean genericas pero por si las moscas...

La direccion 10.x es la que conecta con del deco y la mascara nos permitiria conectar hasta 6 decos.

La direccion 172.x creo que se corresponde con la vlan2 (del comtrend). He respetado las metricas originales.
En un momento dado las cambié por 0 pero el problema de mi consulta no desaparece.

Por ultimo hice un scaneo de mi ip de internet a traves de la web de shield up y me salio passed con todos los puertos en stealth. Con el comtrend me daba fail y todos los puertos en blocked.

Desconozco si a traves de la 172.x pierdo o no segurida y tal vez deba definir alguna regla iptables.

Espero haberte ayudado.

Saludos cordiales.
 
Re: Imagenio

itlo dijo:
Hola:

Yo tengo un asus rt-n66u con tomato raf 1.2 y estoy desesperado porque por más que le doy vueltas solo consiguo internet.

VozIP me da igual, pero con imagenio no hay manera.

Alguien puede poner (o el compañero de 2 post más arriba) que configuración a utilizado o pantallazos para ver su configuración y como ha conseguido ver imagenio?.

Gracias.
Por curiosidad... tienes definida la Vlan1?, cambiala por vlan2.

Pasa tu los pantallazos y lo comparo con el mio. Tengo un linksys E2000 y veo imagenio.
 
Re: Imagenio

mikeltb dijo:
itlo dijo:
Hola:

Yo tengo un asus rt-n66u con tomato raf 1.2 y estoy desesperado porque por más que le doy vueltas solo consiguo internet.

VozIP me da igual, pero con imagenio no hay manera.

Alguien puede poner (o el compañero de 2 post más arriba) que configuración a utilizado o pantallazos para ver su configuración y como ha conseguido ver imagenio?.

Gracias.
Por curiosidad... tienes definida la Vlan1?, cambiala por vlan2.

Pasa tu los pantallazos y lo comparo con el mio. Tengo un linksys E2000 y veo imagenio.
Hola:

Ya lo he conseguido,volví a configurarlo y ahora va todo ok.
Por cierto que he probado a cargar los canales en el videolan por wifi y no es que me vaya a tirones,es que no se ven,me han comentado que tengo que marcar a parte de igmproxy el udproxy.
 
Hola mikeltb

No tengo definida la vlan1, tengo la misma configuracion que puso el usuario castorcillo salvo por la modificacion del script de inicio que expuse en el comentario anterior.

Te pondria los pantallazos pero me van a llamar la atencion por que tal como te he comentado, son identicos a los de castrocillo.
Si me dices como contactar contigo te los paso sin problema.
-------------------------------------------------------------------------------
Hola itlo

Si el udproxy es el que esta en firewall (Enable Udpxy), yo lo tengo desactivado. Lo active en su momento pero no me dio buen resultado y lo volvi a desactivar.

¿Has probado sin el a ver si te mejora o empeora el rendimiento?

Saludos
 
tengo el mismo modelo de Router ASUS RT-N66U, pero es que solo consigo Internet e imagenio por el deco. Por el Pc por cable no logro ver ningún canal. Si lo sustituyo por el router de telefónica si los veo por el PC.

Podeis ayudarme?

Si eso te mando como tengo mi configuración.
 
Sigo peleándome con esto.
¿Cómo es posible que con la configuración de castorcastorcillo en un linksys e2000 me funciona y en el ASUS N-RT66U exactamente con la misma configuración no pueda ver los canales de imagenio en el PC?

Es decir:

e2000: Internet+Imagenio Deco+imagenio PC
ASUS: Internet+Imagenio Deco

La única diferencia es el modelo y el firmware de Tomato de la pagina de victek.

Un saludo.
 
comparándolo con el router de telefónica observo que desde la LAN si ve la VLAN de Imagenio vlan2. Al hacer un ping desde el PC llega perfectamente al deco y al realizar un tracert observo que es el router quien lo enruta.

Lo que no sé es como diablos hacer en tomato para que desde la LAN vea la VLAN2...
 
Dudas sobre router a elegir

Hola.
Tras leer un buen rato el foro se me estan creando mas dudas de las que traia. Quiero cambiar el dichoso comtrend por un router neutro, pero veo que está la opcion mikrotik o de otros routers cambiandoles el firmware. Dentro de los firmwares veo que hay a su vez varios distintos.
Me quiero decantar mas bien por un router normal cambiando el firmware a uno basado en linux, ya que me muevo bien en estos sistemas. Necesitaria saber que router seria mas recomendable, teniendo en cuenta que querria que tenga gigabit en la lan y que soporte 802.11n.
Tambien tengo dudas al respecto, que no se si dependen del firmware o del hardware elegido. Me gustaria que tenga gestion de WOL de dispositivos dentro de la LAN desde internet y que pueda soportar trunk de puertos gigabit para conectar una NAS con doble nic. Si tiene servidor de VPN mejor que mejor.
Gracias por vuestras ayuda. Saludos a todos.
 
Re: Dudas sobre router a elegir

djlevi dijo:
Hola.
Tras leer un buen rato el foro se me estan creando mas dudas de las que traia. Quiero cambiar el dichoso comtrend por un router neutro, pero veo que está la opcion mikrotik o de otros routers cambiandoles el firmware. Dentro de los firmwares veo que hay a su vez varios distintos.
Me quiero decantar mas bien por un router normal cambiando el firmware a uno basado en linux, ya que me muevo bien en estos sistemas. Necesitaria saber que router seria mas recomendable, teniendo en cuenta que querria que tenga gigabit en la lan y que soporte 802.11n.
Tambien tengo dudas al respecto, que no se si dependen del firmware o del hardware elegido. Me gustaria que tenga gestion de WOL de dispositivos dentro de la LAN desde internet y que pueda soportar trunk de puertos gigabit para conectar una NAS con doble nic. Si tiene servidor de VPN mejor que mejor.
Gracias por vuestras ayuda. Saludos a todos.
buenas, no se con que compañía estas, si movistar, ono...
Desde luego a dia de hoy mikrotik parece la mejor opción si tienes movistar pero..... no tiene wifi.

Hay mas router neutros, puedes visitar la pagina de victek. Esta pagina esta orientada al firmware Tomato y podras ver los modelos de routers compatibles. Existe también un simulador donde podrás ver las diferentes características que te puede ofrecer este firmware.
Hablan muy bien del Asus N-RT66U, yo lo tengo y el firmware que viene es una maravilla aunque no es compatible o al menos a dia de hoy con movistar.
 
Re: Dudas sobre router a elegir

mikeltb dijo:
djlevi dijo:
Hola.
Tras leer un buen rato el foro se me estan creando mas dudas de las que traia. Quiero cambiar el dichoso comtrend por un router neutro, pero veo que está la opcion mikrotik o de otros routers cambiandoles el firmware. Dentro de los firmwares veo que hay a su vez varios distintos.
Me quiero decantar mas bien por un router normal cambiando el firmware a uno basado en linux, ya que me muevo bien en estos sistemas. Necesitaria saber que router seria mas recomendable, teniendo en cuenta que querria que tenga gigabit en la lan y que soporte 802.11n.
Tambien tengo dudas al respecto, que no se si dependen del firmware o del hardware elegido. Me gustaria que tenga gestion de WOL de dispositivos dentro de la LAN desde internet y que pueda soportar trunk de puertos gigabit para conectar una NAS con doble nic. Si tiene servidor de VPN mejor que mejor.
Gracias por vuestras ayuda. Saludos a todos.
buenas, no se con que compañía estas, si movistar, ono...
Desde luego a dia de hoy mikrotik parece la mejor opción si tienes movistar pero..... no tiene wifi.

Hay mas router neutros, puedes visitar la pagina de victek. Esta pagina esta orientada al firmware Tomato y podras ver los modelos de routers compatibles. Existe también un simulador donde podrás ver las diferentes características que te puede ofrecer este firmware.
Hablan muy bien del Asus N-RT66U, yo lo tengo y el firmware que viene es una maravilla aunque no es compatible o al menos a dia de hoy con movistar.
Gracias por tu respuesta. Yo tengo FFTH de movistar.
La opcion del Asus N-RT66U la estoy valorando muy seriamente. Me llamaba tambien el ac, aunque no tengo dispositivos que lo aprovechen, pero el precio es bastante cercano... Respecto al WOL he visto que el tomato raf lo trae. Con respecto al port trunk sabeis si se puede realizar en algun router de estos o tendre que buscarme un switch a parte? Gracias.
 
algo he conseguido,

por lo menos ya veo desde la LAN el deco, haciendo tracert al deco me hace la traza completa.
Lo que he hecho es añadir las rutas que mas arriba indica Boris:

ifconfig br0:0 10.x.x.1 netmask 255.255.255.248 up;

ifconfig br0:1 172.x.x.2 netmask 255.255.240.0 up;

route add -net 172.x.x.0 netmask 255.255.240.0 gw 172.26.208.1 metric 1 dev br0:1;
route add -net 172.x.x.0 netmask 255.255.255.224 gw 172.26.208.1 metric 3 dev br0:1;
route add -net 172.x.x.0 netmask 255.255.255.192 gw 172.26.208.1 metric 3 dev br0:1;

Tengo que añadir que ahora ME FUNCIONA EL MENU en el deco salvo que no puedo ver los trailers, por lo demas navego por él sin problemas.
Pero....

sigo sin ver imagenio en el PC :(
 
Configuración

Buenas, después de leer vuestras respuestas, tengo ftth de Movistar 100 megas que me llegan alrededor de 50 megas vía wifi. Compraríais un router neutro para mejorar esa velocidad o creéis que no mejoraría mucho.
 
Arriba