MANUAL: Configuración VoIP FTTH Jazztel

#41
Ante todo muchas gracias neaw por tu respuesta... a ver si entre todos los echamos a andar.
Esta tarde/noche cuando llegue a casa lo probare.
De las imágenes que aportas estaba rellenando todas las casillas excepto.... el auth_id lo dejaba en blanco (me baje un manual de la red y ese campo aparecía en blanco... por si quieres probar).
Y en el proxy probé poniendo la dirección IP se extrae de la config del router algo como Primary Proxy Server: 212.XXX.XXX.XXX y otras veces con el Primary Registrar Server: ims.jazztel.net.
Nota tonta.... estas usando el mikrotik para el routing o directamente el ZTE, si el microtik tienes q asegurarte de abrir bien los puertos.....
 
#42
Ante todo muchas gracias neaw por tu respuesta... a ver si entre todos los echamos a andar.
Esta tarde/noche cuando llegue a casa lo probare.
De las imágenes que aportas estaba rellenando todas las casillas excepto.... el auth_id lo dejaba en blanco (me baje un manual de la red y ese campo aparecía en blanco... por si quieres probar).
Y en el proxy probé poniendo la dirección IP se extrae de la config del router algo como Primary Proxy Server: 212.XXX.XXX.XXX y otras veces con el Primary Registrar Server: ims.jazztel.net.
Nota tonta.... estas usando el mikrotik para el routing o directamente el ZTE, si el microtik tienes q asegurarte de abrir bien los puertos.....
 
#43
Re:

RubenGP dijo:
Ante todo muchas gracias neaw por tu respuesta... a ver si entre todos los echamos a andar.
Esta tarde/noche cuando llegue a casa lo probare.
De las imágenes que aportas estaba rellenando todas las casillas excepto.... el auth_id lo dejaba en blanco (me baje un manual de la red y ese campo aparecía en blanco... por si quieres probar).
Y en el proxy probé poniendo la dirección IP se extrae de la config del router algo como Primary Proxy Server: 212.XXX.XXX.XXX y otras veces con el Primary Registrar Server: ims.jazztel.net.
Nota tonta.... estas usando el mikrotik para el routing o directamente el ZTE, si el microtik tienes q asegurarte de abrir bien los puertos.....

HE CONSEGUIDO REGISTRARLOOOOOOO XD

Recibo llamadas, no puedo hacer tengo que indagar
 
#45
aquí he puesto



donde dice SIP Reg User Agent Name: ZXHN H298N/V1.1.4_JAZZT15


luego en la otra pagina:



Display Name: Nº de teleno con el +34
User ID: Nº de teleno con el +34
Password: la contraseña
Use Auth ID: YES
Auth ID: XXXXXXXXXXXXXXX@ims.jazztel.net

y en Proxy :
Proxy: ims.jazztel.net:5060
Outbound Proxy: 212.106.212.22:5060
Use Outbound Proxy: YES

también en NAT Settings:

NAT Mapping Enable: YES
NAT Keep Alive Enable: YES


creo que me quedara configurar lo de
Dial Plan
Dial Plan: etc...
recibir si que he recibido echo una prueba llamando desde el movil al fijo y funciona y se escucha pero desde el fijo al movil no.

del Mikrotik los abri el puerto 5060 pero lo he vuelto a cerrar
 
#46
Tio si !!! ahora registra !!
Neaw !! eres un crack !!
Prueba a quitarle el stun server.
Yo se lo he quitado y registra también
Ahora estoy en el curro y no puedo cambiar el router por el microtik, por lo q te al autenticar en dos sitios falla.....
 
#47
Re:

RubenGP dijo:
Tio si !!! ahora registra !!
Neaw !! eres un crack !!
Prueba a quitarle el stun server.
Yo se lo he quitado y registra también
Ahora estoy en el curro y no puedo cambiar el router por el microtik, por lo q te al autenticar en dos sitios falla.....
Si lo he quitado y funciona sin el Stun server,
lo que ahora es lo de El Dial plan y códec, para poder hacer llamadas, porque recibir si se puede pero llamar no.
 
#49
Estoy en casa haciendo pruebas tanto como diferentes dial plan como con llamadas.
A mi lo que me pasa es lo siguiente:
-Me llaman (realizo llamada desde el movil al fijo).... suena (luego encamina)... descuelgo.... yo oigo perfectamente en el fijo pero el que me esta llamando (el del movil) no me escucha.
-LLamo desde el fijo.... descuelgo el telefono, se oye el tipico pitido de q hay señal, marco el numero, no da señal ni nada por el estilo sin embargo pasados unos segundos el domo muestra como que te han descolgado puesto que el contador de segundos empieza a incrementarse.
Personalmente creo que es algo de la configuracion de puerto del mikrotik.
A ver si algun master de este router nos ilumina.
Gracias.
 
#50
Hay que mapear los puertos en el router hacia la centralita/ATA :

5060 UDP – Puerto de señalización SIP, usado por los teléfonos SIP remotos.

10000 a 20000 UDP – Puerto de audio RTP, usados por los teléfonos SIP remotos. Este rango puede limitarse.

4569 UDP – Puerto de señalizacion IAX, usado por enlaces entre Asterisk y por softphones remotos.
 
#52
Hola a todos, ayer después de mil pruebas y gracias a neaw que consiguió abrir la caja de los truenos en cuanto a la configuración del ATA por fin conseguí q funcionara correctamente, debo indicar que para que funcionara correctamente tuve que agregar las siguientes reglas al mikrotik para priorizar el trafico q a continuación enumero.

/ ip firewall mangle
add chain=prerouting protocol=udp dst-port=10000-20000 action=mark-connection new-connection-mark=voipconn passthrough=yes comment="Entrada Voip" disabled=no
add chain=prerouting protocol=udp dst-port=5061 action=mark-connection new-connection-mark=voipconn passthrough=yes comment="" disabled=no
add chain=prerouting connection-mark=voipconn action=mark-packet new-packet-mark=voippack passthrough=no comment="" disabled=no
add chain=postrouting protocol=udp dst-port=10000-20000 action=mark-connection new-connection-mark=voipconn passthrough=yes comment="Salida Voip" disabled=no
add chain=postrouting protocol=udp dst-port=5061 action=mark-connection new-connection-mark=voipconn passthrough=yes comment="" disabled=no
add chain=postrouting connection-mark=voipconn action=mark-packet new-packet-mark=voippack passthrough=no comment="" disabled=no

/ queue tree
add name="voip down" parent=global-in packet-mark=voippack limit-at=1000000 queue=default priority=1 max-limit=1000000 burst-limit=0 burst-threshold=0 burst-time=0s \
disabled=no
add name="voip up" parent=global-out packet-mark=voippack limit-at=1000000 queue=default priority=1 max-limit=1000000 burst-limit=0 burst-threshold=0 burst-time=0s \
disabled=no

Comentar también que prácticamente utilice la configuración del ATA de neaw salvo q quite en cada línea donde el ponía el parámetro y agregaba :5060. (quite los :5060)

También agregue un dial plan genérico para España.

(<:0034>xxxxxxxxx|xx.|*xx.|**xx.)

Comentar q todo funciona OK, salvo que algunos números de teléfono no se porque razón o les da comunicando o no se oye, con los fijos funciona perfectamente. Cualquier nueva sugerencia es bienvenida pero me da la sensación que esa salvedad era debida a los miles de registro contra el ATA q realice ayer, comentare si la cosa se ha estabilizado, probé unos 10 números de teléfono teniendo problemas con 2 móviles (de 5 q probé), fijos funcionaron correctamente. Lo mas raro aun fue cuando desde un móvil llamaban y daba comunicando pero si lo hacías con numero oculto funcionaba perfectamente por lo que se lo achaco a la operadora y no a la configuración.
Saludos,
 
#53
Re:

Malosa dijo:
Centralita FreePBX

Creáis un Trunk y en Trunk name lo que queráis....

En Peer details:

type=peer
fromuser=[tu teléfono empezando con +34]
auth=XXXXXXXXXXXXXXX@ims.jazztel.net
secret=[tu contraseña]
fromdomain=ims.jazztel.net
host=ims.jazztel.net
outboundproxy=[la dirección IP de tu proxy]
port=5060
nat=yes
insecure=port,invite
dtmfmode=auto
disallow=all
allow=ulaw,alaw


En User context: "from-trunk".

en User detail:

type=peer
username=[tu teléfono empezando con +34]
secret=[tu contraseña]
fromdomain=ims.jazztel.net
host=ims.jazztel.net
port=5060
outboundproxy=[la dirección IP de tu proxy]
qualify=no
nat=yes
insecure=port,invite
dtmfmode=auto
canreinvite=no
disallow=all
allow=ulaw,alaw
outboundproxyport=5060

Y, por último, en Register string...

[teléfono con +34]@ims.jazztel.net:[contraseña]:[XXXXXXXXXXXXXXX@ims.jazztel.net]@[proxy]/[teléfono con +34]

Tenéis que configurar también lo siguiente.

En Asterisk SIP Settings:

Registration Times
3600 (defaultexpiry)

Other SIP Settings

useragent = ZXHN H298N/V1.1.4_JAZZT15
prack = yes


Hola alguien que controle freepbx podia darnos algo mas de informacion sobre la configuracón, por que solo con esto no conseguimos configurarlo he probado a toquetear mas cosa, y he investigado un poco pero no hay manera.

Muchas gracias.
 
#55
La VoIP es necesaria tanto si se quiere retirar el router como si se quieren utiliza teléfonos IP.

Antes de nada, hay que obtener los datos SIP. Lo haremos exportando la configuración del propio router: primero guardamos el archivo.

Segundo, descargamos este programa:
http://aluigi.altervista.org/mytoolz/offzip.zip

Hay que tener el archivo de configuración (config.bin) y el programa en la misma carpeta, además hay que crear una carpeta llamada off dentro de ésta, que es donde el programa pondrá los archivos... Debe estar algo así:

(carpeta) off
(archivo) config.bin
(archivo) offzip.exe


Una vez con eso, ejecutamos la consola (símbolo de sistema), nos desplazamos hasta el directorio y ponemos en consola: offzip -a config.bin off 0

Y ya nos aparecen los archivos dentro de la carpeta que creamos previamente.
a mi no me reconoce el archivo config.bin , al abrirlo me sale "error no such file or directory".. alguien tiene idea de porque?
 
#56
tunet dijo:
a mi no me reconoce el archivo config.bin , al abrirlo me sale "error no such file or directory".. alguien tiene idea de porque?
Localiza la CARPETA que contiene el offzip.exe, el config.bin y la carpeta off (que tu deberías haber creado).

Dejas pulsado Mayuscula y haz Click Derecho en dicha carpeta (la que lo contiene todo) y le das a "Abrir ventana de comandos aquí"

Te saldrá una ventana de comandos negra. Ahí escribes esto.

offzip -a config.bin off 0

Si todo ha ido bien, te deben de salir los ficheros en la carpeta off
 
#58
Parece que todos los que conseguís conectar algo detrás de un router o switch es por medio de un mikrotik, pero no hay información alguna para los que usamos otros aparatos.

Lo único que he conseguido yo es configurar el VLAN Tagging en el puerto WAN del ASUS, y el ZTE si me registra detrás de él. Pero nada de phonerlite ni Asterisk.

Hay alguna configuración adicional que haceis en el mikrotik? Activáis VLAN Tagging en algún puerto LAN? O en los dispositivos que registran el teléfono? ¿Hay que hacer algún tipo de bridge? Alguna pista!

Es que lo único que hay son scripts para mikrotik, pero no hay información alguna para los que no usamos ese aparato y no conocemos ese lenguaje. si tan solo posteaseis un resumen de la estructuras que hay que crear os lo agradecería.
 
#59
champucham dijo:
Lo único que he conseguido yo es configurar el VLAN Tagging en el puerto WAN del ASUS, y el ZTE si me registra detrás de él. Pero nada de phonerlite ni Asterisk.
Mira la configuración del phonerlite, yo estoy con un Asus y se registra perfectamente.
 
#60
kew dijo:
Mira la configuración del phonerlite, yo estoy con un Asus y se registra perfectamente.
Ya la he revisado un montón de veces, y los puertos abiertos en servidor virtual.

Kew, podrias decirme tu configuración del ASUS en...
WAN > Conexión a internet
y en
LAN > IPTV?

Y una ultima pregunta, El pc que te registra con phonerlite ¿Conectado por wifi o por cable? ¿A que puerto?

Me harías un GRAN favor! :D
 
Arriba