Impresiones switch Netgear GS108E IGMP Snooping y MovistarTV

#1
Bueno lo prometido es deuda.
Puse hace tiempo en el foro que tenia la siguiente instalacion:
ONT---mikrotik RB450G---Switch tp link sg108----lan/AP WR1043ND--lan wifi

Como el AP no admite IGMP Snooping para filtrar el trafico multicast y el Switch tp link aunque en la web ponia que si soportaba igmp snooping no lo hace (confirmado por tp link) pues me compre el netgear GS108E

Ahora la instalacion es:
ONT---mikrotik RB450G---Switch netgear gs108E----lan/AP WR1043ND--lan wifi

Una vez me han instalado el movistar mini me puse a hacer pruebas.

Un ordenador conectado por cable al switch con el VLC viendo una canal de movistar tv y ver si el trafico pasaba al ap.
Mi gozo en un pozo. EL AP se saturaba e incluso llegaba a colgarse.
El AP lo tenia con el firmware oficial de tp link.

Despues de probar todas las configuraciones del switch de IGMP etc y a punto de darme por vencido, se me ocurrio poner al AP el firmware gargoyle.
Y tachan, sin hacer nada raro funciona bien y las lucecitas no parpadean como locas cuando pongo a funcionar el movistar tv en otro equipo que cuelque del switch.
Asi que por ahora asi lo dejo.

No se exactamente que cambia de una configuracion del ap a otra, pero va.
Lo unico que le he hecho al gargoyle a posteriori es activar los canales 12 y 13 y activar los 40Mhz de ancho de banda con noscan.
Va como un tiro llegando a los 95 megas de transferencia por wifi.

Saludos.
 
#2
He resumido mucho la explicacion, pero por supuesto aclaro que la configuración del AP wifi es como AP puro, sin subredes, vlans ni dhcp activados. EL mikrotik lo tengo configurado como igmp proxy para que haga los queries con el fast leave activado.
Si necesitais explicacion de algo en concreto proguntar.
A mi me gustaria que alguien me pudiera decir por que con un firmware si y con otro no va.
Gracias.
 
#4
Pues tengo que hacer más pruebas, pero en principio sí que tiene que hacerlo bien.
Creo que el problema era del AP con firmware original que debia de hacer peticion de multicast y el switch se pensaba que le estaba pidiendo el stream de movistartv y se lo mandaba saturandolo.
El AP con el firmware gargoyle no lo hace y por eso no lo satura.
Tanto el firware original del AP como el gargoyle no tienen puesto igmp snooping ni ebtables configurado por lo que no filtrarian ninguno el multicas, seria todo cosa del switch.
Esto es lo que me ha dejado un poco extrañado pero como digo es así.
Haré más pruebas este finde y os cuento.
Saludos.
 
#5
Anonimo dijo:
Pues tengo que hacer más pruebas, pero en principio sí que tiene que hacerlo bien.
Creo que el problema era del AP con firmware original que debia de hacer peticion de multicast y el switch se pensaba que le estaba pidiendo el stream de movistartv y se lo mandaba saturandolo.
El AP con el firmware gargoyle no lo hace y por eso no lo satura.
Tanto el firware original del AP como el gargoyle no tienen puesto igmp snooping ni ebtables configurado por lo que no filtrarian ninguno el multicas, seria todo cosa del switch.
Esto es lo que me ha dejado un poco extrañado pero como digo es así.
Haré más pruebas este finde y os cuento.
Saludos.

Comprueba que el switch tenga puesto el ultimo firmware, ya que parece que en otros es seguro que tienen algún bug en el Snooping.
En la configuración del IGMP Snooping creo que solo hay que marcar el "Block Unknown MultiCast Address" y puede que deshabilitado el "validate IGMPV3"

El AP en caso de que lo tenga, que no lo sé, busca también que este desactivado el igmp proxy.

Dale al switch también un tiempo de reacción por si acaso, yo he visto en otros fabricantes como a veces puede tardar un par de minutos al principio hasta que tiene claros los puertos donde hay subscripciones y en los que no.

Otro punto que creo que ayudaría por lo menos para acotar si el problema fuese del switch o del AP, es que conectes al menos 2 equipos por cable, de esa forma puedes ver, si cuando uno pide el stream, se replica en los 3 puertos (2xPC + AP), o solo en 2 (1PC+AP), ya que en ese caso seguro que sería lo que tu dices, que el AP esta haciendo enviando Joins.

Saludos.
 
#6
Begepeich, lo he hecho tal como cuentas.
Firmware del switch actualizado a la ultima version desde el primer dia.
Al switch por cable tengo enchufados ademas del ap, 2 ordenadores, 1 nas, tv, y deco.
El ap con el firmware original no pone nada de igmp proxy ni snooping.
Con el Gargoyle tampoco, por lo que entiendo que esta todo desactivado.

Por ultimo en la configuracion del switch solo tengo activado la de igmp snooping lo demas quitado.
Al principio tenia marcado la de "Block Unknown MultiCast Address" pero haciendo pruebas lo quite porque parece que no hace nada.

Tengo pensado pasar otra vez al firmware original del AP para hacer mas pruebas y "ver las lucecitas" como actuaan.
 
#7
Anonimo dijo:
Begepeich, lo he hecho tal como cuentas.
Firmware del switch actualizado a la ultima version desde el primer dia.
Al switch por cable tengo enchufados ademas del ap, 2 ordenadores, 1 nas, tv, y deco.
El ap con el firmware original no pone nada de igmp proxy ni snooping.
Con el Gargoyle tampoco, por lo que entiendo que esta todo desactivado.

Por ultimo en la configuracion del switch solo tengo activado la de igmp snooping lo demas quitado.
Al principio tenia marcado la de "Block Unknown MultiCast Address" pero haciendo pruebas lo quite porque parece que no hace nada.

Tengo pensado pasar otra vez al firmware original del AP para hacer mas pruebas y "ver las lucecitas" como actuaan.

OK y gracias, este tipo aportes son los que nos ayudan luego a elegir lo que comprar y como configurarlo.

Un saludo
 
#8
Hola,

Estaba decidido a comprar este switch por el mismo problema que el OP, pero leyendo su experiencia me ha tirado un poco para atrás. Entiendo que el problema es que su AP con el firmware original no funciona bien porque sigue recibiendo tráfico multicast, pero poniéndole un firmware alternativo el filtrado va bien. Así que supongo que el IGMP snooping del switch sí va bien en realidad.

En mi caso tengo un E4200, y no sé si le pasará igual, de ahí mi preocupación (no quiero cambiarle el firmware original). Pero, buscando por Internet, me encuentro con un usuario que dice que su E4200 en modo puente (como lo tengo yo) es lo suficientemente listo como para filtrar todo el tráfico multicast de vídeo... Así que entiendo que incluso con un switch "normal" (al que el AP va conectado), no afectaría al Wi-Fi. Pero claro, tampoco sé si fiarme mucho.

Cuando me instalen la TV mini ya haré pruebas y comentaré los resultados, ya que veo que este AP es bastante popular por el foro jeje

Saludos.
 
#9
Soy el que empezo el hilo.
Despues de pruebas, parece que le switch funciona bien, lo que pasa es que el ap debe mandar alguna peticion del multicas y lo satura.
Con el firmware alternativo no pasa.
Los demas equpos conecatdado al switch no "parpadean" asi que no es cosa del Swicht.
Seguire haciendo pruebas.
 
#10
La mejor forma de probar un switch no es con un AP detrás.

La forma más correcta es conectando dos ordenadores directamente al switch, en uno de ellos poner Imagenio (con el VLC), y en el otro con un analizador tipo Wireshark, ver si llegan o no los paquetes multicast.

Por otro lado, la utilidad es bastante mayor que hacer funcionar el Wifi (que con cualquier firmware Linux se puede filtrar). Lo que se debe pretender es realmente, que si un ordenador no está viendo Imagenio, la LAN no se sature con tráfico que no sirve.

Si esto realmente funciona, yo al menos estaría muy interesado. Sustutuiría en mi habitación a un switch Asus del año catapún (Gigabit, eso sí) por el nuevo y, por el otro lado, en el Mikrotik desactivaría la funcionalidad de switch y en el puerto 2 conectaría directamente el switch con IGMP snooping.

Por último, esto me permitiría tener también Imagenio en el portátil, porque con ambos switches el filtrado del AP ya no haría falta, y si el portátil pide Imagenio, pues funcionaría (si se satura el Wifi me da igual porque realmente es lo que quiero, cerrar el VLC bastaría para que volviera a su estado normal). Lo que no quiero es una saturación permanente, pero ver Imagenio en el portátil, de vez en cuando puede apetecer (además, la banda a 5 Ghz a 450 Mbps, que es la que yo uso, aún es navegable aun con saturación).

Bueno, yo os estoy contando mi caso, pero evidentemente es interpolable a muchos de vosotros.
 
#11
Malosa dijo:
La mejor forma de probar un switch no es con un AP detrás.

La forma más correcta es conectando dos ordenadores directamente al switch, en uno de ellos poner Imagenio (con el VLC), y en el otro con un analizador tipo Wireshark, ver si llegan o no los paquetes multicast.

Por otro lado, la utilidad es bastante mayor que hacer funcionar el Wifi (que con cualquier firmware Linux se puede filtrar). Lo que se debe pretender es realmente, que si un ordenador no está viendo Imagenio, la LAN no se sature con tráfico que no sirve.

Si esto realmente funciona, yo al menos estaría muy interesado. Sustutuiría en mi habitación a un switch Asus del año catapún (Gigabit, eso sí) por el nuevo y, por el otro lado, en el Mikrotik desactivaría la funcionalidad de switch y en el puerto 2 conectaría directamente el switch con IGMP snooping.

Por último, esto me permitiría tener también Imagenio en el portátil, porque con ambos switches el filtrado del AP ya no haría falta, y si el portátil pide Imagenio, pues funcionaría (si se satura el Wifi me da igual porque realmente es lo que quiero, cerrar el VLC bastaría para que volviera a su estado normal). Lo que no quiero es una saturación permanente, pero ver Imagenio en el portátil, de vez en cuando puede apetecer (además, la banda a 5 Ghz a 450 Mbps, que es la que yo uso, aún es navegable aun con saturación).

Bueno, yo os estoy contando mi caso, pero evidentemente es interpolable a muchos de vosotros.
Malosa, soy el del gs108E, como puse tengo pinchado al switch varios aparatos: 2 pcs, deco, tv, nas, ap, router mikrotik.

Las pruebas que he hecho son con un pc viendo imagenio con vlc y las lucecitas del perto conde esta el otro pc (ni ninguna mas) parpadea.
EL switch traaja perfectamente el igmp snooping.

EL AP (wr1043nd) aun no se por que razon, con el firmware de origen si que se satura, pero con el gargoyle no. Creo que el firmware de origen confunde al switch y este se cree que esta pidiendo multicast y se lo manda, saturandolo.
En el gargoyle no he configurado nada de filtrado ni nada de eso, esta tal cual lo flasheas de origen y haciendolo funcionar como AP. Creo que el tema va a estar en que en el firmware de origen no se puede desactivar la conexion wan (y se deja como ip fija en una ip que no sea del rano que se usa y el puerto wan si usar) y en el gargoyle se puede poner como desactivada. Porque otra cosa no se que puede ser.

La configuracion que quieres poner tu es la que tengo yo ahora mismo.
Tengo la ONT y el Mikrotik en la caja de comunicaciones.
Del mikrotik sale un cable de red conectado al puerto 2, que va al salon donde tengo el switch y todo conectado a el.

Por otro lado, decirte que to tambien he probado a ver imagenio por wifi en el portatil y se satura el wifi, llegando incluso a tumbarlo si lo que se ve es un canal en HD.
Recomiendo que leas esto, referente al trafico multicast y wireless
http://wiki.mikrotik.com/wiki/Manual:Mu ... d_Wireless

Saludos.
 
#12
Anonimo dijo:
Hola,

Estaba decidido a comprar este switch por el mismo problema que el OP, pero leyendo su experiencia me ha tirado un poco para atrás. Entiendo que el problema es que su AP con el firmware original no funciona bien porque sigue recibiendo tráfico multicast, pero poniéndole un firmware alternativo el filtrado va bien. Así que supongo que el IGMP snooping del switch sí va bien en realidad.

En mi caso tengo un E4200, y no sé si le pasará igual, de ahí mi preocupación (no quiero cambiarle el firmware original). Pero, buscando por Internet, me encuentro con un usuario que dice que su E4200 en modo puente (como lo tengo yo) es lo suficientemente listo como para filtrar todo el tráfico multicast de vídeo... Así que entiendo que incluso con un switch "normal" (al que el AP va conectado), no afectaría al Wi-Fi. Pero claro, tampoco sé si fiarme mucho.

Cuando me instalen la TV mini ya haré pruebas y comentaré los resultados, ya que veo que este AP es bastante popular por el foro jeje

Saludos.
Buenas, soy yo de nuevo. Hoy me han instalado la TV mini (lo comento en el otro hilo de la nueva configuración) y como el Netgear GS108E no me llegará hasta finales de semana he estado haciendo pruebas con mi switch "normal", el E4200 y el Comtrend.

Lo que comentaba en el post anterior de que había un usuario que decía que a su E4200 no le afectaba el tráfico multicast... pues en mi caso va a ser que no: nada más poner en marcha un canal no dura ni un minuto el WiFi. Se satura y los clientes se desconectan. Bueno, es lo que ya me suponía, de ahí la compra del Netgear.

Así que mientras me llega el nuevo switch, he probado a poner el Comtrend como AP y, marcándole una opción, tachán, Imagenio por WiFi sin problemas, sin saturaciones ni nada. He probado simultáneamente un iPhone, un iPad y un portátil (todos con VLC) y todo perfecto, incluso con canales HD. Bueno, el iPad se pixelaba un poco con los canales HD, pero lo achaco a la potencia del dispositivo, porque con el iPhone iba fino, fino.

La opción en cuestión está en Wireless - Basic y se llama "Enable Wireless Multicast Forwarding (WMF)":


Buscando información sobre la opción, encontré un post de un usuario de este mismo foro, pero con el firmware Tomato en un router neutro.

El caso es que teniendo esa opción desactivada en el Comtrend, no es posible ver Imagenio por WiFi: se congela la imagen prácticamente nada más ponerla.

Todo esto viene a cuento porque intuyo que el nuevo switch y su IGMP Snooping no va a impedir que se sature igualmente el WiFi del E4200 si un cliente WiFi se pone a ver Imagenio. Ojalá me equivoque, pero...
Y si al final me animo a flashear el E4200 con Tomato, he estado viendo en el simulador de Victek que precisamente esa opción ha desaparecido (en el post que he enlazado hay una captura de dónde estaba).

De todas formas, estando Movistar Go (lo tengo pendiente de activación) estoy cubierto con móviles y tabletas, pero quedaría poder verse en el portátil y demás dispositivos inalámbricos no compatibles con Go. Conociéndome, ya sólo me quedaría esa espinita clavada para que todo funcionase a la perfección :)

Lamento el tocho y un saludo!
 
#13
Bueno, no sé si no he entendido bien lo que quieres decir.

Pero el IGMP Snooping lo que te haría es evitar el envío de trafico multicast pero el "no deseado", es decir, que el problema que normalmente se tiene es que, con que un PC por Cable se ponga a ver imagenio ya te lo reenvía por el Wifi llenandolo con un trafico que ningún cliente wifi ha pedido, y con mas de un canal ya te puedes imaginar la que se lia, ya que se reenvían todos.

Ahora si es un cliente Wifi el que lo pide, entonces se envíará ese por el wifi, eso el snooping no lo va a cortar, aunque si otros canales que se estén viendo por cable. Cada puerto obtiene solo lo que ha pedido, esa es la ventaja.
 
#14
Sí, sí, eso lo entiendo. A lo que me refería es que aún a pesar de contar con IGMP snooping en el switch, dudo que vaya tan bien como el Comtrend con esa opción.

Mis sospechas vienen por lo siguiente: si el E4200 se satura con un cliente cableado viendo un canal, con IGMP snooping en el switch y un cliente por WiFi es como si recibiera lo mismos paquetes multicast ¿no? Pues se saturaría igualmente. Tal vez me explique mejor con un esquema:

Switch "normal" -> PC viendo un canal Imagenio
'-> AP se satura al recibir los paquetes multicast (*)

Switch IGMP snooping -> PC viendo un canal Imagenio
'-> AP no se satura porque no recibe los paquetes multicast

Switch IGMP snooping -> Cliente WiFi viendo un canal Imagenio

¿En este último caso no sería a efectos prácticos igual que (*)?
A lo mejor me equivoco, no sé.

Gracias de nuevo.
 
#15
El tema esta en como se conectan los cacharros.
Si al ap no le conectas nada que pida TV y a su vez el ap esta conectado a un switch que haga snooping, la wifi no se saturara porque el switch no manda trafico multicast al AP.

El tema esta claro por ese lado.

Ahora cuando usamos el ap para ver imagenio
-si se hace con un equipo conectado por cable al ap pueden pasar 2 cosas:
---que el ap no haga snooping y te mande trafico a todas las bocas (ya sea cable o wifi) o
---que le ap haga snooping y solo mande el trafico a la boca que pide la TV por lo que la wifi no satura.

Ahora cuando es la wifi la que pide la TV...
Eso ya es un problema de protocolos de transferencia wifi.
Los paquetes multicast por su "forma" hacen que el wifi baje su velocidad de transmision para asegurarse que esos paquetes llegaran a sus destinos. Esto ya depende del chip wifi y del firmware que tenga el AP.
En tu caso parece que poniendo lo de "Enable Wireless Multicast Forwarding (WMF)" el AP "entiende" como tiene que tratar esos paquetes para no saturar y que lleguen bien.
por lo tanto parece ser que el ver la TVmini por wifi depende del AP una vez hemos resuelto el tema de que solo pase el trafico multicast cuando nosotros queramos.
 
#16
Sí, es verdad que un cliente Wifi saturaría la red. Pues no instales la lista de canales del VLC en los portátiles y ya está. No acabo de ver el problema. ¿Cuántas personas sois en casa? Con que se lo digas que no lo usen es suficiente.
 
#17
Está claro, gracias. Estoy seguro de que el E4200 (con el firmware de fábrica) no hace snooping de ningún tipo, así que si quiero disfrutar de Imagenio por WiFi como con el Comtrend, tocará ponerle algún firmware alternativo, pero claro, no sé cuál le irá bien para este asunto... (y que sea estable en todo lo demás, claro jeje)
 
#18
Malosa dijo:
Sí, es verdad que un cliente Wifi saturaría la red. Pues no instales la lista de canales del VLC en los portátiles y ya está. No acabo de ver el problema. ¿Cuántas personas sois en casa? Con que se lo digas que no lo usen es suficiente.
No, ese realmente no es el problema. "Simplemente" busco que todo funcione perfecto en todos los dispositivos, por satisfacción de haberlo logrado (y disfrutarlo posteriormente). No sé si se me entiende ;)
 
#19
Por cierto, Malosa, unos posts más atrás comentabas que estabas muy interesado en el tema, para que entre otras cosas, pudieras disfrutar de Imagenio en tu portátil... Como creo que también tienes un E4200, entonces estamos en el mismo barco ¿no? :) A ver si lo conseguimos pues.
 
#20
OK ya entiendo lo que querías explicar.

Lo que tu dices también depende del AP y opciones para optimizar cosas relativas al multicast y que no tienen nada que ver efectivamente con solo el bloqueo/nobloqueo del trafico, si no mas bien con esos problemas que detectas, y que son normalmente por la propia configuración del multicast en el Wifi.

Es decir, que una vez se decide a enviar un flujo multicast pueda cursarse mejor o peor y afectando lo menos posible a otros clientes conectados.

Para ese caso busca en la configuración, opciones típicas como "multicast rate", también "basic rate",.. etc. (opciónes que el comtrend suelen estar en Auto o Default, a saber que decide xD)

Busca un poco por tu E4200 para ver como tienes opciones de este tipo.

El multicast forwarding que dices suele ser mas bien relativo a que un cliente Wifi puede enviar multicast para que el resto lo reciba (al ser reenviado luego por el AP), no sé si en el Comtrend puede afectar a algo mas por tocarlo.

Un saludo
 
Arriba