HG8240H desbloqueo firmware

Buenas foro! mi primer mensaje,

Llevo algunos dias investigando ya que me gustaría usar los diferentes puertos de la ONT Huawei HG8240H que proporciona O2. Hasta ahora he podido acceder al router desconectando el cable de Fibra y accedido a la web interface interna y he visto los contenidos del mismo hasta donde me dejan ver (ONT ID, Info del software, diferentes parametros de VoIP...)

Tambien he descargado el archivo de configuración y desencriptado los contenidos del mismo con el programa aescrypt2_huawei, aunque he visto que el userlevel para el usuario con el que entro (telecomadmin) es ya 0, es decir, administrador, por lo que intuyo que el firmware del router ya viene bloqueado para no poder acceder a ciertas partes de la configuración.

Por lo que he leido en el foro, mis opciones son hacer downgrade a una version de firmware anterior, o supongo que actualizando a una version de firmware de huawei oficial y copiando toda la configuración necesaria también funcionaría. Quería preguntar si alguien lo ha probado con éxito y se puede.
 
Última edición:
Yo no optaría por esa vía. Deja la ONT como está, que hace bien su trabajo, y mete un buen router neutro detrás, en lugar del que te da O2.
Con eso vas a poder exprimir la conexión, mucho más que reusando la ONT como router.

Saludos!
 
Quizas lo haga por trastear , mira haber si tiene telnet o ssh habilitados y entras por ahi , si no pues sigue el consejo de pokoyo , por puerto serie tambien se pueden hacer cosillas ,yo en fibra ni idea pero en docsis e pegado algunos tiros , un saludo
 
Quizas lo haga por trastear , mira haber si tiene telnet o ssh habilitados y entras por ahi , si no pues sigue el consejo de pokoyo , por puerto serie tambien se pueden hacer cosillas ,yo en fibra ni idea pero en docsis e pegado algunos tiros , un saludo
Claro, si lo hace por esa razón, te lo compro. Todo lo que sea trastear y aprender, bien está. Pero por sacarle funcionaliad de router a una ONT... no lo veo. Me quedo con la opción del router neutro de calle.

Saludos!
 
Eso pense como tenemos tanto tiempo ahora con la cuarentena habra gente k quiera trastear , aumque sin herramientas como un programador o un simple ftdi mejor no tocar , yo tengo un usb jtag nt para los puma 5 les cambio el firm para ponerlos online
 
Eso pense como tenemos tanto tiempo ahora con la cuarentena habra gente k quiera trastear , aumque sin herramientas como un programador o un simple ftdi mejor no tocar , yo tengo un usb jtag nt para los puma 5 les cambio el firm para ponerlos online
De más de un brick me salvó a mi este :censored:

IMG_0611.jpg

Saludos!
 
Ya viene bien tener uno , lo malo es que ahora todos los router traen nandflash y el bootloader del puerto serie bloqueado , cada vez mas dificil jeje , los puma 5 traen spiflash y son muy faciles de meter mano , para fibra igual traen nand , seria posible clonar un router u ont dado de alta y que funcionara en otro punto de españa o en la misma ciudad ? estuve investigando pero no hay nada de info pero creo k no ya k activan desde la central , yo tengo fibra en casa pero de baja y por el cable no viene nada esta muerto , no quiero piratear nada jaja es solo trastear , seria leer la nad o la spiflash y meterselo a otro igual o compatible
 
En verdad no te hace falta clonar nada en fibra. El tráfico es multicast, quiere decir que a todas las ONT’s llega todo el tráfico, y ellas saben con qué quedarse. Pero claro, tu ONT autentica con su homologa OLT en central, y sospecho que como parte de IDONT (el codigo que te identifica como cliente), va información de dónde está pinchada esa ONT (en qué puerto/CTO/Sector etc), tal que no te puedas llevar la ONT a casa del vecino y pincharla para funcionar allí (sería la caña, para llevarte tu fibra contigo, por ejemplo, a una segunda residencia).

DOCSIS tiene miga, pero estoy seguro que GPON y sus cabeceras tampoco se quedan atrás. Y estas cosas las tendrán ya más que repensadas :p

No obstante, me encanta que la gente trastee y se haga estas preguntas. Así se aprende!

Saludos!
 
Gracias por las respuestas. Lo hago por trastear y aprender pero tambien. Puse un router Wifi 5GHZ flasheado con OpenWRT pero el problema es que no es Gigabit y está haciendo de cuello de botella de mis otros dispositivos de cable (Television, Raspberry, Nas) y por lo cual, poder usar las salidas gigabit que tiene la ONT me dejaría un setup casi perfecto.

Volviendo al tema, esta ONT en su firmware original de Fabrica es un router/gateway, lo que pasa esque al no tener WiFi en españa se configuran como bridge y ponen un router detrás. Hay algunas webs en rusia con firmwares para este modelo. Y teniendo toda la configuración guardada en backup y el IDONT y teniendo el firmware adecuado debería funcionar.

Y otra opcion es comprar el HGU, que visto lo visto creo que es lo que voy a hacer...
 
Quizas lo haga por trastear , mira haber si tiene telnet o ssh habilitados y entras por ahi , si no pues sigue el consejo de pokoyo , por puerto serie tambien se pueden hacer cosillas ,yo en fibra ni idea pero en docsis e pegado algunos tiros , un saludo

Creo que editando y subiendo el archivo de configuración ahí se puede activar ssh o telnet, y a traves de ssh y telnet hay comandos que no salen por la web, es una opcion que tengo previsto probar.

Saludos,
 
Buenos dias , asi tan facil ? con un editor hex o con notepad por ejemplo ? puede que se corrompa el archivo config cuando lo edites , en docsis antes se podia editar el archivo config y podias subir la velocidad de internet , ahora cuando lo editas te pide la shared secret , que solo lo saben ellos , pues adelante haz tus pruebas ,mi consejo es que los equipos que tienes que son de la operadora no los toques , compra en internet de segunda mano , un saludo
 
Buenos dias , asi tan facil ? con un editor hex o con notepad por ejemplo ? puede que se corrompa el archivo config cuando lo edites , en docsis antes se podia editar el archivo config y podias subir la velocidad de internet , ahora cuando lo editas te pide la shared secret , que solo lo saben ellos , pues adelante haz tus pruebas ,mi consejo es que los equipos que tienes que son de la operadora no los toques , compra en internet de segunda mano , un saludo

El shared secret va con algoritmo AES y Huawei siempre pone ls misma clave a todos los dispositivos. Hay post en este mismo foro que hablan de haberlo hecho.

Igual que tocamos configuración de router's tampoco veo tanto peligro en tocar la configuración de onts. Ahora lo de flashear un firmware no oficial ya lo veo más complicado.

Al final por este y otros motivos (enchufes, cuello de botella y mas cosas) voy a cambiar este setup por el HGU
 
¿Porqué no le das la oportunidad a un router neutro? Tienes una de las pocas ONT's que siguen teniendo puerto RJ11 para el teléfono, y por ende puedes colocar detrás un router neutro que te de internet. Quizá te cueste algo más que el HGU, pero desde luego vas a obtener una conexión bastante más estable.

Saludos!
 
Ya tengo un router neutro flasheado con openwrt.

No es la respuesta que esperaba recibir de este foro.

Saludos
 
¿Porqué no le das la oportunidad a un router neutro? Tienes una de las pocas ONT's que siguen teniendo puerto RJ11 para el teléfono, y por ende puedes colocar detrás un router neutro que te de internet. Quizá te cueste algo más que el HGU, pero desde luego vas a obtener una conexión bastante más estable.

Saludos!

Refloto este hilo porque me encuentro en una situación parecida. El tema es que el router neutro que tengo es un Xiaomi ax9000, y no tiene soporte de VLAN. Por tanto, no admite la salida del HG8240H (Orange).

Una de las soluciones que hay al asunto es poner la ONT en modo router, y así dejar la salida en modo pppOE. Pero el firm que tengo (la ONT era de Lowi) no lo permite (tendría que flashearlo y no sé con qué imagen). Además, respeto mucho tu opinión de que mejor no hacerlo. Lo que nos lleva a la siguiente solución porsible, poner un switch gestionable en medio y "aplanar" la VLAN (entrar en el Xiaomi por SSH y editar la configuración de red parece que no es posible en este modelo).

Tengo tanto un Mikrotik HEx como un Netgear GS108E para poder hacerlo, pero no encuentro el tutorial que vi en su día. Si pudieras echarme una manita... :)

Gracias de antebrazo.

PD) Tanto TV como la telefonía fija me importan más bien poco. No uso el fijo, y para ver OrangeTV tengo la app si lo necesito.
 
No te sale más a cuenta poner el hEX como router, y ese chisme que has comprado como AP?

Saludos!
 
No te sale más a cuenta poner el hEX como router, y ese chisme que has comprado como AP?

Saludos!

No, por que aparte de las limitaciones de potencia del HEX, tengo un NAS para el que me vendría de perlas el puerto 2.5G del Xiaomi. Y en modo AP creo que el tema mesh ya no lo gestiona, y tengo dos satélites.

Imagino que el mikrotik es perfectamente capaz de deshacer la VLAN y "transmitirla" a un puerto de salida en modo WAN PPPoe. Soy muy novatillo en redes, pero imagino que será factible y relativamente sencillo.
 
De todas formas, ya te digo que soy bastante limitadito en cuanto a redes, y quizás esté equivocado y lo que tu propones sea la mejor solución. Sabiendo de los mimbres de que dispongo, dime que opción tomarías tu. Soy todo orejas. :)
 
Yo montaría el hEX como router, desde luego le da sopas con onda al Xiaomi en esa tarea, especialmente si me dices que no soporta VLANs.
A menos que tengas una conexión de más de un 1Gbps o que tanto NAS como router tengan puertos a 2,5 y los quieras conectar directos, poco más partido le vas a sacar. No obstante, si quieres la configuración mínima que tendrías que meter en un hEX para deshacer una vlan y meterlo con calzador entre ONT y chisme con antenas, es esta:
Código:
/interface bridge
add name=bridge
/interface bridge port
add bridge=bridge interface=ether1
add bridge=bridge interface=ether2 pvid=832
/interface bridge vlan
add bridge=bridge tagged=ether1 vlan-ids=832
/interface bridge
set 0 vlan-filtering=yes

Conectas ether1 a la ONT y ether2 al puerto WAN del chisme en cuestión, y andando.

Saludos!
 
Gracias! Le daré una vuelta esta noche.

En cualquier caso, si pusiera el Hex detrás de la ONT... ¿se tragaría sin más la VLAN y ya podría poner detrás el Xiaomi en modo AP? Siempre que consiguiese que funcionase también el mesh, que parece ser que hay gente que lo ha hecho...
 
Arriba