FTTH con tomato y problemas acceso al router

Hola Chicos,

Os cuento como lo tengo montado
- Tengo FTTH con movistar y ONT huawei. He cambiado el router neutro que venia por un router (asus rt-n16) con tomato.
- He seguido el tutorial que nos hizo el compañero krasny y funciona perfectamente.
- A este router con tomato se puede acceder, bien desde dentro de la red (especificando el puerto en el router) o bien desde fuera (especificando tambien un puerto distinto o igual al anterior)
- Dentro de la red tengo un servidor web, servidor vnc y un deco de satelite con interface web.
- En el router tengo un dominio ddns configurado y funcionando correctamente.

Problema:
- Cuando intento acceder desde fuera al router no soy capaz, siempre me da un timeout.
- Esto no me sucedia con la misma configuración de acceso al router antes que tenia adsl jazztel y el router en bringe

Pruebas:
- Mi servidor ddns si que funciona correctamente, ya que si accedo al dominio por el puerto 80 entro al servidor web de casa
- el vnc por su puerto accede tambien perfectamente
- al interface web del deco tambien accedo perfectamente desde fuera
- He probado a quitar el nat del puerto 80 del servidor de casa y configurar el router con el puerto 80 hacia el exterior: NO FUNCIONA
- he probado a configurar el acceso desde fuera en HTTPS y HTTP y con ninguno de los dos funciona


Descarto problemas con el tomato, ya que he probado esto con las ultimas 3 versiones publicadas.
Con estas versiones tengo amigos que tienen adsl y conectado en modo bridge y les funciona bien.

Tengo sospechas de que el problema está en la configuración necesaria para que el router funcione con FTTH.

Alguno mas teneis tomato con FTTH y podeis probar esto???
a alguien se le ocurre algo???

un saludo
-DAVIZINHO-
 
No tengo FTTH y no lo puedo probar.

iptables -I INPUT -p tcp --dport 9091 -j ACCEPT

Donde el puerto 9091 el de para acceder desde fuera.

Ya sabes que haciendo esto te saltas el firewal...prueba a ver si así va :)
 
Otra solución sería crear una VPN y entras desde ahí con la IP local...es una buena solución si entras desde fuera con tu portátil etc, pero si es desde cualquier sitio que pilles no porque tienes que estar con el programa y con los certificados.
 
Lo pruebo mañana que ahora no estoy en casa.:-(
Lo de la con esta descartado porque necesito acceder desde fuera para usar el wol con un móvil :)
EDITO:
probado y no funciona :-(
 
Prueba este:

iptables -t filter -A INPUT -p tcp --dport 80 -j ACCEPT

Donde 80 es el puerto, a parte de hacer esto, habilita en el menú el HTTP remoto en el puerto 80 (o el que sea).
 
probado y nada :-(
mira que es raro que si que pueda acceder a lo que está en la red interna desde fuera y no al propio router
 
SOLUCIONADO,
gracias a krasny hemos estado probando cosas y al final ha resultado ser LA DMZ
resulta que tenia la dmz apuntando hacia la ip 23 (una consola) y todas las peticiones de acceso remoto al router que entraban por el puerto 6969 se iban hacia la dmz en lugar de quedarse en el propio router.

Ha sido desactivar la DMZ y funcionar perfectamente el acceso remoto. raro raro raro

un saludo
 
Me alegro ^^

Hombre, desactivar la DMZ y abrir el puerto al router, que por defecto no lo abre. Estoy seguro que cambiando el orden de la prioridad en el iptables se podría hacer manteniendo el dmz, pero sin duda es más rápido que abras los puertos al otro equipo.
 
ahora mismo estoy hablando con victek porque le gustaria poder reproducir el error.
Otro amigo tambien tiene este fallo, mañana probará a quitar la dmz a ver si lo soluciona (en su caso con un rt-n16)

yo pienso que al activar la dmz lo primerito en la configuración y despues todo el mapeo de puertos y demas, lo mismo la iptables se hace la picha un lio

ya os diré que me va contando victek
 
Arriba