[CONSEGUIDO] Configurar Mikrotik y fibra indirecta de Jazzte

#1
Ya que ha costado lo que ha costado explicaré como lo he conseguido por si alguien está en la misma situación que yo
Este es el esquema de conexión:
ONT ----- eth1 Mikrotik (para internet)
eth2 Mikrotik ----- WAN ZTE
Tenemos que conectar el cable desde la ONT al el eth1 del Mikrotik que es por donde vamos a sacar nuestra conexión a internet
Del eth2 del Mikrotik (valdría cualquiera del 2 al 5 si ponemos el 3, 4 y 5 como esclavos del 2) al puerto WAN del ZTE, que es por donde vamos a sacar la telefonía.
Importante clonar la MAC del ZTE al eth1 del Mikrotik, ya que es necesario para validarse a internet, si no clonáis la MAC no va a dar IP
El trafico en este tipo de fibra lo pasan por la VLAN20
Este es el fichero de configuración del Mikrotik que tengo yo ahora

**********************************************************************************************************************************

/interface ethernet
set [ find default-name=ether1 ] mac-address=XX:XX:XX:XX:XX:XX name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=ether5-slave-local
/interface vlan
add interface=ether1-gateway l2mtu=1576 name=vlan20 vlan-id=20
add interface=ether2-master-local l2mtu=1576 name=vlan20_zte vlan-id=20
/ip pool
add name=dhcp ranges=192.168.1.100-192.168.1.120
add name=vpn ranges=192.168.3.100-192.168.3.120
add name=voip ranges=192.168.2.100
/ip dhcp-server
add address-pool=dhcp disabled=no interface=ether2-master-local lease-time=3d name=DHCP_LAN
add address-pool=voip disabled=no interface=vlan20_zte lease-time=3d name=DHCP_ZTE
/ppp profile
set *FFFFFFFE dns-server=192.168.3.250 local-address=192.168.3.250 remote-address=vpn
/interface pptp-server server
set authentication=mschap2 enabled=yes
/ip address
add address=192.168.100.10/24 comment="Red virtual de la interfaz WAN del Mikrotik" interface=ether1-gateway network=192.168.100.0
add address=192.168.2.1/24 comment="Red virtual del ZTE" interface=vlan20_zte network=192.168.2.0
add address=192.168.1.1/24 comment="Red LAN del Mikrotik" interface=ether2-master-local network=192.168.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=vlan20 use-peer-ntp=no
/ip dhcp-server network
add address=192.168.1.0/24 comment="Red LAN del Mikrotik" dns-server=192.168.1.1 gateway=192.168.1.1
add address=192.168.2.0/24 comment="Red virtual del ZTE" dns-server=192.168.2.1 gateway=192.168.2.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.1.1 name=router
add address=192.168.2.1 name=routervlan
add address=192.168.2.100 name=Router_ZTE
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add chain=input disabled=yes dst-port=23,80 in-interface=vlan20 protocol=tcp
add chain=input dst-port=8291 in-interface=vlan20 protocol=tcp
add chain=input dst-port=1723 in-interface=vlan20 protocol=tcp
add action=drop chain=input comment="default configuration" in-interface=vlan20
add chain=forward comment="default configuration" connection-state=established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" connection-state=invalid
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" out-interface=vlan20
add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1-gateway
add action=masquerade chain=srcnat disabled=yes out-interface=vlan20_zte
add action=dst-nat chain=dstnat disabled=yes dst-port=80 in-interface=vlan20 protocol=tcp to-addresses=192.168.1.125
add action=dst-nat chain=dstnat disabled=yes dst-port=21 in-interface=vlan20 protocol=tcp to-addresses=192.168.1.125
/ip route
add distance=255 gateway=255.255.255.255
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=vlan20 type=external
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=RouterOS
/system ntp client
set enabled=yes primary-ntp=163.117.202.33 secondary-ntp=89.248.104.162
/system routerboard settings
set cpu-frequency=533MHz


********************************************************************************************************

El el ZTE no hay que desmarcar la VLAN ni el NAT, si no no funciona
A la LAN del ZTE le he puesto la IP 192.168.2.200
Lo único que me queda es ver la LAN del ZTE desde el Mikrotik, desde el ZTE al Mikrotik llego tanto a la LAN como a internet, pero no se como hacer que el mikrotik vea la parte LAN del ZTE
Saludos
 
#3
Re: Ayuda para configurar Mikrotik y fibra indirecta de Jazz

Gracias por la respuesta pero he modificado ese fichero cambiando la VLAN 1074 por la VLAN 20 que es la que tiene el nuevo router que me han puesto pero por algún motive sigue sin funcionar. Esto es lo que le meto en la configuración:

/interface ethernet
set 0 name=ether1-gateway
set 1 name=ether2-master-local
set 2 master-port=ether2-master-local name=ether3-slave-local
set 3 master-port=ether2-master-local name=ether4-slave-local
set 4 master-port=ether2-master-local name=ether5-slave-local
/interface vlan
add interface=ether1-gateway name=vlan20 vlan-id=20
/ip pool
add name=dhcp ranges=192.168.1.2-192.168.1.25
add name=vpn ranges=192.168.3.10-192.168.3.20
/ip dhcp-server
add address-pool=dhcp disabled=no interface=ether2-master-local name=dhcp1
/ppp profile
set 1 dns-server=192.168.3.250 local-address=192.168.3.250 remote-address=vpn
/interface pptp-server server
set authentication=mschap2 enabled=yes
/ip address
add address=192.168.1.1/24 interface=ether2-master-local
add address=192.168.100.10/24 interface=ether1-gateway
/ip dhcp-client
add add-default-route=yes disabled=no interface=vlan20 use-peer-ntp=no
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=192.168.1.1 gateway=192.168.1.1 \
    netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.1.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add chain=input disabled=yes dst-port=23,80 in-interface=vlan20 protocol=\
    tcp
add chain=input dst-port=8291 in-interface=vlan20 protocol=tcp
add chain=input dst-port=1723 in-interface=vlan20 protocol=tcp
add action=drop chain=input comment="default configuration" in-interface=\
    vlan20
add chain=forward comment="default configuration" connection-state=\
    established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" \
    connection-state=invalid
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=vlan20
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=ether1-gateway
add action=dst-nat chain=dstnat disabled=yes dst-port=80 in-interface=\
    vlan20 protocol=tcp to-addresses=192.168.1.25
add action=dst-nat chain=dstnat disabled=yes dst-port=21 in-interface=\
    vlan20 protocol=tcp to-addresses=192.168.1.25
/ip route
add distance=255 gateway=255.255.255.255
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=ether2-master-local type=internal
add interface=vlan20 type=external
/system clock
set time-zone-name=Europe/Madrid
/system ntp client
set enabled=yes primary-ntp=163.117.202.33 secondary-ntp=\
    89.248.104.162



Y este es el pantallazo de la configuracion WAN del router de jazztel
 
#5
Nada, no tengo ni idea. Si pudiera probar....

Se me ocurre que o bien es otra Vlan, o que en la configuración del mikrotik te falta o sobra algo como que el vlan es tagged o untagged. Pero ni idea.

Podrías mirar si en dhcp Client te está dando la IP externa y está conectando. Esa es la manera si está bien configurado el enlace.

Si estuvieras conectado y no navegas, debe ser algo en firewall o de dns o no se.

Un saludo.
 
#6
Re: Ayuda para configurar Mikrotik y fibra indirecta de Jazz

Voy a mirar eso que  comentas a ver, pero tiene que ser la VLAN20 porque es la que hay configurada en el router que ponen

Otra cosa es lo de tagged o untagged. Voy a mirar por ahí

Si a alguien se le ocurre otra cosa se agradece

Saludos
 
#7
Nada. Sigo sin conseguirlo.
Con esa configuración cuando hago un ping a la dirección de la ONT (192.168.100.1) me responde pero cuando lo hago cuando estoy conectado desde el router de jazztel no llega a esa dirección
No se como enruta el tráfico del router a la ONT, pero creo que es un problema de enrutamiento. El tema es que aunque si control la parte de sistemas no tanto la de redes, y me pierdo un poco
A ver si alguien me puede echar un cable

Gracias
 
#11
Re:

rafa16277 dijo:
No me puedo creer que nadie pueda resolver esto. Una ayuda please

Gracias
Hola de nuevo Rafa16277,

Probemos con lo siguiente que no entiendo que hace ahí...

Elimina el direccionamiento 192.168.100.10/24. Me refiero a esta línea.

add address=192.168.100.10/24 interface=ether1-gateway

En DHCP Client no hace falta que chequees la opción de DNS ni de NTP, pero revisa en Status que esté 'bound' y que te ha dado una IP externa y las IPs de los DNS del proveedor. 

Debería funcionarte. Si no juega con los parámetros de Default Route y Distancia con los valores yes y no y 0 y 1.

Ten en cuenta que a veces requiere de reinicio tanto del ONT como del  Mikrotik, pues si hubieras obtenido ya una IP por alguna razón, el DCHP del proveedor no te va a dar otra IP. De todas formas, insisto, que con los dos puntos que te he comentado, sobretodo el de la eliminación del direccionamiento de red, debería funcionarte.

Otra cosa aparte, te aconsejo que desactives UPNP, o bien por lo menos quites la parte de UPNP de la interface VLAN 20 type external. Aunque yo desactivaría UPNP al 100%.

A ver si así.

Suerte!
 
#13
Nada, sigo igual. He probado lo que dice Monsam pero sigue sin darme IP externa.

La duda es porque tengo que quitar el direccionamiento de 192.168.100.10/24 cuando la IP de la ONT es la 192.168.100.1

Saludos
 
#14
Re: Ayuda para configurar Mikrotik y fibra indirecta de Jazz

Buenas,

Esa IP solo se utiliza para acceder a la ONT desde la red local para configurarla, nada más. Cuando está conectada al router, la ONT hace de bridge (puente), y por tanto esa subred es como si no existiera. El router espera una conexión WAN de tipo IPoE (DHCP) sobre la VLAN 20/0. Si no te funciona, es posible que tengas que clonar la MAC del router de Jazztel, ya que probablemente la usan como autentificación.

Por cierto, lo que tú tienes es fibra indirecta de Jazztel a través del servicio mayorista NEBA de Telefónica. Movistar y Telefónica son la misma compañía, pero una da servicios a clientes finales y la otra da servicios mayoristas a otras operadoras, regulados por la CNMC (Comisión Nacional de Mercados y Competencia).

Saludos
 
#15
Re: Ayuda para configurar Mikrotik y fibra indirecta de Jazz

Ok, gracias por lo de la subred. Aclarado. Lo otro la verdad es que no lo he entendido muy bien. Ya se que lo que tengo es fibra indirecta a través de Movistar o Telefónica
Alguna sugerencia de porque no me da ip externa en el Mikrotik?
Saludos
 
#16
Re: Ayuda para configurar Mikrotik y fibra indirecta de Jazz

Mi aclaración es porque al principio del hilo dices "tengo fibra indirecta de Movistar", lo cual obviamente no es correcto, ya que tu operadora es Jazztel. Como indico más arriba (he editado el post), tendrás que clonar la MAC del router de Jazztel, ya que seguramente la usarán para la autentificación.

Saludos
 
#20
Re: Ayuda para configurar Mikrotik y fibra indirecta de Jazz

Con los cablemodems de ONO, y en general cuando la conexión WAN es IPoE (alias DHCP o MER), p.ej. en el ADSL de Vodafone, hay que clonar la MAC por narices.

Saludos
 
Arriba