Configurar router Asus RT-AC87U para Vodafone FTTH

#41
Hola,

El pasado miércoles me pusieron la fibra de vodafone desde jazztel.
Hoy he conseguido configurar el teléfono ip que tengo, un gigaset C590IP, con la cuenta de vodafone, algo que no conseguí hacer con jazztel. También me ha funcionado con el Phonerlite.
La verdad es que ha sido más sencillo de lo que pensaba.

Phonerlite:
Servidor
Proxy/Registrar: IP_del_SIP_Primay Outbond_Proxy:5095
Domain/Realm: ims.vodafone.es

Usuario
Nombre de Usuario: +34912345678
Contraseña: ABCD12
Nombre de autenticación: 34912345678@ims.vodafone.es
Número de telefono: +34912345678

En el gigaset C590IP:
Nombre de autenticación: 34912345678@ims.vodafone.es
Contraseña: ABCD12
Nombre Usuario: +34912345678
Dominio: ims.vodafone.es
Dirección IP del servidor proxy: IP_del_SIP_Primay Outbond_Proxy
Puerto del servidor proxy: 5095
Servidor de registro: IP_del_SIP_Primay Outbond_Proxy
Puerto del servidor de registro: 5095
Tiempo de refresco del registro: 3600 (es el dato que viene en el router)

Y guardar.

Como codecs, poner el G.711aLaw y el G.729 en ese orden. (el mismo que en el router)


Queda claro que tenéis que poner vuestro número de teléfono, IP y contraseña para que os funcione.

Con todo esto os debería funcionar.
Primero probar con el phonerlite y si lo conseguís, trasladar los datos a vuestro teléfono o dispositivo ATA.

El siguiente paso será ponerlo en una raspbx para poder tener en casa el fijo en todos los móviles y en la calle poder tener también el fijo en el móvil conectando a través de una VPN.

Ahora ya sólo queda poner el router de vodafone en una linda caja. :D

Saludos
 
#42
xipher,

Sobre lo de utilizar el router de vodafone como dispositivo ATA, imagino que será posible.
Yo lo tenía así en jazztel, el asus como router, y el router de jazztel sólo servía como ATA para el teléfono.
Para hacerlo se tenían que eliminar todas las WANs, reglas, etc. del router y conectar un puerto del switch del asus al puerto wan del router de jazztel.
Creo que con el de vodafone será igual.

Saludos
 
#43
Me interesa muchísimo este hilo...
Queréis decir q habéis conseguido deshaceros 100% del router de Vodafone y mantener el fijo??? Eso tengo q conseguirlo yo.

Porzino, la ip del sip primary, de donde te la has sacado?? Interceptando datos con wireshark o como?? Si podrías hacer una guía o pequeño manual de los pasos que has dado te lo agradecería muchísimo!!!

Salu2
Chavo
 
#44
Eso es chavo. Nada de router de vodafone.
Sólo ONT de vodafone, router asus y teléfono gigaset.

El dato de la IP lo obtienes del router de vodafone.
Una vez obtienes la contraseña de administrador del router, entras en el apartado phone->phone settings y verás la IP del dato \"SIP Primary Outbound Proxy\". Ese es el que has de utilizar.

Los datos de usuario y contraseña, tanto del router como de la telefonía los obtienes interceptando datos.
En mi caso no ha hecho falta ya que el instalador al bajar a la calle se dejo la libreta con usuario/contraseña del panel con la orden de trabajo de vodafone y a la noche entré y pude ver todos los datos de mi conexión, tanto de ont, como de router, telefonía, etc., así que me he evitado el paso de interceptar datos.

En resumen, interceptando datos obtienes la contraseña del router para el usuario admin, el usuario y contraseña para la conexión PPoE del router, el usuario y contraseña de la telefonía.
Con los datos de administrador del router entras en él, vas al apartado Phone->Phone Settings y anotas el \"SIP Primary Outbound Proxy\" y el puerto, que debe ser 5095.
Con todo eso ya puedes configurar tu teléfono IP o tu dispositivo ATA.

Saludos
 
#45
porzino, ya he conseguido mi clave de admin del router!!!
He entrado a la config como admin para obtener los datos de voip y demás, pero no he conseguido que me registre en el phonerlite, ni tampoco he conseguido obtener conexion en el asus ac68u.

En el phonerlite he puetso los datos q has dicho tu, con el SIP Primary Outbound Proxy, pero me surge la duda, de q dato meter como contraseña, ya que en el router aparece una morcilla de letras y caracteres en el campo contraseña de FXS 1 y tambien FXS 2, y no me registra, tu podrías poner algun pantallazo tapando parte de tus datos o algo???  Hasta q no me registre esto no puedo prescindir de ese router, si hace falta pillaré un ata cisco o tu mismo teléfono ip.

Y en cuanto a configurar internet con el asus, he puesto como conexion PPoE con usuario y contraseña que he obtenido tambien en la conexion ftth-data del router, poniendo la vlan 100 y el user VFHxxxxx@vodafone, junto con la clave, y no me funciona, me dice error an ela autentificacion ppoe, me puedes guiar un poco??

Salu2 y gracias,
CHAVO
 
#46
Hola chavo,

Los datos que te aparecen de username y Password en la VoIP están encriptados, de manera que no puedes utilizarlos para levantar la conexión de teléfono desde otro dispositivo.

Lo mismo pasa con la contraseña PPoE de la wan, está encriptada (en cambio el username sí lo puedes ver).
Necesitas sí o sí snifar los datos para obtener esa info.
 
#47
Ostras, y eso cómo podría hacerlo?? No sé a q te refieres con eso de esnifar los datos... Yo tengo la captura de wireshark con la q pille la clave de router... Lo podría sacar de ahí??

Salu2
Chavo
 
#49
Hola porzino,

Si, gracias, indagando por el fichero de la captura que hice ya he conseguido también esa clave de la voip y de la conexión ppoe, así que voy avanzando...
No he probado a ponerla en el router Asus, pero sí he probado a configurar el phonerlite y he conseguido que me registre, aunque al de unos minutos se desregistra... supongo q pueda ser por algo de configuración, o q sigo teniendo el fijo puesto en el sercomm... así que el siguiente paso es pillarme un gigaset c590 ip como el tuyo (he visto de segunda mano por 30€), así que con eso creo me podría apañar para finalmente quitar de todo el sercomm

Salu2 y gracias por la info,
CHAVO
 
#50
Hola chavo,

Para comprobar si realmente te registra, desactiva el teléfono del sercomm.
Es muy fácil, vas a Phone->Phone Settings y en \"User Account Settings\" establesces a OFF en \"FXS 1\".

Aplicas los cambios y luego pruebas a registrarte desde el phonerlite.

De esta manera te aseguras que el registro lo hace el phonerlite. A mi al principio al no desregistrar el sercomm me registraba el gigaset, pero luego se desregistraba, así que no sabía que pasaba.
De esta manera te aseguras que el sercomm no se \"entromete\" en el registro del teléfono.

Sobre comprar el gigaset, yo miraría algún otro modelo.
Lo digo pq el gigaset tiene un problema, no puedes cambiar el \"user agent\" que utiliza para identificarse al registrarte en el servidor. En el caso de vodafone no es un problema, de momento, pero en jazztel sí, y era el motivo por el cuál no funcionaba el registro.
Sé que hay algún modelo de teléfono IP que permite modificar este valor (ahora no recuerdo cuál), y aunque ahora no lo valores, si en un futuro vodafone u otra compañía establece ese filtro podrás cambiar ese texto de identificación del terminal y continuar usando el teléfono.

Saludos
 
#51
Muchas gracias por la info porzino, voy a probar lo q comentas de desregistrar el sercomm...

En cuanto al gigaset, decía ese modelo por tener la garantía de q funciona y tu decirme q lo estas usando con vodafone ftth, lo mismo cojo otro y no soy capaz de configurarlo, o de q lo registre tal cual, o dónde meter la config... si de hecho estaba entre ese gigaset, o directamente un ata cisco 122 y dejar el inalámbrico normal q tengo ahora mismo... si tu me recomiendas otro modelo, a ese q me voy, si tiene un precio razonable...

Salu2
CHAVO
 
#53
Pues nada, voy a agenciarme un cisco SP122 y a ver si soy capaz de echarlo a andar... aunque buscando por internet veo mucha mas info del 112 que del 122, supongo que igual porque es el modelo anterior o no se...

De momento lo que he conseguido es que el phonerlite me registre, y tambien la app media5-fone e incluso fuera de casa mediante vpn. Con el Asus AC68u ya he conesguido conectar a internet, pero no lo he dejado ya instalado por no quedarme sin fijo.

Salu2
CHAVO
 
#54
Buenas porzino,

He conseguido algunos avances, aunque aun no lo tengo 100% conseguido, a ver si me podéis echar una mano...

Ya me llegó el Ata Cisco 122, y tras configurarlo he conseguido que lo registre, lo que es un primer paso, pero, si descuelgo el teléfono, oigo tono (algo diferente al de siempre, aunque supongo q será cosa de la config regional), y al de 3-4 segundos, empieza a comunicar, es decir:

Tiiiiiiiiiiiiiiii, ti-ti-ti-ti

Si yo marco desde el fijo, ya llamada no llega a efectuarse, porque da ese comunicando antes de hacer el ruidito de marcar los números...

Por otro lado, si yo marco al numero fijo desde el movil, la llamada si q entra, pero en el movil no oigo tonos.

Supongo q esto será algo de los mil parámetros de configuración que hay en el cisco, son demasiados!!!! Decir q lo del dial plan lo he copiado del router sercomm y pegado tal cual en el dial plan del cisco....

EDITO: He modificado la configuración regional la de España, que he encontrado por internet, y ahora los tonos ya son los de siempre, pero sigo sin poder llamar ni recibir llamadas, no sé donde tocar. Entiendo que si el registro me lo hace ok, la parte de Proxy and Registration y de Subscriber Information estará correcta, ya q sino no registraría no??
Ahora mismo si llamo descuelgo el fijo tengo linea, pero marque lo que marque, tras el ruidito de los números marcados, siempre da comunicando, bien llame a un fijo, o bien llame a un movil.  Si llamo desde un movil al fijo, la llamada me salta en el fijo, pero la persona q llama no oye nada, de hecho no oye ni la señal de q haya linea. 
Ya no sé por donde tirar, los códecs los tengo tal cual tenia el sercomm, y el dial plan este genérico q he encontrado en este foro (<:0034>xxxxxxxxx|xx.|*xx.|**xx.)  En el router he probado abriendo el puerto 5060, y también el 5095 hacia la ip del ata, y nada... no sé por donde pueden ir los tiros...

Salu2 y gracias,
CHAVO
 
#55
Re:

\"chavo\" dijo:
Buenas porzino,

He conseguido algunos avances, aunque aun no lo tengo 100% conseguido, a ver si me podéis echar una mano...

Ya me llegó el Ata Cisco 122, y tras configurarlo he conseguido que lo registre, lo que es un primer paso, pero, si descuelgo el teléfono, oigo tono (algo diferente al de siempre, aunque supongo q será cosa de la config regional), y al de 3-4 segundos, empieza a comunicar, es decir:

Tiiiiiiiiiiiiiiii, ti-ti-ti-ti

Si yo marco desde el fijo, ya llamada no llega a efectuarse, porque da ese comunicando antes de hacer el ruidito de marcar los números...

Por otro lado, si yo marco al numero fijo desde el movil, la llamada si q entra, pero en el movil no oigo tonos.

Supongo q esto será algo de los mil parámetros de configuración que hay en el cisco, son demasiados!!!! Decir q lo del dial plan lo he copiado del router sercomm y pegado tal cual en el dial plan del cisco....

EDITO: He modificado la configuración regional la de España, que he encontrado por internet, y ahora los tonos ya son los de siempre, pero sigo sin poder llamar ni recibir llamadas, no sé donde tocar. Entiendo que si el registro me lo hace ok, la parte de Proxy and Registration y de Subscriber Information estará correcta, ya q sino no registraría no??
Ahora mismo si llamo descuelgo el fijo tengo linea, pero marque lo que marque, tras el ruidito de los números marcados, siempre da comunicando, bien llame a un fijo, o bien llame a un movil.  Si llamo desde un movil al fijo, la llamada me salta en el fijo, pero la persona q llama no oye nada, de hecho no oye ni la señal de q haya linea. 
Ya no sé por donde tirar, los códecs los tengo tal cual tenia el sercomm, y el dial plan este genérico q he encontrado en este foro (<:0034>xxxxxxxxx|xx.|*xx.|**xx.)  En el router he probado abriendo el puerto 5060, y también el 5095 hacia la ip del ata, y nada... no sé por donde pueden ir los tiros...

Salu2 y gracias,
CHAVO
Yo tengo el PAP2T y me pasa exactamente lo mismo.
A ver si alguien nos puede ayudar
 
#56
Hola compañero,

Yo al final no he sido capaz de avanzar, y como aún estaba en plazo yo he devuelto el ata cisco.

He probado con un teléfono d la oficina, un Cisco spa 502g, y metiendo los mismos datos q metía al ata, me registra y me permite llamar y recibir sin problemas, así q tendría q ser alguna cosa del ata, y yo creo q probé a tocar todos los menús...

Como este teléfono q digo es el típico fijo de oficina, me he pillado un gigaset c530 ip, q me llegará mañana, q es el típico inhalambrico, q es lo q necesito para casa, pese a no tener lo del user agent que comentaba porzino... Mañana os cuento si soy capaz de echarlo a andar, pero ahora mismo el router de Vodafone está en su caja, y estoy funcionando con el asus ac68u, y la ont alcatel de Vodafone...

Salu2
Chavo 
 
#57
Pues yo sigo con mis expedientes X, ayer me llego el Gigaset C530ip, y no he conseguido echarlo a andar con la config q puso porzino.

Metí los mismo datos q él comentaba en este hilo, y la primera vez me registro e incluso pude hacer una llamada, y seguido se desregistro y ya me da siempre error en el registro, no tiene tantas opciones como el cisco SPA502G q tengo funcionando perfectamente. Este lo he pillado en amazon por si no conseguia funcionarlo, lo devolveré y me quedare con el ciscoSPA502g, pero no me mola porque es un telefono fijo y no inhalambrico, pero bueno...

Porzino!!!! Te necesito, ponme un pantallazo de tu config con el Gigaset plis!!

Salu2
CHAVO
 
#58
Hola,

Lo que se me ocurre es que compruebes la IP del servidor SIP que te toca. Desconozco si cambia según la central a la que estés conectado.
Luego comprueba es tema de los códecs.
Si todo está bien, igual deberías crear una entrada en las tablas del router con la IP del servidor sip y el nombre \"ims.vodafone.es\".

Creo que no hace falta, pero por si acaso.
El ATA cisco es mucho más potente que estos gigaset en temas de configuración. Seguramente fuera algún parámetro que no estaba bien.

Por cierto, tengo un gigaset C450 IP en casa criando polvo.
Sólo permite una cuenta SIP, en lugar de las 6 del C530IP, además de la línea analógica y el proveedor propio de siemens.
Si a alguien le interesa ya sabe.

Saludos
 
#59
Re:

\"porzino\" dijo:
Hola,

Lo que se me ocurre es que compruebes la IP del servidor SIP que te toca. Desconozco si cambia según la central a la que estés conectado.
Luego comprueba es tema de los códecs.
Si todo está bien, igual deberías crear una entrada en las tablas del router con la IP del servidor sip y el nombre \\\"ims.vodafone.es\\\".

Creo que no hace falta, pero por si acaso.
El ATA cisco es mucho más potente que estos gigaset en temas de configuración. Seguramente fuera algún parámetro que no estaba bien.

Por cierto, tengo un gigaset C450 IP en casa criando polvo.
Sólo permite una cuenta SIP, en lugar de las 6 del C530IP, además de la línea analógica y el proveedor propio de siemens.
Si a alguien le interesa ya sabe.

Saludos
Es que lo q me extraña es q con los mismos datos el cisco (no el ata) me registra y todo ok, s decir q la ip del servidor sip esta bien... Y sin crear nada de esas tablas del router  y el servidor sip... no sé.
Lo del ATA cisco ya lo devolví, así q estoy por conseguir lo del gigaset, q tengo un mes para devolverlo. Hay algún otro parámetro q configurar además de estos q he puesto, no sé si del modelo tuyo C590IP es diferente al C530ip mio, pero podrías ponerme algún pantallazo tapando tus datos personales???   Es q no entiendo porque la primera vez me registro y hast apude llamar y luego se jodio!!

Salu2 y gracias,
CHAVO
 
#60
Hola,

Pues aqui sigo con mis problemas para configurar la VOIP!!!

Voy ya con el tercer dispositivo antes de devolverlo, a ver si lo consigo, en esta ocasion y tras no conseguirlo ni con el ATA Cisco, ni con el gigaset C530ip, he pillado en amazo un Grandstream HT701, y tengo dudas en la config, porque no sé si lo estoy poniendo bien, lo tengo asi:



Las credenciales de Sip User ID, AutenticateID,  y password estan bien fijo, ya que son con las que tengo ahora mismo registrado y funcionando el telefono Cisco SPA 502g, pero tengo la duda de donde colocar el resto de datos, y con toda las pruebas q he hehco aun no he conseguido q registre, yo creo q el Outbound Proxy será el q tengo puesto, y como no veo donde especificar el puerto 5095, lo he puesto así, tengo la duda de donde poner lo de ims.vodafone.es porque se supone q eso es el proxy, pero yo no sé de donde sacar el Primary SIP Server...  YA no me meto en codec de q si se corta la llamada o no, porque de hecho ni siquiera me registra.... Alguna idea??  Me lo quedo para probar esta semana, si no lo consigo desisto y lo devuelvo...

Salu2
CHAVO
 
Arriba