AVISO: Hay una configuración nueva de MovistarTv (WAN y LAN)

Estado
Cerrado para nuevas respuestas.
#1
La manera de identificar si es vuestro caso para seguir esta configuración.

Teneis imagenio y en la configuracion del Comtrend os encontráis algo como esto:




Es decir, que no hay ip secundaria o la que llamamos ip interna de imagenio y que, en este caso, el decodificador obtiene ip mediante de DHCP de un pequeño rango reservado para el mismo de vuestra propia lan (192.168.1.X)

Otro de los cambios esta en la WAN, en lugar de encontrar una ip 172.26.x.x/20, encontrareis otra que será 10.x.x.x/9 y con NAT.

Este sería un ejemplo del fichero exportado del Comtrend en la parte donde encontrareis esa ip:


<Name>ipoe_eth0.2</Name>
<NATEnabled>TRUE</NATEnabled>
<X_BROADCOM_COM_FullconeNATEnabled>TRUE</X_BROADCOM_COM_FullconeNATEnabled>
<AddressingType>Static</AddressingType>
<ExternalIPAddress>10.x.x.x</ExternalIPAddress>
<SubnetMask>255.X.0.0</SubnetMask>
(Nota: Por si no sabeis como exportar la config. Es en el Comtrend via web y en el menu -> management -> Settings -> backup)


Forma de configurarlo si este es vuestro caso:

Sigue el manual de Malosa igualmente para cargar el fichero de configuración que se ajuste a lo que necesitas y una vez terminado todo el proceso cuando lleguéis al punto donde hay que añadir las ips de imagenio, hacéis lo siguiente:

Desde el winbox le das al boton "New Terminal" para añadir lo que falta mediante comando

-Añadir la ip de WAN de imagenio, comando:

/ip address add address=10.X.X.X netmask=255.X.0.0 interface=vlan2

-Activar el NAT de salida

/ip firewall nat
add action=masquerade chain=srcnat out-interface=vlan2


- (Update) Añadir este comando tambien para el correcto funcionamiento en el Deco de la Videoteca, Trailers etc..

/ip firewall nat
add action=dst-nat chain=dstnat comment="VOD" dst-address=10.X.X.X in-interface=vlan2 protocol=udp to-addresses=192.168.1.199



-Configurar el servidor de DHCP para reservarle una ip al deco y ademas enviarle unos parámetros concretos que necesita.

Necesitareis saber la MAC-ADDRESS del decodificador, ya que Mikrotik no parece que tenga opcion de identificarlo por VendorID como hace el comtrend. La MAC seguramente estará indicada en un adhesivo en el propio decodificador. Comandos:


/ip dhcp-server option
add code=240 name=option_para_deco value="':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"

/ip dhcp-server network
add address=192.168.1.199/32 dhcp-option=option_para_deco dns-server=172.26.23.3 gateway=192.168.1.1 netmask=24

/ip dhcp-server lease
add address=192.168.1.199 comment="Deco MovistarTv" dhcp-option=option_para_deco mac-address=XX:XX:XX:XX:XX:XX server=dhcp1



Eso eso todo. Espero que os sea de ayuda.

Saludos.
 
#2
Hola Begepeich,

Muchas gracias por la información. Todavía no sé si me tocará poner esta nueva configuración o la de Malosa, pero me huelo que será muy útil.

Una pregunta, con el comando...

Código:
/ip dhcp-server network 
add address=192.168.1.199/32 dhcp-option=option_para_deco dns-server=172.26.23.3 gateway=192.168.1.1 netmask=24
...no entiendo muy bien porque estás creando una /32 (una IP, la 199 en este caso) pero luego como netmask pones una /24. ¿Es un error?

Y otra cosa, con el comando...

Código:
/ip dhcp-server lease 
add address=192.168.1.199 comment="Deco MovistarTv" dhcp-option=option_para_deco mac-address=XX:XX:XX:XX:XX:XX server=dhcp1
...entiendo que estás reservando una IP para el deco, la 199 de antes. Supongo que elegiste esa porque está fuera del rango DHCP preconfigurado con la configuración de Malosa (que va de la 201 a la 249). Si es así, supongo que en vez de la 199 se podría cambiar a otra más baja por ejemplo, ¿no? Manías de uno jeje

Gracias de nuevo.
 
#3
Anonimo dijo:
Código:
/ip dhcp-server network 
add address=192.168.1.199/32 dhcp-option=option_para_deco dns-server=172.26.23.3 gateway=192.168.1.1 netmask=24
...no entiendo muy bien porque estás creando una /32 (una IP, la 199 en este caso) pero luego como netmask pones una /24. ¿Es un error?
No, lo he puesto así de forma intencionada. Es decir, tengo que usar una mas restrictiva para que no se me "cuele" por el otro network y no le asigne los mismos parámetros que asignará al resto del equipos/PCs, quiero que le dé un DNS distinto y le pase una option especial, sin embargo el GW y la mascara quiero que le dé los mismos, por eso el /24 luego.


Anonimo dijo:
Y otra cosa, con el comando...

Código:
/ip dhcp-server lease 
add address=192.168.1.199 comment="Deco MovistarTv" dhcp-option=option_para_deco mac-address=XX:XX:XX:XX:XX:XX server=dhcp1
...entiendo que estás reservando una IP para el deco, la 199 de antes. Supongo que elegiste esa porque está fuera del rango DHCP preconfigurado con la configuración de Malosa (que va de la 201 a la 249). Si es así, supongo que en vez de la 199 se podría cambiar a otra más baja por ejemplo, ¿no? Manías de uno jeje

Gracias de nuevo.
Claro que si :). Cada uno le puede dar la que quiera, modificandolo en ambos comandos.


Un saludo
 
#4
Perdonar mi ignorancia,

¿Con esta configuración también se ve imagenio en los PC´s? sin tocar nada,

Me supongo que si, al ser el mismo rango, pero me queda la duda y prefiero preguntároslo.

Gracias por la respuesta
 
#5
onjoe dijo:
Perdonar mi ignorancia,

¿Con esta configuración también se ve imagenio en los PC´s? sin tocar nada,

Me supongo que si, al ser el mismo rango, pero me queda la duda y prefiero preguntároslo.

Gracias por la respuesta
Si, sin tocar nada se verá en los PCs.

Un saludo
 
#8
Ya, pero a mí lo que me extraña es que la única forma por la que Movistar querría cambiar la configuración es para que sea automática, es decir, para que el técnico no tenga que estar metiendo a mano direcciones de cada cliente.

Tener una NAT en la interfaz y una dirección, eso es lo que todos los operadores del mundo hacen con DHCP o PPPoE.

Me extraña que hayan hecho este cambio bastante notable para dejarlo con el mismo defecto que antes.

En resumen, ¿has comprobado tú mismo que no asigna dinámicamente la dirección? Porque recuerdo que antes con la VLAN3 mucha gente la ponía estática, hasta que alguien se dio cuenta que que todo: las rutas y las direcciones se recibían solas.
 
#9
Malosa dijo:
Ya, pero a mí lo que me extraña es que la única forma por la que Movistar querría cambiar la configuración es para que sea automática, es decir, para que el técnico no tenga que estar metiendo a mano direcciones de cada cliente.

Tener una NAT en la interfaz y una dirección, eso es lo que todos los operadores del mundo hacen con DHCP o PPPoE.

Me extraña que hayan hecho este cambio bastante notable para dejarlo con el mismo defecto que antes.

En resumen, ¿has comprobado tú mismo que no asigna dinámicamente la dirección? Porque recuerdo que antes con la VLAN3 mucha gente la ponía estática, hasta que alguien se dio cuenta que que todo: las rutas y las direcciones se recibían solas.

Ah, no, la verdad es que no, eso no se ha probado.

Si que puedo garantizar al menos, que Movistar o sus técnicos si que lo están configurando así en el Comtrend (con ip estática). Y el Rip que sigue activo.

¿En la VLAN3 lo pusieron estático también alguna vez en Comtrend? Me refiero a Movistar, no a algún usuario por su cuenta.

Me extrañaría que funcione y configuren otra cosa, pero para hacer la prueba o salir de dudas y ver si también funcionase DHCP, nos tendrían que hacer el favor un par de usuarios si se prestan "Rivez" o "daripo". :)


Un saludo
 
#10
Yo en la VLAN2 monto un cliente DHCP y no pillo nada

Imagino que no estare metido en este grupo de usuarios o que no hay dhcp en la VLAN2 y hay que meter las IPs a mano


Una pregunta, ¿esta nueva configuracion es solo para clientes nuevos o estan migrando a todos poco a poco?

y otra pregunta, ¿si te migran a la nueva config, funcionarias con la config antigua o te la cortan al hacer el cambio?


Un saludo

Y para cualquier prueba por aqui estoy
 
#11
Hola, soy el Invitado que ha posteado en primer lugar.
Hoy me han instalado la TV Mini (han sido sorprendentemente rápidos), y efectivamente, como me suponía, he tenido que aplicar esta nueva configuración. Todo ha ido a la primera, perfecto. Gracias por vuestro trabajo.

Lo que sí he notado, es que no me funcionan los tráilers de los alquileres, le doy y se queda en negro. Imagino que si alquilase algo tendría el mismo problema, pero vamos, que esto no me preocupa mucho.

He probado a poner varios canales HD a la vez en el ordenador con el VLC y es bastante impresionante ver cómo más de 30 Mbps van para Movistar TV pero no restándose de los 100 Mbps. No sé dónde estará el límite de canales simultáneos, si es que lo hay.

Por cierto, viendo que estáis intentando averiguar si se puede pillar la IP 10.X.X.X automáticamente, por si os sirve de algo, en mi Comtrend tanto el archivo de backup como la interfaz web es ligeramente diferente a la mostrada por Begepeich. Por si os sirve de algo, aquí el fragmento relevante del fichero de backup:

Código:
        <WANIPConnection instance="2">
          <Enable>TRUE</Enable>
          <ConnectionType>IP_Routed</ConnectionType>
          <Name>2</Name>
          <NATEnabled>TRUE</NATEnabled>
          <AddressingType>Static</AddressingType>
          <ExternalIPAddress>10.X.X.X</ExternalIPAddress>
          <SubnetMask>255.128.0.0</SubnetMask>
          <DefaultGateway>10.128.0.1</DefaultGateway>
          <X_BROADCOM_COM_IGMPEnabled>TRUE</X_BROADCOM_COM_IGMPEnabled>
          <X_TELEFONICA-ES_IGMPEnabled>TRUE</X_TELEFONICA-ES_IGMPEnabled>
          <RouteProtocolRx>RIPv2</RouteProtocolRx>
          <X_BROADCOM_COM_IfName>eth0.2</X_BROADCOM_COM_IfName>
          <X_BROADCOM_COM_VlanMux8021p>4</X_BROADCOM_COM_VlanMux8021p>
          <X_BROADCOM_COM_VlanMuxID>2</X_BROADCOM_COM_VlanMuxID>
          <PortMappingNumberOfEntries>0</PortMappingNumberOfEntries>
        </WANIPConnection>
Y aquí la captura de la interfaz web (los datos son los mismos, eso sí)
 
#13
Si, en tu caso parece que lo que es distinto es el firmware de comtrend. Ya que se ve, por ejemplo, que en el tuyo contempla la posibilidad de enviar otras "options" por ejemplo, poniendo el prefijo de la que quieras "240".

Para saber si es capaz de conseguir una ip por dhcp en la vlan2, tendrías que primero borrar la ip y luego añadir el interfaz vlan2 en el ip-> dhcp-client y ver si te coge ip.


Un saludo
 
#14
Desde mi total ignorancia....

Llevo varios dias con problemas con Tomato y es que no logro ver Imagenio en el PC y sí en el deco que funciona sin problemas.

He consultado en mi comtrend de movistar y el pantallazo de la configuracion que indica al principio del post Begepeich, no coincide con lo que tengo yo. Soy usuario de imagenio desde hace un porrazo de años, osea que no soy nuevo alta.

Aunque la configuracion de los cambios que esta realizando movistar no coincida con mi router comtrend, ¿es probable que el problema de no ver por el vlc los canales de imagenio sea por todo esto y en el tomato tenga que meter estos cambios que indicais?

De ser asi, me gustaria saber como adaptar esos comandos para Tomato.
 
#16
Begepeich dijo:
Si, en tu caso parece que lo que es distinto es el firmware de comtrend. Ya que se ve, por ejemplo, que en el tuyo contempla la posibilidad de enviar otras "options" por ejemplo, poniendo el prefijo de la que quieras "240".

Para saber si es capaz de conseguir una ip por dhcp en la vlan2, tendrías que primero borrar la ip y luego añadir el interfaz vlan2 en el ip-> dhcp-client y ver si te coge ip.


Un saludo
Lo acabo de probar como me has dicho y nada, se queda en "searching...". Por confirmar, lo que he hecho ha sido borrar la IP 10.X.X.X de IP -> Addresses (la de la vlan2, claro) y luego añadir la interfaz vlan2 en DHCP-Client de la misma manera que estaba configurada la vlan3:

Código:
/ip dhcp-client
add add-default-route=no disabled=no interface=vlan2 use-peer-ntp=no
Saludos!
 
#18
mikeltb dijo:
Desde mi total ignorancia....

Llevo varios dias con problemas con Tomato y es que no logro ver Imagenio en el PC y sí en el deco que funciona sin problemas.

He consultado en mi comtrend de movistar y el pantallazo de la configuracion que indica al principio del post Begepeich, no coincide con lo que tengo yo. Soy usuario de imagenio desde hace un porrazo de años, osea que no soy nuevo alta.

Aunque la configuracion de los cambios que esta realizando movistar no coincida con mi router comtrend, ¿es probable que el problema de no ver por el vlc los canales de imagenio sea por todo esto y en el tomato tenga que meter estos cambios que indicais?

De ser asi, me gustaria saber como adaptar esos comandos para Tomato.
No, si no es tu caso no hace falta que intentes configurar esto en el Tomato.

El problema que tu tienes mas bien parece algún conflicto de configuración cuando separas los direccionamientos en interfaces distintas y como gestiona tu equipo esa mezcla, de vlan, igmp proxy, firewall etc.. No sé, yo creo que lo configuraría o probaría a configurarlo de otra forma, pero no tengo ningun router de ese tipo para probar.

Un saludo.
 
#19
Begepeich, sinceramente ya no se que hacer.
Le he metido otra tarjeta de red al PC, una con el rango IP del deco y otra con la de la LAN, se que no es muy elegante pero es la única forma que he encontrado de ver Imagenio en el VLC o mediaportal.
Podéis ver mis comentarios en este link para no andar duplicando.


http://www.adslzone.net/posts272448-420.html
 
#20
Hola

me acaban de poner la fibra con el imagenio mini de regalo, y como me trajeron los tres aparatos ( ont, router comtrend y deco zyxel ) y como ya tengo mi wifi creada con puntos de acceso airport de apple, y no queria tanto aparato , reconfigure la ONT HG8240 como router tal como explica otro compañero del foro , y funcionó, por lo que para internet puedes quitar el comtrend sin problemas.
El problema es imagenio , no va, por lo que me gustaría saber configurar tanto la ONT ( yo creo que se debe poder , los menus que tiene son como los de cualquier router , por lo que a menos que falte alguna funcionalidad concreta no tendría que haber problemas) como en el deco , si es que hay que hacer algo -> es verdad que cuando llegaron los técnicos a casa , en el deco cambiaron ( me parece) la opcion de IP estatica a DHCP, pues al menos asi esta ahora( lo he reseteado a ver si cogía alguna configuración de la red pero conectado a la ONT directamente no va - de momento-.)

Gracias a todos por el trabajo que le meteis al foro.
 
Estado
Cerrado para nuevas respuestas.
Arriba