ADAMO FIBRA: Configuración router Mikrotik hEX S con IP Estática asignada (WAN)

Hola,

Después de mucho discutir con Guuk (Masmovil) no había forma de permanecer fuera del CGNAT de forma permanente, decidí volver a Adamo que es la única otra opción que hay donde vivo.

En Adamo contraté el paquete PYME (1000 Mb simétricos, IP Fija y SAT 24/7). La verdad que casi todo excelente. Por lo menos no tienen CGNAT, el SAT atiende de forma inmediata las 24 horas, etc... El router es un Inteno que no te dejan suprimir. La única opción que te ofrecen es conectar tu router neutro al puerto LAN 4 que está en modo BRIDGE de forma automática.

Me enviaron un correo con los datos de IP fija, máscara, gateway y DNSs. Desde el primer día, el Inteno no cogía la IP fija asignada, y no te deja modificar ninguno de los parámetros WAN. Según el SAT la IP fija la tienen que asignar ellos desde la central a mi router Inteno en particular. Después de 1 semana sin poder asignarle la IP fija, decidieron cambiarme el router, otro Inteno. Los primeros días con el segundo router INteno no podían acceder remotamente, despues de otra semana, al final consiguieron asignarme mi IP fija al router Inteno.

Hecho esto, quite el Inteno y conecté el Mikrotik hEX s directamente a la ONT de ellos, la Fiberhome. En IP Adresses introduje la IP fija y la interface ether1. En ether1 configuré otra interface llamada Adamo con VLAN ID = 603. En IP DHCP Client lo dejé en blanco, sin dato alguno. En IP Firewal NAT Rule configuré CHAIN = srcnat , Out. Interface List = WAN, y Action = Masquerade. Configuré una nueva ruta con Dst. Address = 0.0.0.0, la gateway que me indicaron, apareciendo como reachable ether1. Los IP DNS y ya está. Pero no conecta. En el Quickset aparece configurado en modo Router e IP fija con todos los datos correctos. Y en el campo MAC configurado con la MAC Address del router Inteno ( el Inteno coge la IP fija asignada sin problemas). Pues nada, imposible navegar con el Mikrotik configurado de esa forma.

Sin embargo, si configuro el Mikrotik para IP dinámica, con sólo introducir la MAC del Inteno en el Quickset, coge IP a la primera, pero distinta de la que tengo asignada, y funciona perfectamente. No hace falta ni introducir dato alguno en el IP DHCP Client. Y así lo tengo funcionando.

Alguien sabe cómo configurar el Mikrotik para que coja la IP que tengo asignada? En principio entiendo que la central asocia a la MAC del Inteno la IP asignada, pero debe haber alguna otra variable porque el Mikrotik con esa MAC no coge mi IP asignada.

SI alguien necesita más datos de configuración para echarme un cable, le puedo mandar los datos que precise por privado.

Gracias a todos.

Sin e
 
La IP no va sobre ether1, sino sobre la VLAN. No tiene más misterio.

Saludos!
 
Hola Pokoyo,

He puesto la IP Fija sobre la VLAN Adamo y sigue sin funcionar. Por privado te he mandado un export solo con los datos relativos a la IP Fija, incluyendo los datos reales de la IP, gateway, etc...para ver si hay algo erroneo.

Publico aqui tambien la configuración que no me funciona pero con los datos privados ocultos. Por si a alguien le sirve de ayuda.

Gracias Pokoyo

Código:
/interface bridge
add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no comment=defconf igmp-snooping=yes \
    multicast-querier=yes multicast-router=permanent name=bridge
/interface ethernet
set [ find default-name=ether1 ] mac-address=YY:YY:YY:YY:YY:YY
/interface vlan
add interface=ether1 name=Adamo vlan-id=603

/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN

/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf

/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface detect-internet
set detect-interface-list=WAN internet-interface-list=static \
    lan-interface-list=WAN wan-interface-list=WAN

/interface list member
add interface=ether1 list=WAN
add interface=bridge list=LAN
add interface=Adamo list=WAN

/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
    192.168.88.0
add address=91.xxx.xx.x/23 interface=Adamo network=91.xxx.x0.0

/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=8.8.8.8,8.4.4.8 gateway=\
    192.168.88.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.4.4.8
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan

/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=\
    out,none out-interface-list=WAN

add action=masquerade chain=srcnat out-interface-list=WAN


/ip route
add distance=1 gateway=91.xxx.yy.y
/ip service
set www address=192.168.88.0/24,192.168.89.0/24
set winbox address=192.168.88.0/24
 
La configuración está bien. Tienes un par de cosillas a corregir (el NAT lo metes dos veces, con la primera regla vale, y todas las opciones de multicast del bridge principal sobran), pero lo que es el setup de la conectividad está fino. Para ver si es simplemente un tema de resolución de nombres (dns), abre la terminal dentro de winbox y haz un ping a 8.8.8.8. Si responde, lo único que te queda por poner es el dns, que al no recibir la IP de manera dinámica, tienes que configurar a mano.

Saludos!
 
Genial, pero una pregunta tonta: Cómo meto las DNS a mano para mí IP? Porque veo varias formas y no encuentra el 8.8.8.8
 
Si el ping no responde desde la terminal de winbox a la 8.8.8.8, olvídate que no es problema del dns. Habría que ver si esa IP que te han dado es válida y funciona, y eso solo lo vas a saber si te lo configuran en su router, el propio de la operadora.

Si sí que responde, tendrías que definir en IP > DNS un par de servidores dns públicos, y marcar la opción de “allow remote requests” para que el propio router haga de servidor dns para tus equipos locales.

Saludos!
 
No, no responde el ping al 8.8.8.8.

Si conecto el router de Adamo a la ONT, inmediatamente coge la IP que me han asignado. Luego tiene que ser una IP válida porque funciona.

Pero el router está tan capado que no hay forma de ver los parámetros que usa para el WAN. Solo aparece en una ventana bajo el título de WAN, la IP con la que está conectado, que es la asignada, la puerta de enlace y los DNS. No hay forma de profundizar. Se puede ver cómo aparece en la foto que adjunto, aunque corresponde a otra IP distinta a la asignada actual. No sé si la IP fija se la da la central o está configurada en el router de Adamo.

Adamo router propio datos IP.png
 
La ip que sale ahi no es la que me enseñas por privado. Ojo con eso.

Otra pregunta, responde a un ping a la puerta de enlace si quiera? Sabes seguro que la vlan de adamo es la 603? Manda si puedes in pantallazo de la tabla de rutas, a ver qué dice.

Saludos!
 
No, la IP de la imagen no tiene nada que ver. La tuve unos dias con el otro router que al final me cambiaron.

Voy a mirar lo del ping a la puerta de enlace. La VLAN de Adamo puede ser la 603 o 604. Creo que esta última la usan para cuando su router esta en modo Bridge. Y te mando pantallazo de la tabla de rutas. Gracias.
 
No, la IP de la imagen no tiene nada que ver. La tuve unos dias con el otro router que al final me cambiaron.

Voy a mirar lo del ping a la puerta de enlace. La VLAN de Adamo puede ser la 603 o 604. Creo que esta última la usan para cuando su router esta en modo Bridge. Y te mando pantallazo de la tabla de rutas. Gracias.
Ahí voy. Que puede que estemos dando por hecho que la vlan es esa y resulta que cambie cuando vayas por estática. Es raro, pero podría darse el caso. Con la VLAN 603 y conexión dinámica (cliente dhcp) sí que coge IP el mikrotik, ¿correcto?

Saludos!
 
Correcto, con la VLAN 603 e IP Dinámica, el Mikrotik coge IP. Y en los dos o tres días que llevo probando, aunque es dinámica, siempre me da la misma, extraño no? A ver si resulta que es esa la IP Fija, y como el Mikrotik lleva la MAC del router de Adamo....

Voy a investigar lo de si la VLAN para IP fijas es otra. Por privado te mando los pantallazos.

Gracias.
 
Tu vlan va a nivel de WAN, no de LAN, así que quieto parado que no necesitas tocar más configuraciones a nivel switch.

Dos pruebas: la primera, tal cual lo tienes (IP estática con los datos que te han dado), simplemente cambia la vlan 603 por la 604. Si tampoco, prueba con la vlan 20 (menos probable), por si tu servicio fuera Neba.

Segunda prueba: es posible que, aunque tengas una IP “fija” tu IP se entregue de manera dinámica por DHCP. Al igual que nosotros podemos hacer una reserva en el DHCP con el “make static”, lo mismo puede hacer tu operador, vinculando tu dispositivo final por MAC a esa IP. Eso puede tener que ver con que siempre recibas la misma IP si clonas la MAC del router original.

Prueba primero lo de cambiar la vlan 603 por la 604, y sino ya vemos cómo le metemos mano a lo otro.

Saludos!
 
Aupa hi, la vlan es la 605 si tienes ip fija, te queda la 603 con dinamica y dhcp y la 605 con static y la que te hubieran asignado. la 604 deja de funcionar al tener ip fija.
 
Arriba