Comtrend CT-5361 como cliente Wifi con OpenWRT

#1
Intento conectarme a una red abierta que llega con poca señal según a qué puntos de mi casa. Después de investigar y ver que este Router no se puede usar como repetidor universal, la mejor opción es conectarlo como cliente a la red principal y a partir de ahí utilizar otro router como AP que distribuya la señal wifi.

Para usar el Comtrend CT-5361 como cliente, he seguido este manual.

He cambiado el firmware a OpenWRT.

La interfaz WAN la he configurado como sigue:
Protocol: static
IPV4-Address: 192.168.1.53
IPV4-Netmask: 255.255.255.0
IPV4-Gateway: 192.168.1.1
DNS-Server: 192.168.1.1
(Aquí tengo mis dudas, y también he probado con 80.58.61.250 que es el que me asigna al conectar por DHCP a la red principal)

La interfaz LAN:
Protocol: static
Bridge interfaces marcado
IPV4-Address: 192.168.2.1
IPV4-Netmask: 255.255.255.0
IPV4-Gateway: (vacío)


Y finalmente Network/Wifi/Radio0 con los datos de acceso (cifrado, ESSID, Encription, Key) en modo cliente a la red principal en su mismo canal.

Cuando después voy a Status/Interfaces, la configuración es como en el manual y WAN transmite datos pero no recibe. Si trato de hacer un ping al router que he configurado como cliente, me devuelve host inaccesible. Dónde puede estar el fallo? Estoy haciendo algo mal? Me dáis alguna idea?

Si consiguiera conectarlo a esta red, detrás he configurado un AP con un Observa Telecom que tenía por casa, al que he deshabilitado el DHCP y he configurado una red wifi en un canal diferente al de la red principal con su propio ESSID y encriptación. Su IP es 192.168.2.2 y su máscara de red 255.255.255.0 (no tiene para configurar el gateway). He conectado un cable de red cruzado del puerto LAN1 del Comtrend al LAN1 del Observa. Aquí también tengo mis dudas: cable cruzado o paralelo? Los puertos mecionados u otros (dado que el LAN4 del Comtrend hace de WAN)?

Con esta configuración conectado a la wifi del Observa me asigna IPs de la red 192.168.2.0/24 y puedo hacer ping sin problemas a los dos routers (incluso a la IP 192.168.1.53), así que supongo que el problema es que el Comtrend no está haciendo bien de cliente y no tiene acceso a Internet.

Perdón por el tocho y muchas gracias por la ayuda que me podáis prestar.
 
#2
Hola:

Prueba de esta forma:

El router que se conecta a la wifi.
1.- WIFI:
Mode = Client
Network = Wan
Configura SSID y demás.
Save & apply
NOTA: La versión backfire de openWRT tiene un botón de scan para buscar la wifi a la que te quieres conectar. Facilita mucho las cosas.

2.- WAN:
La red wifi a la que te conectas, seguramente, sirva ip's mediante DHCP. DHCP también configurará los DNS.
Protocol = DHCP client.
Interface = La wifi. Wlan0 o radio0
save & apply

3.- LAN
Configuras tú red como más te guste. DNS's y cosas por el estilo los que te proporcionen por dhcp.

Conectas los routers, con un CABLE NORMAL. No necesitas cables cruzados.

Buena suerte.

En router de tu red interna debes de configurar como WAN la conexión que tiene con el que esta conectado a la wifi.
La wifi (la tuya) puedes configurarla como más te guste.
 
#3
Gracias @dopicom, volveré a probar a ver si consigo dar con la configuración siguiendo tus pasos, que no termino de dar con la tecla.
 
#4
aquaryorp dijo:
Gracias @dopicom, volveré a probar a ver si consigo dar con la configuración siguiendo tus pasos, que no termino de dar con la tecla.
HOla:
Otra recomendación, descargate la última versión, backfire, aquí:
http://downloads.openwrt.org/backfire/10.03.1-rc6/brcm63xx/openwrt-96348GW-generic-squashfs-cfe.bin

Así compartimos versión del firmware y será más fácil ayudarte.
Además veras que es mucho más sencillo configurar la wifi con backfire.

Un saludo.
 
#5
Sí, ya la instalé. Es que primero di con el manual, y luego ya metido en faena vi que habían versiones nuevas, así que la instalé pero no he tenido mucho tiempo aún para trastearla.
 
Arriba