Os dejo una config que seguro que os sirve ;)

Current configuration : 1708 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 xxxxxxxxxxxxxxxxxx
enable password 7 xxxxxxxxxxxxx
!
username chatplay
ip subnet-zero
no ip finger
!
ip cef
no ip dhcp-client network-discovery
!
policy-map WFQ
class class-default
fair-queue
random-detect
!
!
!
!
interface Tunnel1
ip address 192.168.50.3 255.255.255.0
tunnel source 217.xxxxxxxxxxx
tunnel destination 213.xxxxxxx
tunnel mode ipip
tunnel key 33493
tunnel sequence-datagrams
tunnel checksum
!
interface Ethernet0
ip address 192.168.0.16 255.255.255.0
ip nat inside
no ip mroute-cache
no cdp enable
!
interface ATM0
no ip address
no ip mroute-cache
no atm auto-configuration
no atm ilmi-keepalive
no atm address-registration
no atm ilmi-enable
bundle-enable
dsl operating-mode auto
hold-queue 208 in
!
interface ATM0.1 point-to-point
ip address 217.xxxxxxx 255.255.255.224
ip nat outside
no ip mroute-cache
pvc 8/32
encapsulation aal5snap
service-policy output WFQ
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
ip route 192.168.1.0 255.255.255.0 Tunnel1
no ip http server
!
ip nat inside source list 101 interface ATM0.1 overload
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 101 permit ip any any
no cdp run

!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
password 7 xxxxxxxxxxxxxx
login
!
scheduler max-task-time 5000
end
 
tengo pregunta un poco tonta supongo de esa config cual seria la ip k tendria k poner como puerta de enlace¿??¿gracias y salu2
 
Buenas, yo tengo otra pregunta.
Como se entra esa serie de comando en el router?
Siguendo el tutorial de Cambiar el password cada vez que entro por hyperterminal (desde un PC con puerto COM) o telnet (ahora solo puedo acceder asi ya que mi PC no tiene puertos COM, uso el putty) se me queda en:
Router>

y desde ahi lo unico que he conseguido, a traves de los tutos de la web, ha sido arrancar o parar los interfaces.

Decir que lo quiero configurar para Wanadoo ADSL (IP dinamica) pero no se como meterle los comandos, y en el tutorial dice que solo arrancar el router se han de poner, pero a mi me entra en Router.

Espero que me podais guiar.

Gracias.
_____________________________________________________________

[EDIT]

Bueno, pues nada.. al final lo he sabido hacer.

[/EDIT]
 
Para poder configurar el Router debes estar en modo privilegiado.

Router>enable (Te pedirá la contraseña enable secret...)

Router#config t (para entrar en modo configuración por terminal)

Router(config)# (aqui ya puedes configurar tu router)


Un saludo,


Olaf Marcos
 
Siguiendo el manual de Cambio de Password del Cisco 827, en un 837,
y llegando el momento de hacer login...

router (config)#line console 0
router (config-line)#password --------
router (config-line)#login
% Incomplete command

Por que incompletoooooooo.
Que se me escapa. :oops:
Un Saludo y Gracias.
 
prueba a poner:
router (config-line)#login ?
que te cante a ver lo que te falta
en teoria el comando es valido, pero weno.
 
Me pide si quiero entrar la configuracion cada vez que encie

Tengo un cisco 827 al que le cambie la IO pero a la hora de configurarlo lo configuro con lo tutos que hay aqui pero al reiniciar el router me vuelve a pedir la configuracion y se me queda sin nigun parametro de los que le he puesto y eso que cuando acabo de introducir toda la config le hago el "copy run start" y el "copy running-config startup-config" pero no se queda no se que hacer gracias.
 
Hola pens,

Lo mas probable es que el valor del registro de configuracion no sea el correcto.

comprueba el estdo del registo de configuracion:

1.- ejecuta show ver y busca la linea:

Configuration register is 0x2102

si el valor es distinto de 2102, cambialo siguiendo las lineas de abajo

2.- enable (para entrar en modo enable)

3.- conf ter (para entrar en modo conf)

4.- router(config)#config-register 0x2102

5.- reinicia el router y ejecuta show ver y el valor debe haber cambiado y debe conservar la config.


Si el problema no fuese este, escribelo aquí.

Saludos
 
Hola pens,

Lo mas probable es que el valor del registro de configuracion no sea el correcto.

comprueba el estdo del registo de configuracion:

1.- ejecuta show ver y busca la linea:

Configuration register is 0x2102

si el valor es distinto de 2102, cambialo siguiendo las lineas de abajo

2.- enable (para entrar en modo enable)

3.- conf ter (para entrar en modo conf)

4.- router(config)#config-register 0x2102

5.- reinicia el router y ejecuta show ver y el valor debe haber cambiado y debe conservar la config.


Si el problema no fuese este, escribelo aquí.

Saludos
 
Gracias ese era el problema ya no me pide volver a ponerle la configuracion en cada reinicio, creo que quise volver a la configuracion de fabrica y no lo devolvi a esa configuracion
 
Me alegro que todo bien. Para devolver un cisco a la config de fabrica hay que escribir en modo enable "write erase". Esto borra todos los ficheros de la NVRAM y deja el Router limpio (con el conf-reg a 0x2102)

Saludos
 
Cual es la ultima version de IOS de cada rama?

Hola a todos los foreros de la zona.
La verdad es que llevo tiempo dándole vueltas a un tema en cuestión, os explico mi problema.

Tengo un router 1720 el cual estoy configurando como router en mi casa, hasta aquí todo bien, pegarme un poco con el y listo.
Pero antes de conectarlo definitivamente me gustaría tener una versión del IOS sin fallos de seguridad, que últimamente esta muy de moda atacar a los pobrecitos ciscos.

He pasado mucho mas tiempo intentado entender por que hay tantas versiones de IOS que configurando el router.
Aquí mis conocimientos adquiridos,

-> 12.1, 12.2, 12.3, 12.4 son versiones diferentes del sistema (como serian un w98, NT y un w2k. Ya se que es muy mal ejemplo, pero no me matéis)

-> Además cada versión IOS puede tener diferentes módulos, por ejemplo IPSEC o VOIP, Firewall, etc... Estos se nombran con letras, por ejemplo el modulo básico de IP es el “y”, el de ADSL es el “7” , el de ADSL+ es el “s” y el de Firewall es el “k”.

-> Dentro de cada versión del IOS existen diferentes ramas, principalmente la rama principal “Mainline”, que solo suele recibir actualizaciones de seguridad y la rama “T”, que seria como la rama en la que se van aplicando nuevas funcionalidades y que será la base de la siguiente versión (rollo Debian Testing, no soy muy bueno con los ejemplos)

-> Y por ultimo, cada versión o subversión (ramas) del IOS va recibiendo actualizaciones. Creo que es el ultimo numero en los nombres de las IOS.

Bueno después de toda esta morralla, perdonarme pero tenia que dejarlo claro, aquí va mi batallón de preguntas:

Siguiendo la premisa de seguridad: Instala solo lo que necesites, mi imagen debería tener una forma parecida a c1700-y7-mz-12.3(15) <---- (creo que la 15 es la ultima actualización de seguridad)
¿¿ Es esta la IOS mas adecuada a mis necesidades ??

¿¿ Como puedo saber cual es la ultima versión de una IOS incluyendo las actualizaciones ?? Es decir si me decido por la versión 12.4 Mainline como sabría cual es el nombre de la ultima imagen ??

Muchas gracias por anticipado, la verdad es que me esta siendo muy difícil. En la página de cisco siempre que te van a dar la respuesta a algo que buscas te pide login.
 
tinao dijo:
Siguiendo el manual de Cambio de Password del Cisco 827, en un 837,
y llegando el momento de hacer login...

router (config)#line console 0
router (config-line)#password --------
router (config-line)#login
% Incomplete command

Por que incompletoooooooo.
Que se me escapa. :oops:
Un Saludo y Gracias.



Prueba poner

router (config)#line console 0
router (config-line)#password 0 --------
router (config-line)#login

despues de password espacio y despues de 0 espacio

un saludo
 
kesler dijo:
tinao dijo:
Siguiendo el manual de Cambio de Password del Cisco 827, en un 837,
y llegando el momento de hacer login...

router (config)#line console 0
router (config-line)#password --------
router (config-line)#login
% Incomplete command

Por que incompletoooooooo.
Que se me escapa. :oops:
Un Saludo y Gracias.



Prueba poner

router (config)#line console 0
router (config-line)#password 0 --------
router (config-line)#login

despues de password espacio y despues de 0 espacio

un saludo

router(config-line)#line console 0
router(config-line)#password 0 ------
router(config-line)#login
% Incomplete command.

router(config-line)#

Pos eso, que no hay manera.

Haciendo un login ? me da:

router(config-line)#login ?
authentication Authentication parameters.

Una ayudita???, gracias
 
Entiendo que eso es una configuracion basica para hacer funcionar un adsl y demas, creo que es demasiado complicada para empezar a configurar un router ya que estas utilizando tuneles y politicas de QOS que creo que son demasiado complicadas como para que una persona que tiene contacto por primera vez con un bicho de estos entienda lo que esta poniendo.

Hay configuraciones mucho mas sencillas e igualemente eficazes para estos cisco por el foro.
 
Hola.

Yo tengo que configurar una VPN en un 877 y no sé qué parámetro he de cambiar o configurar para que funcione.
Me puede alguien ayudar?.

Un saludo y gracias.
 
cisco 837

soy nuevo en esto como salgo de aqui
es que no se que error cometi
pero ya no me entra en router>
y ya menos en router#
le cambie la contraseñay me lie
cuando entre en la http://192.168.1.2/
y despues de instalar el java
no deje que terminara de cargar y desde hay no
se que hacer
 
Re: cisco 837

soy nuevo en esto como salgo de aqui
rommon 1 >
sigo este manual apartir de aqui
Instalar el Servidor tftp en un ordenador.
Instalar el CRT (Emulador de HyperTerminal).
Conectar el Router al Ordenador con un cable de red (Necesario para transferir la FLASH mediante el TFTP)
Conectarse al Router con el CTR a traves de serial usando esta configuración:

- Protocol: Serial
- Port: Com1
- Baud Rates: 9600
- Data Bits: 8
- Parity: None
- Stop Bits: 1
- Flow Control: None

Una vez dentro, si tenemos que detener la carga de la flash, ejecutamos la combinación de teclas [Control] + [Pause] en los primeros segundos, para entrar en modo:

Rommon 1>

En este modo tecleamos en pantalla

Rommon 1>tftpdnld [Enter]

Aparecerán las siguientes líneas:

----------------------------------------------------------------------------------

Missing or illegal ip address for variable IP_ADDRESS
Illegal IP address.

usage: tftpdnld [-ur]
Use this command for disaster recovery only to recover an image via TFTP.
Monitor variables are used to set up parameters for the transfer.
(Syntax: "VARIABLE_NAME=value" and use "set" to show current variables.)
"ctrl-c" or "break" stops the transfer before flash erase begins.

The following variables are REQUIRED to be set for tftpdnld:
IP_ADDRESS: The IP address for this unit
IP_SUBNET_MASK: The subnet mask for this unit
DEFAULT_GATEWAY: The default gateway for this unit
TFTP_SERVER: The IP address of the server to fetch from
TFTP_FILE: The filename to fetch

The following variables are OPTIONAL:
TFTP_VERBOSE: Print setting. 0=quiet, 1=progress(default), 2=verbose
TFTP_RETRY_COUNT: Retry count for ARP and TFTP (default=7)
TFTP_TIMEOUT: Overall timeout of operation in seconds (default=7200)
TFTP_CHECKSUM: Perform checksum test on image, 0=no, 1=yes (default=1)

Command line options:
-r: do not write flash, load to DRAM only and launch image
-u: upgrade the rommon, system will reboot once upgrade is complete

----------------------------------------------------------------------------------


Para hacer posible la descarga del archivo al Router, tendremos que introducir los comandos de la lista sustituyendo los datos por los pertenecientes a nuestro sistema:

IP_ADDRESS=192.168.1.2
IP_SUBNET_MASK=255.255.255.0
DEFAULT_GATEWAY=192.168.1.1
TFTP_SERVER=192.168.1.13
TFTP_FILE=c820-oy6-mz.124-10a

Una vez hecho esto, abrimos en el ordenador el programa Cisco TFTP Server; lo configuramos para que en la opción

TFTP Server root Directory=(Directorio donde está el archivo Flash).

Una vez hecho todo esto, escribimos en la consola del CRT:

Rommon 10>tftdnld [Enter]

Aceptamos las opciones que nos vayan apareciendo, y listo; el Router queda programado con la nueva Flash. Solo hay que reiniciarlo y listo.
para poder cambiar la IOS pero nada de nada no se que hacer.
es que no se que error cometi
pero ya no me entra en router>
y ya menos en router#
le cambie la contraseñay me lie
cuando entre en la http://192.168.1.2/
y despues de instalar el java
no deje que terminara de cargar y desde hay no
se que hacer
 
PUEDO CONFIGURAR VARIOS TUNNELES?? EN UN MISMO ENRUTADOR COMO LO HARIA
 
MrBunbury dijo:
Current configuration : 1708 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 xxxxxxxxxxxxxxxxxx
enable password 7 xxxxxxxxxxxxx
!
username chatplay
ip subnet-zero
no ip finger
!
ip cef
no ip dhcp-client network-discovery
!
policy-map WFQ
class class-default
fair-queue
random-detect
!
!
!
!
interface Tunnel1
ip address 192.168.50.3 255.255.255.0
tunnel source 217.xxxxxxxxxxx
tunnel destination 213.xxxxxxx
tunnel mode ipip
tunnel key 33493
tunnel sequence-datagrams
tunnel checksum
!
interface Ethernet0
ip address 192.168.0.16 255.255.255.0
ip nat inside
no ip mroute-cache
no cdp enable
!
interface ATM0
no ip address
no ip mroute-cache
no atm auto-configuration
no atm ilmi-keepalive
no atm address-registration
no atm ilmi-enable
bundle-enable
dsl operating-mode auto
hold-queue 208 in
!
interface ATM0.1 point-to-point
ip address 217.xxxxxxx 255.255.255.224
ip nat outside
no ip mroute-cache
pvc 8/32
encapsulation aal5snap
service-policy output WFQ
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
ip route 192.168.1.0 255.255.255.0 Tunnel1
no ip http server
!
ip nat inside source list 101 interface ATM0.1 overload
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 101 permit ip any any
no cdp run

!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
password 7 xxxxxxxxxxxxxx
login
!
scheduler max-task-time 5000
end
Hola gente. MrBunbury nos facilita la configuración de arriba.
¿Alguien sabe si vale para ya.com?. Y en ese caso, ¿podéis decirme qué hay que poner en las xxxxxxxxxxx que figuran en:

interface Tunnel1
ip address 192.168.50.3 255.255.255.0
tunnel source 217.xxxxxxxxxxx
tunnel destination 213.xxxxxxx
tunnel mode ipip

y en

interface ATM0.1 point-to-point
ip address 217.xxxxxxx 255.255.255.224
ip nat outside
no ip mroute-cache

Y otra cosa más. ¿sabe alguien como configurar el router para poder acceder a él a través de web?.

Gracias.
 
Arriba