ISP--CISCO 857---[Ip Publica]PC/firewall (AYUDA!)

Saludos,
Tengo un router Cisco 800 series (857).
Necesito encontrar la forma de que la ip publica (dinamica)
que me da el isp me caiga directamente en la PC (o en un firewall).

Probe con un router thompson y ya se que es posible,
Alguien sabe la manera de hacer esto con un router Cisco??

A continuacion les dejo mi running config:

Router#show run
Building configuration...

Current configuration : 7442 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable password cisco
!
no aaa new-model
!
ip cef
no ip domain lookup
!
interface ATM0
no ip address
ip nat inside
ip virtual-reassembly
no atm ilmi-keepalive
pvc 0/33
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description ETHERNET
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
mtu 1488
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username xxxxxxxxx@xxxxx.net password 0 xxxxxxxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0

!
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload

!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 deny any
no cdp run
!
control-plane
!
!
line con 0
password 7 104D000A0618
login
no modem enable
transport output all
line aux 0
transport output all
line vty 0 4
privilege level 15
login
transport input all
transport output all
!
scheduler max-task-time 5000
end
 
Prueba con el comando "bridge" en la configuración del terminal y "bridge-group" en la interfaz.
Podría ser algo así:

Código:
conf t
bridge 1 protocol ieee
int vlan1
bridge-group 1

(El número que pongas en "bridge-group" tiene que ser el mismo que el que pones en "bridge", del 1 al 255).
 
Arriba