Problema WPA-PSK con Vista (Solucionado)

#1
Después de mucho navegar y mucho buscar he encontrado la solución a mis problemas con Windows Vista y la encriptación WPA-PSK del router.

Mis problemas con la conexión Wi-fi consisten en que si tienes una encriptación de la WLAN de WPA-PSK o WEP e intentas conectarte bajo Windows Vista configurado con WPA-Personal o Enterprise, no te deja conectar o si te deja pero se desconecta cada 1 o 2 minutos. Me fijé que esto con Windows Xp no me pasaba y navegando encontré la solución.

Resulta que Windows Xp y Windows Vista tienen una gestión diferente de la WLAN. En Windows Xp viene deshabilitado el BROADCAST DHCP y en Windows Vista no. Para deshabilitarlo en Vista solo hay que seguir los siguientes pasos:

En Windows Vista no viene deshabilitado el BROADCAST DHCP que en Windows XP sí estaba. Para solucionarlo, basta con seguir los siguientes pasos:

Meterse en el registro de Windows, dando al menú Inicio y en el recuadro de “Iniciar búsqueda” escribir regedit y ejecutar el programa (se pedirá confirmación de apertura como administrador).
Buscar la subclave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID} (para llegar, basta con ir abriendo las carpetitas con el nombre que hay entre barra y barra). Donde pone GUID será el numerajo perteneciente a la red inalámbrica (para saber cuál es, ir recorriendo todos los numerajos e ir viendo las IP’s que tienen asignadas; la que pertenezca a la red inalámbrica es la correcta).
Una vez estés en el GUID correspondiente, introducir el siguiente valor nuevo “Valor DWORD (32 bits)” con nombre DhcpConnDisableBcastFlagToggle e información de valor a 1 (por defecto se pone en 0, pero haciendo doble click se abre una ventanita donde se ha de cambiar a 1).

Más información en http://support.microsoft.com/kb/928233

Espero que os ayude como a mi. ;)
 
#2
WPA - PSK

Muchas gracias, a mí me ha funcionado perfectamente tu opción del registro para poder activar la seguridad WPA-PSK en Windows Vista, me estaba volviendo loca para conseguirlo.

Muy bueno
 
#4
xaviman dijo:
Después de mucho navegar y mucho buscar he encontrado la solución a mis problemas con Windows Vista y la encriptación WPA-PSK del router.

Mis problemas con la conexión Wi-fi consisten en que si tienes una encriptación de la WLAN de WPA-PSK o WEP e intentas conectarte bajo Windows Vista configurado con WPA-Personal o Enterprise, no te deja conectar o si te deja pero se desconecta cada 1 o 2 minutos. Me fijé que esto con Windows Xp no me pasaba y navegando encontré la solución.

Resulta que Windows Xp y Windows Vista tienen una gestión diferente de la WLAN. En Windows Xp viene deshabilitado el BROADCAST DHCP y en Windows Vista no. Para deshabilitarlo en Vista solo hay que seguir los siguientes pasos:

En Windows Vista no viene deshabilitado el BROADCAST DHCP que en Windows XP sí estaba. Para solucionarlo, basta con seguir los siguientes pasos:

Meterse en el registro de Windows, dando al menú Inicio y en el recuadro de “Iniciar búsqueda” escribir regedit y ejecutar el programa (se pedirá confirmación de apertura como administrador).
Buscar la subclave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID} (para llegar, basta con ir abriendo las carpetitas con el nombre que hay entre barra y barra). Donde pone GUID será el numerajo perteneciente a la red inalámbrica (para saber cuál es, ir recorriendo todos los numerajos e ir viendo las IP’s que tienen asignadas; la que pertenezca a la red inalámbrica es la correcta).
Una vez estés en el GUID correspondiente, introducir el siguiente valor nuevo “Valor DWORD (32 bits)” con nombre DhcpConnDisableBcastFlagToggle e información de valor a 1 (por defecto se pone en 0, pero haciendo doble click se abre una ventanita donde se ha de cambiar a 1).

Más información en http://support.microsoft.com/kb/928233

Espero que os ayude como a mi. ;)
Hola compañero gracias por el aporte, solo decir que te sigo hasta "Interfaces", posteriormente he encontrado en Interfaces un monton de carpetitas con diversos números. He mirado en cmd - ipconfig a ver cual corresponde a mi ip, pero no coinciden ninguno. No se porque razón, a ver si alguien puede echar un cable.

Gracias antemano.

Saludos
Juan
 
#5
Muchísimas gracias por esto, lo que había padecido yo con mi router 3com y el windows vista. Tanto que me había dado por vencido y estaba utilizando WEP con todo tipo de artimañas!!!
 
Arriba