Hackean repetidores WiFi de TP-Link: actualiza ya o te robarán tus datos

Redes

TP-Link es la marca que más repetidores vende de Amazon, con productos que tienen miles de reseñas en la tienda. Entre ellos encontramos los repetidores de la serie RE, como el RE365 o el RE650, que se encuentran entre los más vendidos. Ahora, esos repetidores se han visto afectados por una grave vulnerabilidad que los pone a merced de un hacker.

Algunos repetidores de la gama RE, afectados por una vulnerabilidad

Así, por muy seguro que sea el router que tengas en casa, añadir uno de estos extensores a tu red la convierte en vulnerable ante un hacker. Han sido investigadores de IBM los que han encontrado una vulnerabilidad crítica en estos dispositivos de TP-Link, la cual permite a un atacante tomar el control del amplificador de red.

tp-link repetidor wifi vulnerabilidad

Con ello, puede, entre otras cosas, redireccionar el tráfico mediante DNS a webs controladas por él que le permita robar las credenciales de acceso de los usuarios. De hecho, también puede redireccionar a otras páginas con malware que le permita tomar un control aún mayor de un dispositivo.

El atacante no necesita estar cerca del repetidor WiFi para aprovechar la vulnerabilidad (con código CVE-2019-7406), ya que se puede hacer de manera remota mediante un cambio en el encabezado de la solicitud HTTP al repetidor. Para ello, es necesario que el atacante conozca la dirección IP del extensor, algo que no suele ser muy difícil teniendo en cuenta la cantidad de direcciones expuestas que hay en páginas como Shodan.

Este tipo de ataques son los que luego acaban llevando a multitud de dispositivos a formar parte de botnets como la de Mirai, donde miles de ellos se utilizan para lanzar ataques DDoS que tumban servicios y páginas web con relativa facilidad.

Actualiza ya el firmware si tienes uno de los dispositivos afectados

Los modelos afectados son el RE365, RE650, RE350 y el RE500. El primero es el que los investigadores utilizaron para comprobar la vulnerabilidad, con el firmware 1.0.2, build 20180213 Rel. 56309. Después de avisar a TP-Link con el fallo, la compañía realizó unas pruebas internas y descubrió que también estaban afectados los otros tres repetidores. TP-Link ha parcheado la vulnerabilidad, por lo que os recomendamos que actualicéis de inmediato para estar protegidos ante este fallo. Este fallo se suma a otros descubiertos recientemente, como el que afectó a algunos routers ADSL hace menos de un mes.

Los firmwares para actualizar los extensores están disponibles en la página web en los siguientes enlaces: RE365, RE500, RE650 y RE350. Los RE350 y RE500 ya se encuentran descatalogados.

Escrito por Alberto García

Fuente > IBM