Página 1 de 1
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Sab 05 May, 17:57

Hola, he conseguido el Comtrend CT 5361 y quiero ponerle una toma USB para compartir el disco duro en red local.
De momento le he instalado el Poligon, concretamente la versión 1.10.08.011b (de aqui: http://www.adslzone.net/modules.php?name=Downloads&d_op=viewdownload&cid=89).

Después me he puesto a la modificación hardware tal y como se muestra en la tutoimagen:

Imagen

Solo he hecho las modificaciones de la parte de USB HOST, ya que es el que me interesa. La alimentación de 5V viene de una fuente de alimentación externa.

Soldaduras repasadas, comprobada correcta continuidad, etc etc.

Esto no hay manera de hacerlo funcionar.

Con el firm que expongo mas arriba tendria k funcionar no? o pongo otro firm?
La verdad es que me parece un firm un poco viejuno, del 2008, algó habra mas actual no?

Muchas gracias.
Avatar de Usuario
dopicom
ZoNeR@ habitual
ZoNeR@ habitual
 
Mensajes: 76
Registrado: Sab 28 Abr, 00:00

» Mar 08 May, 00:59

Hola:

Yo tengo uno como el tuyo y también estoy pensando en ponerle el USB.
Antes de eso he estado buscando firmwares que lo soporten, antes de hacerme caso en lo que expongo a continuación, espera unos días por si hay correcciones:

openWRT: Tiene soporte para USB, pero, no tiene drivers para el modem ADSL, es decir, que perderás esta posibilidad de conexión.

Bitswitcher: Si soporta el modem ADSL, pero, no tiene soporte USB. Aunque creo, es posible que no sea demasiado complejo compilar un BS con ese soporte.

Poligon: Creado por un forero, tiene todo pero su creador ha abandonado su desarrollo y no habrá nuevas versiones, una lastima :(
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 13:32

La verdad es que no lo quiero por el ADSL, sinó simplemente para poder tener un disco duro USB compartido en red local a través de elComtrend CT 5361.
Me dispongo a buscar el mencionado openWRT.
Muchas gracias por tu aporte e interés.
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 13:51

Madre de Dios!!!!!!!
Según la web de OpenWRT, para instalar dicho firm en mi Comtrend tengo que hacer birguerias!!!!!!!!!

Pagina oficial del firm para el CT-5361:
http://wiki.openwrt.org/toh/comtrend/ct5361

Descargar el firm y compilarlo con Linux, jopeta, eso si que me va a costar si (por no tener no tengo ni Linux instalado, madre mia!!!!):

http://wiki.openwrt.org/doc/howto/obtain.firmware

No hay archivos .bin por ahi que ya esten compiladitos? como Dios manda vamos, que sea actualizar y punto?

Muchas gracias de antemano!!!!!!!!
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 14:02

Madre mia!!!!!!!! voy a probar suerte, según la web: http://wiki.openwrt.org/toh/comtrend/ct5361, el firm que necesito (el archivo .bin, todo compiladito y apañao) es el openwrt-96348GW-generic-squashfs-cfe.bin, lo he buscado acá: http://downloads.openwrt.org/backfire/10.03.1-rc6/brcm63xx/, y me dispongo a su instalación, eso si, antes rezaré unas oraciones........ 8O .
Ya comento.
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 16:08

El firm funciona, y a la primera!!!!!!!
Lo que pasa es que no veo nada referente a USB, pongo unas capturas de las librerias (creo que se llama asi) que trae este firm.

Imagen
Imagen


Tengo que ponerle las librerias para el USB?
Estoy por meterle lo que aparece aqui dentro ( http://downloads.openwrt.org/backports/rc6/) que lleva en el nombre la palabra USB.

libusb_0.1.10a-1_mipsel.ipk 07-Nov-2006 06:56 9968

usbutils_0.71-1_mipsel.ipk 07-Nov-2006 07:09 76226

Librerias del 2006??? un poco viejunas no?

Gracias por todo.
Avatar de Usuario
dopicom
ZoNeR@ habitual
ZoNeR@ habitual
 
Mensajes: 76
Registrado: Sab 28 Abr, 00:00

» Mar 08 May, 16:14

Traktoret escribió:Madre de Dios!!!!!!!!

Traktoret escribió:Madre mia!!!!!!!!

Tranki, no cunda el pánico :)

No es tan difícil como parece, no hace falta compilar, sigue estos pasos:

1.- Supongo que has instalado el firmware y que además ya tienes conexión a internet con el router.
2.- Te conectas al cacharro, usando la interfaz web.
3.- Pinchas en la pestaña System y en la subpestaña Sofware.
4.- Pinchas en un botón que pone update list (o algo así) que esta por la parte superior.

Ahora ya se ha actualizado la lista de paquetes disponibles:

5.- Pinchas en la pestaña Avaliable Packages.
6.- Pinchas en la pestaña que tiene la letra K.

8.- Buscamos los paquetes que empiezan por kmod, que son módulos del kernel.

Necesitaras instalar al menos los siguientes:

kmod-usb-core
kmod-fs-msdos
kmod-fs-vftat
kmod-fs-ntfs
kmod-ide-core
kmod-usb-storage y kmod-usb-storage-extras
usbutils

Ahora en principio cuando pinchas el disco ya debería reconocerlo.
Prueba a conectarte por telnet o ssh y pon el comando lsusb.

Con esto, si funciona, el router reconocerá el disco que le conectes.
Aún falta, montarlo y compartirlo en red.

Un saludo
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 16:48

Muchisimas gracias dopicom.
Si, la opción esta de actualizar librerias la he visto, el problema es que no se como demonios cambiarle la dirección IP al router con este firm, ya que a mi internet me llega de un punto de acceso wimax que tengo en el tejado, y ese punto de acceso ya tiene la dirección 192.168.1.1.
Si pudiera cambiarle la ip al comtrend, actualizaria las librerias que dices me faltan, pero no tengo forma.

Gracias de nuevo.
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 16:50

Lo encontré, esta escondidillo todo en este firm eh!!!!!!!
Voy a actualizar libreriar a ver si peta el asunto, jejejejeje
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 18:12

dopicom escribió:
Aún falta, montarlo y compartirlo en red.



Ya tengo las librerias instaladas en el router.
Ahora me falta esto de montar y compartir en red.
Estas acciones las tengo que realizar en el router o en PC?

De momento en "Mis sitios de red" no aparece nada.

Seguiré intentando.

Nuevamente, gracias.
Avatar de Usuario
dopicom
ZoNeR@ habitual
ZoNeR@ habitual
 
Mensajes: 76
Registrado: Sab 28 Abr, 00:00

» Mar 08 May, 18:34

Traktoret escribió:Ya tengo las librerias instaladas en el router.
Ahora me falta esto de montar y compartir en red.
Estas acciones las tengo que realizar en el router o en PC?

Ok, vamos bien :)
Es hora de pinchar el disco usb al router y cruzar los dedos.
Para saber como ha ido el tema:
1.- Mejor apaga el router antes de pinchar el disco.
2.- Conectate al router, no por el interfaz web sino con telnet o ssh.
3.- lsusb (Este comando muestra los dispositivos conectados a los puertos usb)
4.- mount (Este comando muestra los discos montados en el sistma).

A ver si reconoce el disco.

Traktoret escribió:De momento en "Mis sitios de red" no aparece nada.

Aún no es momento de eso, primero tienes que conseguir que el router reconozca el disco y que este funcione.
Si esto va bien ya intentaremos compartirlo en red.
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 20:13

Te estaré eternamente agradecido dopicom!!!!!!!
Cuando un problema se soluciona, enseguida sale otro.

Voy a inicio -> cmd -> telnet 192168.1.11 (IP del Comtrend)

Me sale:

Conectándose a 192168.1.11... No se puede abrir la conexión al host, en puerto 23: Error en la conexión.

He buscado un poco por el foro y se dice que esto es por los firewalls en el PC. Pues los tengo todos apagados, incluso el de Win 7.

Que será que el router tiene el puerto 32 cerrado?
Via web entro perfectamente, puedo hacer ping perfectamente pero por telnet rien de rien.

Navegando he visto esta solución, pero para mi que es lo mismo que hacerle un reset con el pulsador y listo no?

hola a todos la SOLUCION ES LA SIGUIENTE. cuando al hacer ping al 192.168.1.1 te responde pero al entrar a telnet te rebota, entonces lo UNICO es que necesitas resetear LA CACHÉ DEL ROUTER, y eso se hace escribiendo el siguiente comando dentro del cmd: netsh winsock reset luego le dan ENTER y les da un mensaje confirmando q se reseteo la caché del router. AHORA SOLO QUEDA APAGAR EL ROUTER...15 SEGUNDOS....PRENDERLO Y LISTO....ya puedes entrar desde tu navegador con los datos que tu router tenia por defecto cuando te lo dieron.

Veo que la unica forma de que el router reconozca el disco duro o pendrive es via telnet verdad?
Voy a probar eso del ssh a ver que tal.

Todo esto es mas complejo de lo que pensaba.
Y no hay ningún tuto donde este explicado? lo digo por no darte tanto la vara, con la cantidad de tutos para instalar el conector USB que hay, y no aparece nada en lo que se refiere al software.

Si todo esto me sale bien creo que crearé yo mismo ese tutorial completito.

Muchisimas gracias por tu tiempo!!!!!!!
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mar 08 May, 20:45

Probando con este tutorialito (http://wiki.francofon.fr/index.php/Accueil_es/tuto_other_es/ssh_connect_es de ssh, parece k si k puedo entrar al router, pero una vez dentro, ni idea, los comandos lsusb y mount parece que no hacen nada.
Última edición por Traktoret el Mié 09 May, 12:28, editado 1 vez en total
Avatar de Usuario
dopicom
ZoNeR@ habitual
ZoNeR@ habitual
 
Mensajes: 76
Registrado: Sab 28 Abr, 00:00

» Mié 09 May, 00:10

Traktoret escribió:Provando con este torialito (http://wiki.francofon.fr/index.php/Accueil_es/tuto_other_es/ssh_connect_es de ssh, parece k si k puedo entrar al router, pero una vez dentro, ni idea, los comandos lsusb y mount parece que no hacen nada.

Hola de nuevo:
Vamos por partes:
> Me da la impresión de que no eras usuario de Linux, al menos hasta ahora.
El openWRT es una versión de linux. Si ya tuvieras práctica con linux todo esto te sonaría menos a chino :)

> En cuanto al telnet, debes saber que, una vez que le cambias la contraseña al router, este (el telnet) queda deshabilitado.
Desde ese momento, la única forma de acceder al cacharro es mediante ssh.
El tuto que has encontrado es válido.

> Los comandos lsusb y mount, así tal cual, solo muestran información.
Ejecuta además dmesg.
¿Puedes ponerme lo que sale en pantalla cuando los ejecutas?

En cuanto a lo darme la brasa, no te preocupes, todo esto me ayudará cuando yo instale el usb en mi comtrend.
Si todo sale bien el tuto lo podemos escribir entre los 2.
Y para despedirme, por ahora, una buena noticia.
He visto entre los paquetes de software de openwrt una utilidad para manejar los discos y sus comparticiones desde la interfaz gráfica.

Siento el tocho, un saludo.
Traktoret
Traktoret
ZoNeR@
ZoNeR@
 
Mensajes: 43
Registrado: Mar 01 May, 00:00

» Mié 09 May, 12:32

dopicom escribió:
Traktoret escribió:Provando con este torialito (http://wiki.francofon.fr/index.php/Accueil_es/tuto_other_es/ssh_connect_es de ssh, parece k si k puedo entrar al router, pero una vez dentro, ni idea, los comandos lsusb y mount parece que no hacen nada.

Hola de nuevo:
Vamos por partes:
> Me da la impresión de que no eras usuario de Linux, al menos hasta ahora.
El openWRT es una versión de linux. Si ya tuvieras práctica con linux todo esto te sonaría menos a chino :)

> En cuanto al telnet, debes saber que, una vez que le cambias la contraseña al router, este (el telnet) queda deshabilitado.
Desde ese momento, la única forma de acceder al cacharro es mediante ssh.
El tuto que has encontrado es válido.

> Los comandos lsusb y mount, así tal cual, solo muestran información.
Ejecuta además dmesg.
¿Puedes ponerme lo que sale en pantalla cuando los ejecutas?

En cuanto a lo darme la brasa, no te preocupes, todo esto me ayudará cuando yo instale el usb en mi comtrend.
Si todo sale bien el tuto lo podemos escribir entre los 2.
Y para despedirme, por ahora, una buena noticia.
He visto entre los paquetes de software de openwrt una utilidad para manejar los discos y sus comparticiones desde la interfaz gráfica.

Siento el tocho, un saludo.


Voy a probar a ver, primero probaré con el SSH y si no me aclaro mucho, reseteo al canto y entro por telnet, porque si lo reseteo se pierde todo, contraseña, ip, config wifi, .... Lo que no se es si perderé tambien los paquetes para controar el USB que le he instalado, todo es cuestión de probar, muriendo y aprendiendo!!!!
Muchas gracias, y de tocho nada hombre!!! jejejejeje
Un saludo dopicom!!!!
Página 1 de 1

Volver a Comtrend